6.6.414 = crash [6.6.416 released with a fix]

rr4242rr4242
edited May 2017 in Windows Beta

Today my 1P was auto updated to 6.6.414, and crashed - win10 only shows that I can close it. I uninstalled, and reinstalled 6.5.401. Got that to open normally. I then manually updated to 6.6.414 and got the same behaviour, crashing. I'm now back on 6.5.401.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • btw, if it matters... my chrome extension version for 1P is 4.6.6.1

  • Same here. Auto-updated and crashes on start. I downgraded and it works.

  • I was about to write the same :)

  • MikeTMikeT Agile Samurai

    Team Member
    edited May 2017

    Hi guys,

    Thanks for reporting this. We've disabled 6.6.414 beta update from the beta channel. You can download the previous update from here: https://cache.agilebits.com/dist/1P/win6/1PasswordSetup-6.6.407.exe

    Did you guys submit the crash reports? We don't see any submitted crash reports.

    Can you generate the diagnostics report and email it to us, it should include the recent crash reports. Please use this guide to generate the 1Password diagnostic report and email it to us at [email protected]. Also, in the email, include the link to this thread along with your forum username, so that we can connect the email to this thread.

    Let us know here when you've sent it, so we can confirm we got the email.

  • Same here; luckily I still had the installer for 6.6.407.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @XIII,

    Please email us your diagnostics report with the crash report as requested in the post above yours.

    For everyone else, the previous beta update is here: https://cache.agilebits.com/dist/1P/win6/1PasswordSetup-6.6.407.exe

  • MikeTMikeT Agile Samurai

    Team Member
    edited May 2017

    Just an update; we're looking into adding a crash detection process, so that if the auto-update has failed, it can help with reverting to the previous stable build.

  • All logging is dated before the update...

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @XIII,

    You don't see any crash reports at the very bottom of the diagnostics report? The general app logs won't have this but it should grab the recent crash reports from Windows' Event Logs.

    If not, please check the following:

    1. Click on Start Menu, search for "Event Viewer" and open it
    2. On the left sidebar, expand "Custom Views" on the top and then click on "Administrative Events"
    3. Reproduce the issue with 1Password if you can or look for any .NET/1Password crash reports.
    4. If you reproduce it, go back to the Event Viewer, right-click on the list to refresh. You should see errors from the source ".NET Runtime".
    5. Right-click on the error(s) to select "Copy > Copy Details as text".
    6. Paste it into a new text file with NotePad and attach it in your email to us at [email protected]. Be sure to include the link to this thread and your forum username.
  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    While we wait for you to send in the crash/diagnostics report, can you tell us what Windows version you're using?

    Can you install 6.6.414 directly and let me know if it is crashing? We're not able to reproduce any crashes just yet, so we need to figure out why it is happening.

  • I can't send an log because I can't go into 1Password, everytime it crash..

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @ShadowFM,

    Please do the following:

    1. Click on Start Menu, search for Event Viewer and open it
    2. On the left sidebar, expand Custom Views on the top and then click on Administrative Events
    3. Reproduce the issue with 1Password
    4. Go back to the Event Viewer, right-click on the list to refresh. You should see errors from the source .NET Runtime. Right-click on the error to select Copy > Copy Details as text.
    5. Paste it into a new text file with NotePad, save it and attach it to an email, send that email to us at [email protected] along with your forum username and the link to this thread, so we can connect the dots.

    Please let us know here when you sent it, so we can confirm we got the email.

    For now, reinstall previous beta update here: https://cache.agilebits.com/dist/1P/win6/1PasswordSetup-6.6.407.exe

  • MikeTMikeT Agile Samurai

    Team Member
    edited May 2017

    Hi @ShadowFM,

    Awesome, thank you! We got the email and will investigate it as you're the first one who sent it in. Please stay tuned, we may release a quick update to fix this.

    ref: MZH-75812-752

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    Can you update to this and let me know if it works: https://cache.agilebits.com/dist/1P/win6/1PasswordSetup-6.6.415.exe

    Thanks!

  • Hi @MikeT just mailed my crash log. Support ID is #JWN-69491-984.

  • Wow, just when I hit send, I saw the entry with the new version. 6.6.415 does not crash anymore. Great job

  • MikeTMikeT Agile Samurai

    Team Member
    edited May 2017

    That's great, thanks for confirming that for us. We didn't catch this in testing because it was specific to a system locale. Apparently, we don't have many non-English-US users on our team, so we'll need to fix that.

    We've just enabled the beta update now for everyone, 6.6.416 is now available.

  • MikeTMikeT Agile Samurai

    Team Member

    Also, thank you guys for reporting this to us so quickly. You're the heros of the day.

  • Btw. there was no auto-report of crash. Just kept asking to open in VS which would be meaningless.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Przemysław Klys,

    Thanks for letting us know. The crash was happening prior to the process that starts the crash detection method and that's what we're working on; to move it out somewhere where this type of earlier crashes can be detected and submitted to us.

This discussion has been closed.