enhanced connection vivaldi mac browser?

I've just installed the latest Vivaldi browser (1.9.818.50 (Stable channel) (64-bit)) on my macbook pro, and when I try to install the browser extension (and when I start the browser) I get the following message: 1Password requires an enhanced connection in order to communicate with your browser This happens when I try using the Beta browser extension as well as the stable one. Can you help me figure out how to make 1Password work with the latest Vivaldi? Thanks!


1Password Version: 6.8 Beta-5
Extension Version: Beta 4.6.7.2
OS Version: OSX 10.12.5
Sync Type: dropbox
Referrer: forum-search:vivaldi mac

Comments

  • brentybrenty

    Team Member

    @neatokino: Indeed, the latest Vivaldi still doesn't support Chrome's NativeMessagingHosts configuration, which 1Passwordfor Mac 6.8 (the beta you're running) needs to validate it for the new extension connection method. Just follow the instructions here to set it up for Vivaldi:

    If you see a code signature error in an unsupported browser, like Chrome Canary, Opera, or Vivaldi

    Vivaldi is my favourite browser as well, so I feel your pain. Hopefully they'll come along with that soon.

  • Thank you, that appears to have done the trick! Now I can happily continue with Vivaldi!

  • brentybrenty

    Team Member

    Excellent! Thanks for the update. You are most welcome! I enjoy me some Vivaldi too, and we'll continue to work with the browser vendors as we all make this transition to NativeMessaging. Cheers! :)

This discussion has been closed.