Hotkeys no longer work

Neither the hotkey for autofilling info or to open 1password mini work after updating to 6.6. Tried changing the hotkey, and changing keyboard layout to US, neither helped.

I've tried reinstalling the windows 10 app, and browser extensions, no luck.

The extension itself runs fine in chrome, also tried beta version in chrome.


1Password Version: 1Password 6.6.439d
Extension Version: 4.6.7.3
OS Version: Windows 10 1703
Sync Type: Not Provided

Comments

  • matthew_agmatthew_ag 1Password Alumni

    Hey @FallDown,

    Thanks for writing in and welcome to the Forum!

    • The first thing to double check is what is configured in your 1Password app's Options. You can check this by:

      1. Opening the main 1Password app and unlocking it.
      2. Then clicking the Settings Cog icon down the bottom-left and selecting "Options".
      3. Within Options, click on "General" on the left and you should see the Keyboard Shortcuts section.
      4. For me the shortcut to "Show 1Password Mini" is Ctrl \ to show when connected to a browser and Ctrl Alt \ when not.
    • If this matches what you see then the next thing to be sure of is that your \ key on your keyboard is mapped to the right character. You can check this by opening up Notepad and hitting the \ key on your keyboard. If you see the right character appear in Notepad then this is OK.

      If not then it's likely your keyboard layout settings. Sometimes as you guessed, the keyboard layout changes due to accidental keyboard shortcut usage (the "Change Keyboard Layout" keyboard shortcut in Windows 10 is Shift Left-Alt).

    • So if all the above matches my description and when you use Ctrl \ in your browser nothing is happening then it's likely the browser extension isn't connected to the 1Password app.

      You test this by clicking on the 1Password browser extension icon. What happens if you click on it?

    Looking forward to hearing back.

    Best regards,
    Matthew

  • Finnish keyboard layout does not have \ mapped directly, instead you have to press ctrl + alt + ? (see: https://upload.wikimedia.org/wikipedia/commons/thumb/3/35/KB_Finnish_Multilingual.svg/420px-KB_Finnish_Multilingual.svg.png)

    Regardless, this used to work. And even if I change my keyboard layout to US, and press the \ key, the hotkeys don't work.

    In my 1Password app, I see this: http://i.imgur.com/sMsR9JU.png and like I said, I tried using different keys, not just \

    What comes to the browser extension, clicking the icon opens up the mini version in the browser: http://i.imgur.com/nZkJDsT.png

  • matthew_agmatthew_ag 1Password Alumni

    Hey @FallDown,

    Thanks for checking all that. Since the 1Password Mini window is being displayed when you click the 1Password extension this proves that the connection between them is up and running. I also see that there is a Login item displayed which is an "Exact Match". If the keyboard shortcut was working and there was a log in web form on the page this should result in the page being filled without any 1Password Mini being displayed.

    Let's see if we can try a few other things to get that shortcut working again.

    Finnish keyboard layout does not have \ mapped directly, instead you have to press ctrl + alt + ?

    This is news to me, thank you for letting me know! It might be worth trying an alternative keyboard combination such as Ctrl < which as far as I can tell on the Finnish keyboard doesn't require any extra key presses I'm not familiar enough with it to be sure though. If you know of a better choice for a shortcut that would suit you please choose it instead.

    The next suggestion will seem silly but have you tried rebooting you Windows computer to see if that helps at all?

    If the above suggestions don't help could you please:

    1. Open your browser on a log in page for a website for which you have a Login in 1Password.
    2. Confirm once again that clicking the 1Password browser extension button opens the 1Password Mini and shows an exact match for the website.
    3. Close the 1Password Mini by clicking back into the browser window.
    4. Use the keyboard shortcut you have configured in 1Password's Options > General. This will fail as expected.
    5. Then create a Diagnostics Report using the instructions below.

      I'd like to ask you to create a diagnostics report from your Windows PC:

      Sending Diagnostics Reports (Windows)

      Attach the diagnostics to an email message addressed to [email protected].

      With your email please include:

      • A link to this thread: https://discussions.agilebits.com/discussion/79629/hotkeys-no-longer-work#latest
      • Your forum username: FallDown

      That way we can "connect the dots" when we see your diagnostics in our inbox.

      You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so we can track down the diagnostics and ensure that this issue is dealt with quickly. :)

    Once we see the diagnostics we'll be able to better assist you.

    Thanks very much!
    Matthew

  • Ta_HuTa_Hu
    edited November 2017

    hi @matthew_ag

    I have the same problem as FallDown. Have you found a solution for the problem after sending the diagnostics reports for windows?

    thanks already for your help.

  • brentybrenty

    Team Member

    @Ta_Hu: Never heard back from them. Additionally, it won't be the same problem, as this discussion is half a year old and a lot has changed since then. So, unless you're using very old versions of 1Password, the browser, and extension, this will be different.

    Unfortunately without some basic information it's hard to say what might be going wrong and how we might right it! Please tell me the OS, 1Password, browser, and extension versions you're using, the exact steps you're taking, and what is (or is not) happening the way you expect so we can figure out the best plan of action:

    Find your version

    The more information you can give, the better. Thanks in advance! :)

  • hi @brenty

    thanks for reaching out.

    I'm using windows 10, chrome, 1password 6.

    I made an update to 1password 6.6.439 last friday. since then, i can't start 1password mini with my keyboard combination. Changing the combination didn't help aswell. The browser extension works perfectly fine.

  • brentybrenty

    Team Member

    @Ta_Hu: 6.6.439 is very old. Please do the following:

    1. Remove the 1Password extension from Chrome
    2. Update Chrome: chrome://settings/help
    3. Install the latest version of 1Password: https://1password.com/downloads/
    4. Restart Windows
    5. Install the latest Chrome extension: https://agilebits.com/onepassword/extensions

    Let me know how you get along! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file