Read Only mode Safari extension

RJDRJD

Hi,

When you changed your business model, the safari extension showed the 'Read Only' message. After updating to the latest versions the issue was solved and everything worked fine for quite a while.

All of the sudden, after restarting my mac, the issue is back. I have no clue how to fix this, so please help.

Kind regards,

Ralph


1Password Version: 6.7 (670008)
Extension Version: 4.6.6
OS Version: OSX 10.12.3
Sync Type: Wifi

Comments

  • Drew_AGDrew_AG 1Password Alumni

    Hi @RJD,

    I'm sorry you're having some trouble with 1Password! If you're seeing a "read only" message, it sounds like you're using a copy of 1Password that you downloaded from the Mac App Store. The Mac App Store version of 1Password has been a free download since version 6.6 (released in February), but will be in read-only mode unless you paid for it on the Mac App Store before it became free to download, make a new in-app purchase for it, or sign into a 1Password.com account.

    Is it possible you bought a 1Password license from our AgileBits Store? If so, you must have recently switched from the AgileBits Store version to the Mac App Store version. A license from our web store won't work with the Mac App Store version of 1Password, so if that's what happened, you'll need to remove the Mac App Store version (drag 1Password.app from Applications to the Trash, but don't use any app cleaning tools) and reinstall the AgileBits Store version (available from our download site).

    On the other hand, if you previously bought 1Password through the Mac App Store, you may have recently re-downloaded it through a different Apple ID than the one you originally used to buy it. If so, you'll need to go to Applications and drag the 1Password.app file to the Trash (don't use any app cleaning tools), sign out of the Mac App Store and then sign back in with the Apple ID you used to pay for 1Password, and then reinstall it from the Purchased tab.

    Does that help? Please let us know how it goes, and if it's still a problem, we'll continue from there. Thanks! :)

  • Hi Drew,

    I purchased the app way before it came a free app from the Mac AppStore and i've been using one and the same Apple ID.

    Now, the scary thing is that the issue spontaneously disappeared. The only thing that happened that might have solved the issue is restarting my Mac.

    Regards,
    Ralph

  • Drew_AGDrew_AG 1Password Alumni

    Hi @RJD,

    Hmm, that's definitely strange, although I'm happy to hear the issue seems to have solved itself! It sounds like the app wasn't correctly reading the Mac App Store receipt. I think there was a small bug that caused a similar problem earlier this year (shortly after it became free to download) but that was fixed in an update, so I'm not sure if this was related to that.

    Hopefully it continues to work for you and doesn't revert to read-only mode again, but if it does, please let us know and we'll take a closer look into why that's happening. Cheers! :)

This discussion has been closed.