Firefox is not logging me on after auto-filling my username and password

Apologies if this has been discussed before, but I searched the forum topics and didn't come up with an answer.

I'm using the latest version of Firefox <54.0.1 (32-bit)> and noted from reading other topics that it is supposed to auto-fill and log you in immediately using this browser. I am using 1Password 6 (just signed up today) and have the 1Password Extension app extension 4.6.7 in place, although getting Firefox to recognize it at first was a challenge.

Anyway, when I click on the 1Password icon in the tool bar, it loads my username and password just fine for all my saved websites, but it does not log me on unless I click on the submit button. While this is a very small inconvenience, I would really like to get it to work as it should, so any advice would be greatly appreciated.


1Password Version: 1Password 6
Extension Version: 4.6.7
OS Version: Windows 7
Sync Type: Not Provided
Referrer: forum-search:Firefox is not logging me on after auto-filling my username and password


  • brentybrenty

    Team Member

    @PaKettle53: Which version of 1Password are you using? I wonder if it just needs to be updated — or you may simply have the automatic form submission disabled (under Settings in the extension). Without some basic information it's hard to say though. The more information you can give, the better. For instance, are you having trouble with specific sites? If so, knowing the URL will help. Often simply manually saving the login will save additional information that will allow 1Password to work. Thanks in advance! :)

  • edited July 2017

    I thought that maybe 1Password 6 and the fact that I signed up on July 6th was enough info, but I checked and the specific version is 6.6.439d. Sorry about that.

    So, I found the "Submit Logins" in Settings and it is now checked, but trying to log in to any of my saved websites, it still does not log me in without clicking on submit within the website itself.

    Since this is happening on all my urls and that would be way too many to post here, one example is this support group login:

    When I go to 1Password and sign in, then click on the AgileBits icon to load the website, it enters my saved user id and password, but it does not log me in. I have to click on "Sign In" to complete the process.

    I tried manually saving the login, but that gives me the same result.

  • Greetings @PaKettle53,

    Can you see if the following guide helps at all please.

    Turn off the built-in password manager in your browser

    By default Firefox has autofill enabled and as best I can tell from testing just now there are no clear indicators that Firefox has automatically filled fields as soon as the page has loaded. If it has this would interfere with 1Password's filling. When we find the field values already match what is contained in the Login item we won't touch that field. If we don't explicitly fill a password field we won't attempt to submit the page afterwards.

    I don't know for certain this is the cause but it's worth eliminating as a possibility. Do keep us informed :smile:

  • Thank you, littlebobbytables. That seems to have been the fix I needed.

  • beyerbeyer

    Team Member

    @Pakettle53: On behalf of @littlebobbytables, you're welcome! Please let us know if there's anything else we can help you with.

    Andrew Beyer (Ann Arbor, MI)
    Lifeline @ AgileBits

  • edited July 2017

    Thanks, beyer. I am finding it to work in most, but not all instances. For instance, the log-in url for Capital One is

    I've tried every way possible to get it to log me in, including creating a new log-in, but it will not even take me to the website as the url changes to:

    and doesn't progress to the site.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @PaKettle53 I'm guessing that you're using Firefox with the multi-process feature enabled. This is not compatible with our current extension and we are working hard to get a compatible version out in the very near future. Open and fill from the main app or the URL button in the item's details in 1Password mini is the one area where 1Password has issues with the new multiprocess approach in Firefox.

    In the meantime, open and fill from 1Password mini's search results should work for you. Bring up 1Password mini (I use the keyboard shortcut, Option-Command-\) and search for "capitalone". When your Login is highlighted, simply press return and 1Password will open and fill for you.

    Let us know how that works for you!

    Jamie Phelps
    Code Wrangler @ AgileBits
    Fort Worth, Texas

  • Thanks, Jamie. I'm not sure if I understand what 1Password mini means. I tried the 1Password 6 extension in the web browser and like you said, it doesn't fill in. I also tried using the web version and that doesn't work either. It doesn't work from the phone app either.

    I might just have to wait until your updates get done to sort this out. It's not a huge problem since it only occurs with two of my saved websites, so only a minor inconvenience.

  • Hi @PaKettle53,

    When we talk about 1Password mini it's because we're so familiar with 1Password for Mac; 1Password mini is the term for the helper process and to put it into context, any time you are interacting with a 1Password menu while in your browser it's the helper process rather than the extension. Our actual extension has no UI (User Interface) of its own and instead is merely a bridge between the browser and 1Password.

    What Jamie missed from your first post was that you mentioned Windows 7 meaning you're referring to 1Password 6 for Windows rather than Mac. Again, it's a mistake a few of us have made because we're so used to the Mac.

    Can you tell us what happens if you try the following.

    1. Manually visit in Firefox.
    2. Click on the 1Password Browser Extension button in Firefox and select your CapitalOne Login item. Another way to do the same thing is with the keyboard shortcut ctrl + \ on Windows.

    Do the fields fill?

  • Brilliant! Thanks!

  • matthew_agmatthew_ag 1Password Alumni

    Glad littlebobbytables was able to help! Please let us know if we can be of further assistance.

    Best regards,

This discussion has been closed.