A bug in the 6.8 update installer

romadromad Member

I use Carbon Copy Cloner so I have an external hard drive with a clone of my internal drive. However, the 1Pwd 6.8 installer has a bug in it that prevented me from updating my internal system hard drive from 1Pwd 6.7.1 to 1Pwd 6.8 and demanded I trash the copy of 6.7.1 on my backup clone. The installer should have either ignored the copy on the clone backup drive (as it apparently did my TM backups) or it should have identified all updatable copies of 1Pwd, and then let ME choose which one to update.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: forum-search:Spinning beachball, slow Finder response after updating to 1Pwd 6.8

Comments

  • rudyrudy

    Team Member

    Hi @romad,

    While it is a bug, its not with the updater, that is behaving as designed. Unfortunately the sheet it is presenting to you is a workaround for an OS level bug with the process responsible for launching all other processes, launchd. It will quite regularly and spectacularly fail to properly launch the correct 1Password mini. If the mini it launches is a different version than the main application then it will most definitely crash when trying to communicate with it. The other side effect of launchd's absentmindedness is that multiple copies being installed will cause it to fail to launch mini at all, leaving you with no access to your data.

    Rudy

  • romadromad Member

    Once I had updated my internal drive to version 6.8, I restored the 6.7.1 version to the clone. When the scheduled CCC task is run tonight, then the clone should also have the 6.8 version on it. In the future, I won't move the clone version to the trash when I update the internal drive, but rather just unmount the external clone drive. Of course, I still have various versions of CCC on my TM drive, the oldest being 1Pwd 3.4.7.

  • dancodanco Senior Member Community Moderator

    If you're happy having the clone drive unmounted, that should work fine.

    An alternative is to set up CCC (or SuperDuper, for anyone who is using that) not to copy 1PW. You could always redownload 1PW to the clone drive if needed. Or you could keep a zipped copy of 1PW and allow that to be copied to the clone.

    Note that it is only the PROGRAM that causes problems if it is copied to the clone drive. The DATA can (and should) be copied.

  • rudyrudy

    Team Member

    @romad and @danco,

    We really wish launchd worked better but we are actively working on a solution that minimizes launchd's absentminded impact.

    rudy

  • romadromad Member
    edited July 2017

    danco, the clone drive will be unmounted ONLY when I update the internal drive with a new 1Pwd version. Once the update is finished, then the clone will be remounted. Having 1Pwd 6.8 installed and running on the internal drive after I restored 1Pwd 6.7.1 to the clone drive yesterday afternoon worked just fine. Also, as I expected, when the CCC Scheduled Task ran last night, it replaced 1Pwd 6.7.1 on the clone drive with a clone of 1Pwd 6.8.

    Oh, BTW, the whole IDEA behind cloning your primary drive is so you DON'T need to reinstall all of your applications, documents, settings, etc.

  • dancodanco Senior Member Community Moderator

    Yes, of course, one doesn't WANT to have to reinstall anything.

    Unfortunately the launchd bug (which does apply to other programs, as noted in the CCC manual) means that having two copies of 1PW around can cause trouble. It's an Apple bug, which they haven't bothered to fix.

    Sorry I misunderstood you about unmounting. I think there is a "proceed anyway" button. As far as the update itself is concerned there's no issue in doing that. But trouble is likely further down the line.

    Best advice, then, is still not to copy 1PW to the clone but to copy a zipped version. That way it's only a few seconds to install if needed.

  • BenBen AWS Team

    Team Member

    I believe danco's advice here is spot on. If there is anything else we can do, please don't hesitate to contact us.

    Ben

This discussion has been closed.