PIN unlock?

SystemSystem

Team Member
This discussion was created from comments split from: Feature Request - Bring Back the PIN Code access.

Comments

  • The PIN code option for IOS has disappeared from Security > Settings with the last update. I am now required to enter my (long and complicated) master password, instead of the PIN code, every time I start the app. "Lock On Exit" is, and has always been. turned off. AutoLock after 15 minutes is turned on as there is no "never" option. Same problem with both my iPhone (6+) and my new iPad Pro 9.7". I have submitted this to support through the app, but the automated reply isn't any help either. Please restore the PIN code option (my preference) or add a "never" option to Autolock.

  • BenBen AWS Team

    Team Member

    Hi @DearlG,

    Sorry to hear about the trouble here. I see you also emailed us. Just for future reference it isn't necessary to contact us both via email and here in the forums. Doing so causes a duplication of efforts, and slows down the support process for everyone. :)

    But since I have you here now let's see what we can figure out.

    You mentioned you have an iPad Pro and an iPhone 6 Plus. Both of these are newer devices that support Touch ID. If you have Touch ID enabled on the device 1Password will not offer the option to set a PIN, but can be set to unlock with Touch ID:

    Use Touch ID to unlock 1Password on your iPhone or iPad - 1Password Support

    We have no plans to offer PIN unlocking on devices that have Touch ID enabled. If you'd like to unlock 1Password with a PIN you'd need to disable Touch ID on your device (Settings > Touch ID & Passcode).

    I hope that helps. Should you have any other questions or concerns, please feel free to ask. Thanks!

    Ben

    ref: LVP-39545-721

  • Thank you for your reply, Ben. I do not have touch-I'd enabled on either device. My fingerprints are mostly not consistently readable due to injury, age, etc. Point is that the PIN code option was available in the past, and I used it, and the option has now disappeared.

  • BenBen AWS Team

    Team Member

    Thanks, @DearlG. Could you please take a screenshot of the 1Password > Settings > Security preference pane and post it here for us?

    ▷ How to take a screenshot in iOS

    After you've taken the screenshot you can see how to post it using this illustration:

    Thanks.

    Ben

  • BenBen AWS Team

    Team Member
    edited July 2017

    Thanks, @DearlG. 1Password thinks you have Touch ID enabled, even if this is not the case. Can you please double check the settings in the Settings app under Touch ID & Passcode and make sure nothing relating to Touch ID is enabled?

    If that is already set correctly, I'd like to ask you to create a diagnostics report from your iOS device:

    How to send a 1Password diagnostics report - 1Password Support

    Please add the following code (including the square brackets) to the subject of your diagnostics email before sending it:

    [#LVP-39545-721]

    This will link your diagnostics to our current discussion. We'll take a look and let you know what we find out.

    Ben

  • Ben...I checked the IOS touch-ID settings on both devices. There are (were) fingerprints stored from previous attempts to use this feature on both devices and in various apps. I deleted the stored fingerprints on both devices and returned to 1Password settings and the PIN code option has become available again and all appears well at this point. The fingerprints have been stored for quite some time now and I turn off the option in various apps as needed.
    Not the expert here, but it appears that a bug has slipped into 1PW to cause it to now behave this way.

    Thank you for your help.

  • BenBen AWS Team

    Team Member

    Thanks for the update, @DearlG. I suspect just the opposite: if you have fingerprints stored in iOS 1Password is intended to not allow the PIN, so it sounds like we fixed a bug. ;) Glad to hear removing the fingerprints has got this working for you as you'd like.

    Have a great weekend!

    Ben

  • Prolly correct on fixing a

  • Reply was truncated. Oh well...it's working.

  • BenBen AWS Team

    Team Member

    Excellent. :+1: :)

    Ben

This discussion has been closed.