Mac App Store Version now in Read Only Mode

Today I reinstalled 1PW on my wife's computer. We own it from a "family sharing" purchase from 2012. When she runs it, it shows "read only mode."

Deleted it and went back to the app store. This time went to "purchases" and clicked the family member who bought it and loaded it from there. Still in "read only mode."

Also, I can see in the app store under "purchases" that 1PW is also listed as purchased under my wife's account with today's date. Could that be part of the problem?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • I have this same problem, on my partner's new MacBook Pro. I've also tried removing the BOM and PLIST files in /var/db/receipts but the app still thinks we don't have a purchased license.

  • Same problem here. Just migrated to a new MacBook Pro. 1password shows 'read only' in the right corner.
    It still works on the old MacBook Pro.

  • bundtkatebundtkate

    AgileBits Team Member
    edited July 25

    Hey @Chris100! Apple doesn't allow sharing of in-app purchases, so you'll need to be signed in to the Mac App Store with the Apple ID used to purchase it when you download and install the app. Since it sounds like you can access the Apple ID used to purchase 1Password, we can fix this:

    1. Make a backup of your data from "File > Backup" from the Menubar in 1Password
    2. Quit 1Password and 1Password mini with the Control-Option-Command-Q keyboard shortcut.
    3. Go to the Launchpad app to view your list of apps and hold the mouse or trackpad button down on the 1Password icon until the icons "jiggle" and delete 1Password by clicking the black circle with the x in it on the top left corner of the 1Password icon (don't use any app cleaners, such as CleanMyMac. Just delete it the regular way so as to not risk losing your 1Password database as well).
    4. Reboot the Mac, then open the App Store app and sign out of the Apple ID account you're using and then sign into the account you used to buy 1Password
    5. Reinstall 1Password from the Purchases tab in the Mac App Store.

    It only matters which Apple ID is signed in when 1Password is downloaded and installed, so once you've reinstalled with the Apple ID used to purchase, you can feel free to swap back. :chuffed:

    @benjaminchait and @Sylvester : If you were both also installing 1Password while signed into the App Store with an Apple ID other than the one used to purchase 1Password, the above should work for you as well. That said, there are other issues that can lead to read-only, so if either of you is using the purchase Apple ID or if you cannot access the Apple ID used to purchase 1Password, let us know. :+1: :

  • Chris100Chris100
    edited July 24

    Hey, I will try the suggestions, but note that when I bought this years ago it was not an in app purchase. That's why I'm confused about this happening. Via family sharing, it should have simply installed it in full functional mode.

    I get that your suggestion should have her up
    and running. Yes, I can log in as the user that originally purchased the app.

    But I didn't really want to do this because then my wife will be prompted for that user's password each time there is an update. Since we use 2-factor, this could also become onerous for her.

  • bundtkatebundtkate

    AgileBits Team Member

    Hey @Chris100! We do understand it's a bit of a fuss, but since Apple sets these rules and the switch to an in-app purchase was necessary to support some new features, we don't have the ability to differentiate based upon when you purchased 1Password. :frown:

    If you're open to using 1Password downloaded directly from us instead, once you've installed from the proper Apple ID, you can follow these instructions to swap over. This "version" of 1Password can read your Mac App Store receipt (which you'll have updated by installing from the proper Apple ID) and will allow your wife to avoid having to enter your Apple ID password to update the app in the future.

    Regardless, I do apologize for the hassle. One peril of ongoing development is you can't always predict what challenges the future might bring. I hope the additional steps above help limit the hassle for you down the road. :chuffed:

  • Is there a difference? My son 'installed' the app at first time through a family shared Apple ID. So his Apple ID is connected to my Apple ID. My Apple ID is the one that was paying for it, if you understand... :)
    So which one should I use? The first installer or the one who 'payed' ?
    If I should install with his Apple ID, what will happen with my data? Is 1Password going to use also his data from his iCloud because it's installed with his Apple iD?

  • beyerbeyer

    AgileBits Team Member
    edited July 28

    @sylvester: In your scenario, on your son's Mac, you should do the following:

    1. Copy the username and password of the Apple ID that was used to purchase 1Password from the 1Password app (if needed).
    2. Remove the 1Password app (leave the 1Password extension and data intact).
    3. Launch the Mac App Store and select Store (from the menu bar) > Sign out.
    4. Select Store > Sign in. Enter your Apple ID and Password (that made the original purchase).
    5. Reinstall 1Password from the Purchased tab.
    6. (optional) Switch to the version of 1Password from the AgileBits website, to allow for updating without needing your Apple ID.

    The Apple ID you use to install applications from the Mac App Store is different from the Apple ID used for iCloud (in System Preferences), therefore, following these steps won't have any negative impact on your or his data.

    I hope that helps. If you have any additional questions, please let us know.

    --
    Andrew Beyer (Ann Arbor, MI)
    Lifeline @ AgileBits

  • Beyer, thank you. That the trick!
    Also the optional 5 is working well.

  • I think Beyer's Step 1 should be open 1Password and copy/paste the Apple ID password into notes needed for Step 3 (which I forgot to do, sigh). Thanks for the process, it worked for me, the other Apple ID is my wife's ID as part of my Apple Family plan id's (long story) if that makes any difference. What's interesting is I have never deleted the 1Password app but after signing out from my wife's ID and back on with my ID and then updating 1Password from the MAS 1Password went read only. I'm wondering if this will happen again with the next MAS update.

    Bill

  • beyerbeyer

    AgileBits Team Member

    @Sylvester: You're welcome!

    @wgkrueger: You bring up a great point about copying out your Apple ID, I apologize for not thinking about that. I've updated my post, for the next person that comes across it.

    I'm not an expert on how the MAS caches receipts, but in my experience, they last for quite a while. This shouldn't be a process that you need to do for every update. However, I'd be very interested to hear about how this works out for you on future updates.

    I hope you both have a great weekend! :)

    --
    Andrew Beyer (Ann Arbor, MI)
    Lifeline @ AgileBits

  • Thank you for the help, @bundkate. (great screen name, btw). In addition to the MAS license, I also have family licenses for the mac and windows versions from the Agilebits store. So I solved my wife's problem by transitioning her to the Agilebits store license.

    I bought all these different licenses because I wanted to throw some extra cash your way.

    So having said that, it should be clear that I am a fan and a strong supporter or AgileBits and and advocate for 1Password. Please take the following comments in that spirit:

    • I am really disappointed that I had to transition my wife away from the MAS store. She now gets updates in a manner that is different from most of her other updates. She really preferred receiving them from the MAS store notifications, rather than the big popup dialogs from the AgileBits Store version.

    • I understand that there are limitations in terms of what Apple allows you do do when you change your business model from outright purchase to in-app purchase. But I feel like the "family sharing reinstall" use case could have been foreseen, and probably could have been solved for in some way (eg multiple versions).

    • As I have said, I am a fan and an advocate. When this kind of experience generates problems for someone like me, what does it say about the process for the population at large? I hope that future transitions will be thought out more carefully, and that AgileBits can solve for scenarios in ways that are not disruptive (even it takes more work).

    Again, I love AgileBits, and I look forward to paying for a V7 upgrade to help keep you in business. Just disappointed by this bump in the road.

  • rudyrudy

    AgileBits Team Member

    @chris100,

    I want to correct some false information that was provided earlier in this thread. If you purchased 1Password prior to the introduction of the In App Purchases then it should have indeed worked.

    If you have two linked Apple IDs under Apple's Family sharing, and you click the person selector on the Purchases tab in App Store.app and use that "download" button to download 1Password then it should work. You should not have to sign in with different Apple IDs as long as you've linked them under Family Sharing

    If you had instead just gone to the App Store.app and searched for 1Password and then clicked the Get button then it wouldn't work. This is definitely a limitation in the way the store/Family sharing works and it catches a lot of people off guard.

    Family sharing is only possible for the prior direct purchase users and unfortunately the standalone IAP is not transferrable in this manner.

    Rudy

  • Chris100Chris100
    edited August 15

    @rudy:

    If you have two linked Apple IDs under Apple's Family sharing, and you click the person selector on the Purchases tab in App Store.app and use that "download" button to download 1Password then it should work.

    As mentioned in my original post, after doing it the wrong way the first time around, I did try this.

    I deleted the app and went back to the MAS, installing from the appropriate family member under "purchases." It remained in read only mode.

    My assumption is there is some kind of prefs file or license file lying around that is left over from my first attempt, which needs to be cleared out. (Along the lines of what @benjaminchait said he tried in post 2,)

    If anyone knows what that might be, I would most appreciate it. I would very much like to get my wife back to the way she is used to receiving her updates -- from the Mac App Store,

  • rudyrudy

    AgileBits Team Member

    @chris100,

    The MAS receipt primarily exists inside the binary, typically /Applications/1Password.app/Contents/_MASReceipt/receipt the Store itself writes that file and if absent will cause the OS to prompt you to sign in with your Apple ID.

    Rudy

  • I guess that won't help then, since I deleted it before reinstalling from the proper user under purchases. Am I completely out of luck here?

  • JacobJacob

    AgileBits Team Member

    @Chris100 Ah thanks for letting us know. You're not out of luck. :) I'm going to reach out via email and get you one last option. Talk to you soon.

    ref: WCF-22169-876

  • Hi Jacob, I made the same mistake. Installed under my own App Store account instead of the family organiser. Now getting read only even after deleting and installing again after selecting the family organiser. Is it possible to delete my own purchase from the App Store? Please advise.

    Thanks

    Roger

  • LarsLars Junior Member

    AgileBits Team Member

    Hi @Remainer -- sorry for the delay in our response here. There's a couple of possibilities here, so bear with me a bit. For a few years, 1Password was a paid app at the Mac App Store. If your family organizer purchased 1Password during those years, then you should be able to share it by downloading from the family organizer's link. To do that, you'll have to go to the Purchased tab in Mac App Store (after signing in), then switch the drop-down menu at the top from My Purchases to whatever the family organizer's name is and download from their purchase history, you should get the full, unlocked app.

    However, if your family organizer purchased 1Password after we switched to an IAP model, it won't matter. Apple doesn't allow Family Sharing with IAPs, so you would need to either sign up for a 1password.com membership (one of your options), or make an individual purchase within 1Password. Do you know which is the case for you? You should be able to tell the exact date your family organizer bought or downloaded 1Password for Mac, right in their purchase history in the Mac App Store.

  • Many thanks Lars

    Yes, we did purchase 1Password as a paid for app. I am the organiser. The problem though is that when setting up my wife's account on her new MacBook we made the mistake of first getting the app under her own account. This is all discussed in the thread above. Even after deleting the app and installing again, this time switching to my account as you explain, the app still only works in read-only mode. Presumably this is because it is still shown as a previous purchase under her own account.

    I have asked Apple if her purchase can be "refunded", hoping that would fix things, but have not heard back yet. Apple support said I should "reach out" to you. Since the thread shows that you have had to help others with this situation recently, I was hoping for a solution from you.

    Roger

  • LarsLars Junior Member

    AgileBits Team Member

    @Remainer -- I've sent you out an email; let's continue this conversation there, if you don't mind. If you don't see it, please check your Spam/Bulk folders, as sometimes overzealous junk filters can mark unsolicited email from our domain as spam (the nerve! ;) )

    ref: ALL-88191-214

Leave a Comment