Network issues caused by use of loop back 127.0.0.1 1password -- Chrome extension

Is there a way to change 1 password's use of 127.0.0.1 to a different localhost: 127.x.x.x ?

"1Password communicates with its browser extension through web sockets over localhost (127.0.0.1), and sometimes apps related to network connections (VPN, proxy, firewall, etc) can block that communication, depending how they are set up."

While this article flips through an option, is it possible to just switch the IP address?

FWIW this localhost conflict is my guess as to what causes chrome to misbehave in this thread.

We've found conflicts with PLEX server, VPNs, etc. Seems this localhost address is getting over crowded.


1Password Version: 6
Extension Version: 4.6.7.90
OS Version: windows 10
Sync Type: Not Provided

Comments

  • bundtkatebundtkate

    Team Member

    Hey @SamLabrador! Using localhost is a pain, which is one reason we're moving away from it. 1Password shouldn't need localhost any longer when used in Chrome. You can enable native messaging in Chrome by checking Enable Native Messaging for Chrome under Settings > Options > Advanced.

    Are you currently having a particular problem using the 1Password extension in Chrome? If so, I'd first give the above a try (making sure to restart Chrome after enabling the above setting) and, if you're still having issues, share any details you can so we can better help you sort things out. :chuffed:

  • Can not find "Native Messaging" to "enable" anywhere in Chrome.

    The problem we are having is with a non responsive Chrome extension. On-click produces no response on some computers -- they have localhost apps/services which cannot deleted.

  • bundtkatebundtkate

    Team Member

    @SamLabrador My apologies for the lack of clarity. This setting needs to be enabled in the 1Password desktop app, not in Chrome itself. This takes localhost out of the equation, so you should be able to avoid the issues you're having by using Native Messaging instead, but let me know if you're still having trouble. :chuffed:

  • Enable Native messaging was/is checked. Problem persists.

  • MikeTMikeT Agile Samurai

    Team Member
    edited July 2017

    Hi @SamLabrador,

    In that case, the issue is not with localhost/127.0.0.1 as we no longer use that. Please use this guide to generate the 1Password diagnostic report and email it to us at [email protected]. Also, in the email, include the link to this thread along with your forum username, so that we can connect the email to this thread.

    Let us know here when you've sent it, so we can confirm we got the email.

This discussion has been closed.