Mac Chrome extension stopped working

The 1Password extension stopped working. I've tried reinstalling it multiple times and restarted the Mac. Clicking on the light-gray icon always shows this window:


1Password Version: 6.8 (Mac App Store)
Extension Version: 4.6.7.90
OS Version: OS X 10.12.5
Sync Type: iCloud

ref: IPK-48524-816

Comments

  • Make sure you relaunch chrome. Click on Chrome --> About Chrome. You will get this if Chrome is updating/updated, but did not relaunch. I was having the same issue.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Hey, @thomas88. Sorry for the trouble you're having. We have a fairly lengthy delay when the extension loses the connection to the main 1Password application since the main reason this might happen is when there is a 1Password update in progress and we want to give it time to complete before we attempt to reconnect.

    If you wait about 20 seconds, you should see the button come back alive. If it continues to disable itself, it might point to a problem with the connection. Could you let us know what version and distribution of Chrome you're using—stable, beta, Canary, or something else?

    Thanks!

    --
    Jamie Phelps
    Code Wrangler @ AgileBits
    Fort Worth, Texas

  • Hey @jxpx777. Thanks for the reply. Do I need to do anything while waiting for the connection? I tried unlocking the 1Password application and keeping it open, as well as keeping the extension open. Also just to clarify - this is not a problem that I have sometimes or that it looses the connection - the extension never connects to the application. I think this started after an update of 1Password. Versions are:

    1Password Version: 6.8 (Mac App Store)
    Extension Version: 4.6.7.90
    OS Version: OS X 10.12.5
    Sync Type: iCloud

    Let me know if you need more details.

  • Also thanks for your suggestions @SDRacerR1. I've just tried restarting Chrome again, but unfortunately it doesn't help in my case.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Hey, @thomas88. Not sure if you missed this from my post before:

    Could you let us know what version and distribution of Chrome you're using—stable, beta, Canary, or something else?

    If you're not sure, you can check in Chrome > About Google Chrome. For instance, my copy of Canary shows this:

    Version 62.0.3169.0 (Official Build) canary (64-bit)

    while the stable build shows this:

    Version 59.0.3071.115 (Official Build) (64-bit)

    Let us know what you find. :)

  • Sorry, thought I mentioned the Chrome version in my previous comment. I'm using the regular Chrome download - so stable.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    And have you quit and relaunched Chrome?

    If so, I'd like to ask you to create a diagnostics report from your Mac:

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    • A link to this thread: https://discussions.agilebits.com/discussion/80555/mac-chrome-extension-stopped-working
    • Your forum username: thomas88

    That way we can "connect the dots" when we see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so we can track down the diagnostics and ensure that this issue is dealt with quickly. :)

    Once we see the diagnostics we'll be able to better assist you. Thanks very much!

  • Yes, I tried quitting and relaunching Chrome. Also tried restarting Mac completely. You've got the diagnostics report in Support ID #UXY-62713-363. Thanks!

  • jxpx777jxpx777 Code Wrangler 1Password Alumni
    edited July 2017

    Thanks, @thomas88! I just sent you a reply. I think we're on our way to solving it. :)

    ref: IPK-48524-816, OPM-5215

  • Thanks @jxpx777, it's working again :) For others reading this: The issue was that I was using 1Password from the Mac App Store, but Chrome installed as a Homebrew Cask. This led to 1Password being unable to validate the code signature of Chrome (as it's outside of the /Applications folder). Options were to move Chrome to the /Applications folder or switching to the non-Mac App Store version of 1Password.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Glad that worked for you, @thomas88! :+1:

  • Hi,

    I have the same problem with 1Password Chrome extension stop working, and I get it every couple of days. I can certainly restart Chrome, but I have a ton of tabs and windows am working on, and it gets annoying after a while. I now use a Chrome extension manager utility to unload and re-load 1Password, and it works most of the time but I am getting tired of this and would really would like to get to the root cause of this. Do you have any suggestions?

    I am running MacOS 10.13, Chrome Version 62.0.3202.62 (Official Build) (64-bit) and 1Password 6.8.2 003

    Thanks,

    Carl

  • Hi @cgadener,

    We've released version 6.8.3 of 1Password for Mac which includes a significant improvement to the connection between 1Password and the extension. Can you update please and see if the issue persists.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file