1PW does not come to front when first launched

I know that this is minor but it's annoying. On the mac and in v4 when 1pw is launched for the first time it comes to the front so you can enter the password - but no longer. It starts hidden in the background and requires an alt-tab or task bar click to get at it.


1Password Version: 1Password 6.6.439d
Extension Version: Not Provided
OS Version: w10 - 64
Sync Type: Not Provided

«1

Comments

  • MikeTMikeT Agile Samurai

    Team Member
    edited July 2017

    Hi @DoctorDan,

    Thanks for reporting this.

    Can you update to 1Password 6.7 and let me know if it is better, we had some focusing issues that has been improved in the 1Password 6.7 update.

    Also, how are you launching 1Password, is it via start menu or from the notification area?

  • Updated just now. The installer wreaked havoc on the system. First time it froze with explorer killed. Second time it launched 1pw which stayed "not responding" till I logged off again. Third time it installed but app still launches (from quick launch bar) in the background.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @DoctorDan,

    I'm sorry to hear that, the installer has been tested with a lot of users over the past month and it hasn't caused any issues like that.

    Can you confirm what anti-malware solution you're using?

    From quick launch bar? Do you mean the taskbar or the extra toolbar you've added to the taskbar?

  • Avast
    extra toolbar you've added to the taskbar from %APPDATA%\Microsoft\Internet Explorer\Quick Launch

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @DoctorDan,

    Can you check the shortcut’s launch arguments of 1Password you’ve added to Quick Launch, it may have /silent added at the end, which means it will launch straight to the notification area, instead of showing you 1Password.

  • C:\Users\essin\AppData\Local\1password\app\6\AgileBits.OnePassword.Desktop.exe

    I don't keep the notification area visible. I just use quick launch. It always used to come to the front whenever I clicked on quick launch. Now it still does but not on first launch.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @DoctorDan,

    Do you have 1Password app set to start itself after signing into Windows?

    I'm not able to reproduce it, it always launch on the first click in Quick Launch no matter what.

    You're using Windows 10 Creators Update?

  • Yes to autostart

    version: 2017-07 Cumulative Update for Windows 10 Version 1703 for x64-based Systems (KB4025342)

  • GregGreg

    Team Member

    Hi @DoctorDan,

    Could you please try rebooting into Safe Mode with Networking and see how 1Password behaves in there? Here's how:

    Start your PC in safe mode in Windows 10

    Does the issue remain? Please let us know.

    Cheers,
    Greg

  • yes, the issue remains. Also, when not is safe mode, it rejects my master password on the first attempt and sometimes on the second attempt. This is a new behavior.

  • bundtkatebundtkate

    Team Member

    Hey @DoctorDan! For what it's worth, I was just able to get 1Password to immediately minimize after launching from Quick Launch, but only once so far. I have some thoughts I'll share with the team when everyone is back in on Monday to see if we can't figure out how to do it more consistently. One theory is that this is related to another issue we already know about, so to make sure I'm covering my bases on that point, where do you have your taskbar located? Top or side of your screen by chance? Do you have any programs pinned to your taskbar or do you only use Quick Launch? This will help me make sure I'm working with the same setup you're using and, if I'm right, location of icons matter.

    Thanks! :chuffed:

  • It's on the bottom, double height (to accommodate 2 rows on the Quick Launch).

    Also, the recent problem of getting it to accept my master password extends to the browser extension. I'm not sure what is going on because, even it I slowly and deliberately type the characters one at a time, it still rejects it on the first, and sometimes on the second, attempt.

    I don't know if the two issues are related but the both appears at about the same time.

  • bundtkatebundtkate

    Team Member

    Thanks for the extra details @DoctorDan! I can still only reproduce the issue with 1Password going into the background intermittently, but knowing how you're set up will certainly help and I'll have some assistance tomorrow when our development team is back.

    My instinct says the issue with the Master Password is unrelated, but instinct isn't always trustworthy, so I'll reserve judgment until we can get a better idea of what's causing the problem. Did this issue persist when you were testing in Safe Mode as well?

  • If it's any help. I have noticed lately that other things, that seem to me to coded as non-modal dialogs, seem to have trouble coming to the front, even in some MS apps. For example, I just asked Vivaldi to check for updates and the dialog telling me that I was up to date remained in the background, hidden by several other windows.

  • I've also noticed a couple of times that after launching 1PW it will appear for a split second in the foreground and then recede to the background.

  • There was a suggestion in a different forum about apps opening in the background that it might have something to do with checking for updates that causes it to move to the background while waiting for the check to complete. Another suggestion was to disable SuperFetch (which I don't know to much about). I will give that a try.

  • bundtkatebundtkate

    Team Member

    @DoctorDan: Do let me know how you get on with these other ideas, but we also just released a small update with a fix for the issue I felt might be related. I just spent some time mucking around with the latest build and I'm personally no longer seeing this occur, so please also update and let me know if you find 1Password is still moving to the background. For me, it seems to be sticking 100% of the time now when opening from quick launch. Thanks! :+1:

  • Thanks, I'll work on it later today when I get off the Mac and onto the Windows machine.

  • bundtkatebundtkate

    Team Member

    Sounds good, @DoctorDan. Look forward to hearing results. :chuffed:

  • Same thing with and without superfetch

  • you mentioned a new build but I don't think I know how to get it. The test I made turned out to be with the same version that I already had.

  • bundtkatebundtkate

    Team Member

    Hey @DoctorDan! It may have auto-updated in the background all sneaky-like, but just in case, you can manually check for updates. Go to Settings (cog wheel) > Options > Update and click the Check for Updates button. The build you want is 6.7.457. :+1:

  • I don't know if this was ever resolved for DoctorDan, but I have it as well on Windows 10 (64-bit) when starting 1Password for the first time after starting my PC. I have 1Password pinned to my taskbar and launch it from there. It will show up in the foreground for a split second before disappearing (minimizing). It is quite annoying and has been doing this for months now. I'm on 6.7.457.

  • Hey @freeAgent! I don't know if this was resolved for DoctorDan either, but I do know that I was no longer able to reproduce his problem on 6.7.457. Of course, that doesn't mean something similar couldn't have popped up in some other fashion. This is going to sound piddly, but if it's the same sort of issue, I promise it really does matter: where do you have 1Password pinned on your task bar (ie -- right next to the start icon, 4 icons over, etc.) and where is your task bar docked (top of screen, left side, etc.)? If you'd like to drop a screenshot of your task bar, that'll work too. It's entirely up to you. I just want to pin it in the exact same spot and see if I can reproduce this on my end. Thanks! :chuffed:

  • Sure, I have my taskbar along the bottom of my screen. 1Password is in the middle of my pinned programs (everything from the left all the way over to IE is pinned).

  • @freeAgent: No dice reproducing this on my end. Does this happen every single time you launch 1Password from the task bar, or only intermittently? Also, do you use any anti-malware software on this PC beyond Windows Defender, by chance? If so, could you let me know what AV you have? Thanks!

  • I believe it happens every time on this PC (my work laptop). I don't restart my home PCs nearly as much, so I'll keep an eye on it/test and get back to you. I believe it happens every time on this PC. If not, it's very, very frequent. As far as security software goes, it's just running Defender. There's not much going on software-wise on this PC beyond what you see on the taskbar already :smile:

  • @freeAgent: You mention not restarting often at home -- does that mean you don't have 1Password set to launch on startup (Settings > Options > General > Start 1Password automatically when I sign in to Windows) on the problematic PC? As you may be aware, once 1Password 6 starts, it keeps running in the background, even if you close the main window, so when you click your taskbar icon, the only time it's actually launching is the first time after you restart and, even then, only when you have this setting disabled. Are you only having this issue when you're using the task bar icon to launch 1Password 6 following a restart, or is it happening every time you open the main window, whether the 1Password 6 process is already running or not? Apologies for the interrogation, but I want to make sure my efforts to reproduce this were in the right environment. :+1:

  • 1Password is set to start with Windows on my work machine, but I don't believe it prompts me to log in when it starts (or opens any windows on my desktop). I sometimes open it using the taskbar shortcut after/during startup to retrieve passwords from the application. The problem only occurs on the first time I open the application following a clean restart of my work PC. I'll just go ahead and restart now to verify this is all true and update you. I may even see if I can record a video screen capture.

  • @freeAgent: If you catch this in time, check your task manager for 1Password processes as well before clicking the task bar icon. If 1Password isn't launching properly on startup, that could be a clue. :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file