Website Issue (Synapse doesn't work)

STR:
1) Open https://www.ricardo.ch/de/login?return_url=https://www.ricardo.ch/MyPages/Summary.asp
2) Fill out forms through 1Password Extensions

Issue: Username (E-Mail oder Benutzername in German) is not filled in if you use the Browser Extensions.

My second issue is that I can't use 1Password Synapse as I always get the follow error when I press Report Website Issue in the Browser Extensions.


1Password Version: 6.8
Extension Version: 4.6.9.1
OS Version: MacOS 10.13 Beta (17A315i)
Sync Type: Dropbox

Comments

  • Hello @heubergen,

    Can you try creating a new Login item please using the steps outlined on our page How to save a Login manually in your browser. These are the steps I followed for testing and it filled both fields for me. My hope is you find a new Login item works for you as well.

    With regards to Synapse, could I ask what browser you were using please, I suspect that might be behind the error message.

  • Hello @littlebobbytables,

    Creating the login again seems to work - at least I can now fill the login again at the website.
    But there's a very strange behavior with the new login item:

    It seems like no username was saved but when I try it, the username is filled in >_< .
    Is there any logical explanation for this?

    About Synapse, I'm currently use Firefox Nightly 56 with the beta Webextensions.

  • Hi @heubergen,

    I'm not sure I'd want to use the word logical but there is an explanation :tongue: When a Login item is saved inside the browser we store a number of details about every field and if things match later, we use these details to fill the fields. Along with this, at the time of saving we do try to identify which fields may represent a username and the password. Now why this page confused 1Password I'm not sure but we can manually correct its mistake.

    1. Edit the Ricardo New Login item.
    2. Click the show web form details button.
    3. You will see a field as having been identified as the password field by the silhouette of a key in the final column.
    4. Flag the (obvious) username field by selecting the silhouette of the person for that row.
    5. Save.

    You should now find that it always displays the username and password at the top of the item and it will continue to fill properly. At first glance 1Password should be identifying that field correctly so I'm not sure why it isn't.

    The web form details is also what allows a Login item to fill more than just the username and password. So if you ever have a 3+ field form to fill but wonder where 1Password is storing those details its in here.

    Thank you for letting us know about the browser, we'll have to see why that isn't working.

  • Hello @littlebobbytables,

    Thanks for the explanation, something more I learned today :)

  • If I was helpful then I'm happy @heubergen :smile:

  • Synapse is still broken. I can't submit reports for broken websites (aa.com)

  • brentybrenty

    Team Member

    @wandy_applesood: I think maybe you mean "it's broken again". This is a rather old forum discussion. ;)

    In all seriousness though, can you tell me where you're running into trouble? I just sent a test report for aa.com and it worked, so I'm probably missing something. Thanks in advance! :)

  • Synapse is down still, for me.

    Submitting a report (just did it again right now) only gives me the following:

    Oops, something went wrong.

    Please make sure that you:

    attempt to fill an item first and then report the issue second.
    use the Report Website Issue option in the 1Password extension or in 1Password mini.
    update to the most recent version of 1Password for Mac or 1Password for Windows Beta.
    To learn more, please check out our guide on reporting website filling issues.

  • LarsLars Junior Member

    Team Member

    @wandy_applesood -- I was just able to both successfully fill the American Airlines site as well as successfully submit a dummy Synapse report for it. It sounds as if you may be experiencing something related more specifically to your individual setup. Have you followed those steps in the error message? Did you try to fill first, then make the report? Are you using the current version of 1Password (6.8.4 for Mac)? Have you tried restarting your computer?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file