How to move 1P data from old Snow Leopard to clean install Yosemite?

I'm moving from Snow Leopard (10.6.8) where I use 1P v3.8.2 (build 32010) and doing a clean install of Yosemite (10.10.5).

Does 1P4 work in Yosemite? Your downloads#legacy_versions page says 1Password 4.4.3 is for OS X 10.9 Mavericks and 10.8 Mountain Lion, but does NOT say 10.10 Yosemite.

Hoping it does, I've downloaded 1P4 in Snow, but hesitate to try and use it in Snow in case it screws things up. Where do I pay for 1P4 and how much does the non-subscription upgrade cost? Your pricing page only sells a 1P6 subscription for a year at $35.88 every year yet I recall paying $19.95 for the 1P3 upgrade which was the same as my original 1P2 price....

Since there's no Sync in Preferences in 1P3, I presumably use 1P3 > file > export ... 1PIF then presumably 1P4 has file > import. Check?

Any other considerations for this upgrade?

Thanks in advance for your help. warm regards, Cris


1Password Version: 1P3 and 1P4
Extension Version: Not Provided
OS Version: 10.10.5
Sync Type: Not Provided

Comments

  • brentybrenty

    Team Member

    I'm moving from Snow Leopard (10.6.8) where I use 1P v3.8.2 (build 32010) and doing a clean install of Yosemite (10.10.5). Does 1P4 work in Yosemite? Your downloads#legacy_versions page says 1Password 4.4.3 is for OS X 10.9 Mavericks and 10.8 Mountain Lion, but does NOT say 10.10 Yosemite.

    @lifestrateg: Correct. While 1Password 4 may work in Yosemite, it isn't supported there, and you'll run into issues with browser integration with the legacy version. You can find more details in the pinned thread in this forum category:

    1Password 4 legacy support information

    Hoping it does, I've downloaded 1P4 in Snow, but hesitate to try and use it in Snow in case it screws things up.

    It won't screw anything up; it won't run except on Mountain Lion or Higher.

    Where do I pay for 1P4 and how much does the non-subscription upgrade cost? Your pricing page only sells a 1P6 subscription for a year at $35.88 every year yet I recall paying $19.95 for the 1P3 upgrade which was the same as my original 1P2 price....

    We stopped selling 1Password 4 years ago, so it isn't possible to purchase that version. You do, however, get 1Password 6 (which supports Yosemite and higher, along with current browser releases) as part of a 1Password.com membership. You may want to consider that since it also includes all of the other apps, the web interface, and does away with license management and sync configuration altogether — you simply login to your account to authorize a device and access your data. You can also try it for free for 30 days to take advantage of all of its benefits](https://support.1password.com/why-account/). When you sign up, just shoot us an email at [email protected] and post the Support ID you receive here so we can see what we can do for you as an existing customer to help.

    Since there's no Sync in Preferences in 1P3, I presumably use 1P3 > file > export ... 1PIF then presumably 1P4 has file > import. Check?

    Definitely don't export to plaintext unless you absolutely have to. Newer versions of 1Password can read your existing vault from 1Password 3 (AgileKeychain) directly, so there's no work involved there. The new app will almost certainly open it right up when you install and run it.

    Any other considerations for this upgrade?

    The main issue is that upgrading from one legacy version to another isn't going to get you very far and probably cause a lot of undue pain and frustration. Definitely backup everything before doing the OS upgrade!

    Thanks in advance for your help. warm regards, Cris

    Any time! I hope this helps. Be sure to let me know if you have any other questions! :)

This discussion has been closed.