iOS 11 Beta 4 not following “Require Master Password”

I have my “Require Master Password” set to “After Device Restart”, and yet it has been asking for my Master Password after every long-period of non-use.

Lemme know if I need to send anything special, log-wise.

Thanks!

Comments

  • sjksjk oversoul

    AgileBits Team Member

    Hi @jpartain89,

    Which iOS device type(s) are you seeing this behavior on, and are they all running version 6.8 of 1Password for iOS?

  • iPhone 7 Plus, 6.8 (680005) 1Password.

    It specifically happens on the share sheet extension for Safari, because I just opened the app directly and it ran TouchID.

  • Same here, iPhone SE with 1pw 6.8.

  • MrRooniMrRooni

    AgileBits Team Member

    Thanks folks, we've received other reports of this as well. Have you seen this behavior continue with iOS 11 beta 5?

  • Not yet.

  • rudyrudy

    AgileBits Team Member

    @sniem,

    Thanks for your report. We will investigate.

    Rudy

  • So, as of the last 1Password beta update, the specific setting for this specific issue is completely missing, and my app is constantly locking back to my MasterPassword rather than TouchID

  • And now to add insult to insanity? I just restarted my phone bc of other, iOS beta issues, the Security Option in the Advanced menu page has now reappeared.....

  • MrRooniMrRooni

    AgileBits Team Member
    edited August 25

    Hey there @jpartain89. Thanks much. I've seen this behavior as well. Can you get me a diagnostic report so I can check on the errors we may have gotten back from Touch ID?

    Sending Diagnostics Reports (iOS)

    Attach the diagnostics to an email message addressed to support+forum@agilebits.com.

    With your email please include:

    • A link to this thread: https://discussions.agilebits.com/discussion/80874/ios-11-beta-4-not-following-require-master-password
    • Your forum username: jpartain89

    That way we can "connect the dots" when we see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so we can track down the diagnostics and ensure that this issue is dealt with quickly. :)

    Once we see the diagnostics we'll be able to better assist you. Thanks very much!

  • Good morning to ya @MrRooni !

    The Support ID number I got back is XNK-99461-817

    And, to make everything EVEN MORE weird? Ever since I performed that last restart of my iPhone? 1Password has not forced a MasterPassword entry on me yet....

    The new iOS beta is really confusingly... unstable is the only word that comes to mind....

  • This bad behaviour is back with Beta 6 on my iPhone SE, too. Do you want another report?

  • MrRooniMrRooni

    AgileBits Team Member

    Got your DR, @jpartain89. I see this particular bit in the logs:

    Touch ID evaluation returned an error: "Biometry is locked out."
    

    This means that Touch ID has failed to recognize your fingerprint enough times in a row that it's locked you out from unlocking with your fingerprint at all. Were you able to unlock your device with your iPhone with your fingerprint during this time?

    Regardless, it explains why a reboot fixed it, because you are forced to enter your PIN code upon reboot which unlocks Touch ID as well.

  • The way I understood that specific process was that when your fingerprint failed too many times, ALL you had to do was input your pin code on the lock screen, thus re-activating TouchID for the next round.

    Plus, all of that should be completely negated in relation to using TouchID in 1Password because you already unlocked your iPhone. Therefore, the process above of inputting your pin code would've unlocked the ability to use TouchID.

    But, before the reboot, as I said in a prior comment, the Advanced Settings option for when your Master Password was required was completely missing....

  • MrRooniMrRooni

    AgileBits Team Member

    The way I understood that specific process was that when your fingerprint failed too many times, ALL you had to do was input your pin code on the lock screen, thus re-activating TouchID for the next round.

    This is absolutely correct.

    Plus, all of that should be completely negated in relation to using TouchID in 1Password because you already unlocked your iPhone. Therefore, the process above of inputting your pin code would've unlocked the ability to use TouchID.

    One would think so, I agree.

    But, before the reboot, as I said in a prior comment, the Advanced Settings option for when your Master Password was required was completely missing....

    One of the things we do before even showing that option is settings is asking if the device supports Touch ID. The "biometry locked" error kicks us to a state where the answer to that question is "no". I'm going to kick this question around with the team here and see what we can come up with.

  • AGKyleAGKyle AgileSupport

    AgileBits Team Member

    Some further information here.

    Biometric lockout can happen after you unlock your device. I've been working on a fix around the Biometric lockout and 1Password, and the way I've been testing this is to create a new Note in the Notes app, setting it up with a password, and then making Touch ID fail on that until it asks for the passcode for the note. At this point I can cancel and 1Password will then prompt for Master Password.

    In a future update this will inform you that you need to lock your device, unlock with your device passcode and Touch ID will be available again. This also needs to pass through our security team as well, so it's subject to change.

    But the point of that is that you can cause biometric lockout after you've unlocked your device. So if 1Password is encountering that error from Touch ID then you're failing Touch ID at least 5 times in a row in some other application and then opening 1Password.

    Admittedly 1Password does not handle this very well in the current form, but hopefully that helps explain why that biometrics lockout is potentially being encountered.

  • So, now that I'm armed with @AGKyle's information about the 5 time rule, I can safely state that that has never actually happened to me while I was using my iPhone.

    1password would always unlock through TouchID with, at most, 1 failure. And 1Password is the only app I use regularly that utilizes TouchID, therefore, unless the 5 strike rule adds up in between LockScreen lock/unlocks, (which, even then my TouchID failures wouldn't have been able to accrue in that manner, simply due to limited use), something wonky is throwing in a wrench....

    I think I just found a spot in the Extension Section of my logs that is when my original reported error occurs.... Between the block ENDING Aug 23 13:11:48 and beginning Aug 23 21:20:01. It pops with Lock mode changed (4): 'MasterPassword'.

  • AGKyleAGKyle AgileSupport

    AgileBits Team Member
    edited August 25

    @jpartain89

    It's possible you're encountering both a bug and the biometry being locked out.

    Unless there's a bug in iOS that's causing the biometry to become locked you are somehow triggering it as the error for that comes from iOS, not 1Password. From our side, all we do is ask iOS if Touch ID is available basically, it reports back with a success or failure, and if failure what the reason was. Your diagnostics report is showing the failure and the reason being biometry being locked. In this case we just dump the error to the log file, there's no determination on our end about what the error is, we just report the exact error we got.

    Now, that's not to say that you're always encountering this error. But I do see it having occurred 12 times in the report you sent. So, it feels pretty likely that you may be encountering it more often than not.

    Note that the extension and the main app share state. So if the extension opens and Touch ID is not available, it will effectively behave the same way in the main app, and vice versa.

    Currently in the shipping version of 1Password, if Biometry is locked out it will force 1Password to ask for the Master Password.

    What might be helpful for us is if you can recreate the problem and send a report immediately after. Also if you can note the time on the device that this occurred, it would mean we could look at the logs specifically around and before that particular time to try to piece together what might have happened.

    That said, I am sorry you're encountering trouble. As someone who does a bulk of the work in this area of the application I'm never happy when I see bugs or issues in this area of the application because it's probably the result of my work and they're never pleasant issues for our users.

    ref: XNK-99461-817

  • @AGKyle Now that I'm fully armed with all of this information, including the refresher on grabbing the logs and what not, if/when this issue occurs again I'll definitely be ready....

    But, as of now, since these errors aren't showing their ugly heads, I know I personally am more apt to push this issue onto an error in iOS itself.

    And as far as the Advanced Menu option disappearing, I would honestly have to assume that iOS wasn't even pushing out that TouchID was an option at all, therefore 1Password wouldn't have a reason to show that menu option. Though, if TouchID collapsed at that level, thats a bit of a catastrophic failure on the OS's part.

    And as far as the apology, honestly, the fact that FOUR of you guys were a part of this thread is just the start of the litany of reasons why I am obsessed with 1Password and AgileBits as a company.... Other than Waze, 1Password is the ONLY other Application/Service that I push onto anyone who will ever listen. And I consider it a privilege to be able to send you guys these weird, fringe occurrences, not only so its fixed but this way, we all end up learning a ton...

    But, beyond all this, kudos to @AGKyle for the simple fact that I haven't had any issues regarding TouchID and 1Password until I was on iOS 11 Beta.... To have a crazy error pop ONLY on a beta, in my mind is kinda the hallmark of an amazing developer, to have millions of calls to your code and its completely seamless... Keep it up!

  • AGKyleAGKyle AgileSupport

    AgileBits Team Member

    Hi @jpartain89

    Thanks for the kind words and for being so understanding. It's kind of what I needed today, from the bottom of this developer's heart, thank you.

    If you have any questions along the way do reach out. But hopefully having some more information on how it works and how it behaves you'll be able to spot something of interest next time it happens. That's the hardest part about providing support really, taking the information we know and distilling it in a way that our users can take that information and use it to help solve the problem. I'm happy to help, and it would be a great perk if it means we've found a bug that needs to get fixed.

    Keep in touch and thanks again for being so willing to help out here. If I don't hear from you today please enjoy your weekend!

  • brentybrenty

    AgileBits Team Member

    @jpartain89: At the risk of being a fifth wheel here, I did want to share my own experience in case it is somehow applicable to you or others as well.

    I regularly get locked out of Touch ID on my iPhone 6S. I love the newer generation (second?) Touch ID sensor because it's so fast...but due to (I think) the combination of this super sensitive sensor and (apparently) some fairly thin pockets (I love these pants), it's seemingly getting triggered in my pocket rather frequently. So more often than not this affects 1Password as well.

    Now you may simply be running into a bug with iOS 11. Since it sounds like this is a fairly recent development for you, I'm willing to concede that. But I did want to share this since Kyle's excellent explanations reminded me of that. Cheers! :)

  • doetraardoetraar Junior Member

    For what it is worth, I too have this issue, but, only on my iPhone 7+. On my iPad (also running the iOS 11 beta), the TouchID unlock works reliably. On the iPhone, however, it will ask for my Master Password nearly every time. For a day or so, by changing the timeout period from one hour to 30 minutes kept 1Password working with TouchID as I'd expect, but, that, too, ceased working -- no other apps are having issues with TouchID, the device is not restarting, and normal unlock of the device works. Just seems to be that 1P on this beta gets wedged into the state of not requesting TouchID and requiring the Master Password.

    I can live with it for now, but, given the length and complexity of my Master Password, it is a little on the frustrating side to enter it several times per day.

  • I've sent in my diagnostics, the ID is [#LTX-67654-666]

  • brentybrenty

    AgileBits Team Member

    @doetraar: Thanks for the feedback on this. I admit it drives me nuts too when I run into similar issues. We'll get to the bottom of this!

    @sniem: Thanks! I see that we've received your email, so we can continue the conversation there. We'll take a look at the diagnostics and get back to you shortly! :)

    ref: LTX-67654-666

  • Ok, so for - sadly, incredibly literally - the first time since I reported this I can, 100% without a doubt, say that this time that 1password failed to present touchID to me, I neither had ANY failed TouchID instances system-wide, nor had I performed a restart, nor have I triggered any other type of instance that would have normally stopped the TouchID from being presented....

    I did send in my logs IMMEDIATELY afterwards, like, thats the first thing I did after inputting my 1password:

    MUK-73852-289

    Happened before 8:45 am on Sept 26, 2017. (Thats the timestamp on my email sent for the diagnostic logs...)

    If anything more is needed... I have Xcode installed along with my iPhone linked in Xcode, so I'm able to grab the logs off the device... So, if there is a specific log I could try to find, the log files are not being deleted.. But I can at least try to find that extra item for y'all... Because this is frustrating and I adore helping y'all...

  • brentybrenty

    AgileBits Team Member
    edited September 26

    @jpartain89: Awesome! Thank you! Same here. Happened to me today, after updating iOS on my new phone. I've restarted it and we'll see what happens in my case, and see if we can gain some insights from your logs. I see that Andrew already replied without context, so I've added notes there in case we need to follow up with you. Definitely hard to tell sometimes with issues like this if our minds are playing tricks on us. ;)

    ref: MUK-73852-289

    ref: OPI-4149

  • brentybrenty

    AgileBits Team Member

    Closing this discussion, as it isn't related to the beta in any way.

This discussion has been closed.