1Password button in Firefox greyed out not working

SystemSystem

Team Member
This discussion was created from comments split from: Chrome browser extension on Mac not working.
«13

Comments

  • Exactly the same problem in Firefox. 1Password plug-in completely broken. Greyed out and cannot be clicked. Also the 1Passord Mac top Menubar doesn't recognize the websites, so it is of little help. I have to manually alt-tab back and forth with the 1Password application to copy and paste logins etc.

    Broken as of this morning CET. Worked fine yesterday.

    Firefox 54.0.1. MacOS Sierra 10.12.6. 1Password plugin last updated August 8th (today; automatic) plugin version 4.6.9.

    Things still in Safari however (may be not yet updated or something, don't know, as I normally only use Firefox except for a few things).

  • edited August 2017

    Hi,

    Based on a solution that was published a few months back, I tried this and it worked for me, as I had the same problem:

    • Quit the 1Password app with the Ctrl key pressed
    • Restart the Mac
    • No step 3

    Hope this helps.

  • Thanks LeFrenchFab, but that didn't solve my problem. Tried that. Also tried various reboots and reinstalling the addon, but problem persists. :(

  • Ah! Turns out the problem was solved when I updated 1Password from 6.6 to 6.8

    For some reason automatic updates was turned off and I hadn't got any notifications about need to update.

    Case closed as far as my problem goes.

  • Just had the exact same problem. As it happens, I did exactly what LeFrenchFab did, and all is working fine now.

  • brentybrenty

    Team Member

    @assai_puppet_wean, @scottwoz, @LeFrenchFab: Sorry for the hiccup there! Most folks won't notice, but a fairly large change has happened with 1Password to support browser integration going forward behind the scenes, so you will need to be on the latest version of 1Password, the browser, and extension for all of them to be compatible with each other. Glad that updating did the trick for you. We're here if you need anything else! :)

  • edited August 2017

    It didn't work for me. :( The app, the extension and firefox are all fully updated, I quit 1password with the control key pressed, restarted the mac, reopened firefox, and the extension looked like it was coming in black, but it switched to grey. In fact it's switching back and forth from black to grey right now . . . but landing on grey every time. Boo.

  • BenBen AWS Team

    Team Member

    Hi @BlueskySusan

    I'm sorry to hear about the continued trouble. :( I'd like to ask you to create a diagnostics report from your Mac:

    How to send a 1Password diagnostics report

    Please add the following code (including the square brackets) to the subject of your diagnostics email before sending it:

    [#JRN-48231-327]

    (Please note this support ID is for @BlueskySusan only)

    This will link your diagnostics to our current discussion. We'll take a look and let you know what we find out.

    Thanks!

    Ben

    ref: JRN-48231-327

  • I am using 1Password 6.8-680015, FireFox 54.0.1 with 1Password std and beta extension - on latest Mac 10.12.6. 1Password button is grey... no way to activate it. Before I got "authorization" prompt, but it is not coming. Is there a way to manually trigger it. Or is there another way? Thank you.

  • Hi, I have the exact same problem: Everything up to date, button is grey.

    Firefox: 55.0
    1Password extension: 4.6.9
    1Password: 6.8 (680014) – AppStore version

    When I deactivate the extension and activate it again, the button is active for about one second.
    After a second – or as soon as I try to click on the button – it is greyed out.

    If I open 1Password Mini (in the menu bar), it suggests »Install Firefox Extension …«.
    Everything did work fine until yesterday. I don’t remember changing anything.

    Best regards, Martin

  • sjksjk oversoul

    Team Member
    edited August 2017

    Hi @tomtomm and @mby,

    Sorry for the trouble you're having with the 1Password extension in Firefox. The disabled toolbar button is because the extension can't connect to the app. First, could you try simply quitting and reopening Firefox? If that doesn't help, then give this a try:

    1. Quit Firefox.
    2. Open 1Password and click the 1Password menu. Hold down the Control and Option keys on your keyboard. While holding the Control and Option keys, select “Quit 1Password and 1Password mini”.
    3. Open 1Password again.
    4. Open Firefox again.

    And if it's still not working after that, restart your Mac and give it another try.

    Please let us know how that goes for you.

  • Hell sjk,

    just executed the 4 steps; during FireFox restart, the button is active for part of a second, then it gets inactive. Restart did not change the reaction.

  • one note: I use Cookie v 5.5.8; for Safari, there is a browser extension favorite entry; for Firefox this option is not available...

  • sjksjk oversoul

    Team Member
    edited August 2017

    Hi @tomtomm,

    Drat, sorry that didn't work - thanks for trying! Let's move this into email with more details. Please start by creating a diagnostics report on your Mac using the 1Password Troubleshooting tool:

    How to send a 1Password diagnostics report (Mac)

    Then add the following code (including the square brackets) to the subject of your diagnostics email before sending it:

    [#QNT-36345-951]

    (please note: this support ID code is only for tomtomm)

    After receiving your email we can better assist you with getting this sorted out. Thanks in advance!

    ref: QNT-36345-951

  • Hi sjk,
    same as with @tomtomm:
    Restart of apps as well as restart of the computer didn’t change anything.
    For me actually this is not a big deal. I only need one password in Firefox.
    So I saved it in Firefox.

  • sjksjk oversoul

    Team Member

    Hi @mby,

    Sorry the restarts also weren't enough to get it working for you. If you'd like to send a diagnostics report we wouldn't mind doing further troubleshooting. You'll receive an automated reply from our BitBot assistant with a support ticket ID. If you post that ticket ID here we can track down your email and figure out how to properly resolve this. Who knows, you might want to use 1Password with Firefox in the future even if you can get by without it right now. :)

  • ForrestForrest Junior Member

    Yup. 1P is kaput in FF 54.0.1 and FF Developer Edition 55.0b14. Tried everything here.

  • sjksjk oversoul

    Team Member

    Hi @Forrest,

    We've also received your email about this issue so let's keep the conversation going there. Cheers! :)

    ref: XXI-83931-516

  • essiecabessiecab Junior Member

    I'm also having the exact same problem, I have FF 54.0.1 and 1Password manager/wallet 4.6.9 running Mavericks. It was working fine just a day ago (I do have verify browser code signature unchecked and was still able to fill things in yesterday)

  • brentybrenty

    Team Member

    @essiecab: Definitely update Firefox, as 55 is current now. However, 1Password 4, which is the highest version you can use on Mavericks, is not compatible with the new extension, as it was discontinued years ago. Please see this thread in the legacy category for 1Password 4 for more information on all of the issues you'll be facing there:

    1Password 4 legacy support information

    But you can find a temporary workaround here for this particular issue here:

    Firefox and 1Password 4

    Just be aware that this problem isn't going to go away, and it will only get worse and 1Password, macOS, and Firefox continue to move forward together. :(

  • I am having this same problem. I've tried both the latest versions of 1Password from AgileBits' website and from the Mac App Store, and I've updated the browser extension. I'm using the new Firefox 55, and my extension is grayed out. None of the posted solutions have worked for me. I've reached out to support about this issue and linked to this thread.

  • sjksjk oversoul

    Team Member

    Hi @ABouchard,

    I've found your email and just sent a reply. We'll keep the conversation going there to get this resolved for you. Cheers! :)

    ref: DFM-51291-414

  • Thanks @sjk,

    As requested, I generated a report and sent it along with the tutorial provided in your email. It's great to hear from you so quickly!

  • ABouchardABouchard
    edited August 2017

    Updated to Firefox 55.0.1 this morning. Still grayed out. It seems like 1Password doesn't know that I have the browser extension installed.

  • rudyrudy

    Team Member

    @ABouchard,

    Since you're using the Mac App Store version you'll want to Help -> Troubleshooting -> Restart mini to get it to write out the necessary support file. You can verify that this file has been written out by looking at the contents of ~/Library/Application Support/Mozilla/NativeMessagingHosts/2bua8c4s2c.com.agilebits.1password.json

    Rudy

  • @rudy

    The file is there, yes.

  • brentybrenty

    Team Member

    @ABouchard: That's really odd. You mentioned that you have Firefox 55.0.1, but can you tell me the exact versions of 1Password and the extension you have installed? Thanks in advance!

  • Sure, I've attached some more screenshots. It appears to be 1Password 6.8 and the extension is 4.6.9.

  • brentybrenty

    Team Member

    @ABouchard: Scratch that. I see you've included this and some additional information in your emails, so let's continue the conversation there to get to the bottom of this.

    ref: DFM-51291-414

  • FWIW, I had the same problem.

    I went through all tshooting permutations above and it wasn't until upgraded to 1P to 6.8--I was on 6.7.1--that my re-re-re-reinstalled 1P FF browser plugin began working again.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file