Firefox and 1Password 4 [outdated information from 2017]


Team Member
edited December 2019 in 1Password 3 – 6 for Mac
This discussion was created from comments split from: 1Password button in Firefox greyed out not working.

AgileBits Update:
1Password 4 will not be compatible with Firefox going forward.

Please see this thread in the legacy category for more details on 1Password 4:

1Password 4 legacy support information

But you can find a temporary workaround for this particular issue here:

Firefox and 1Password 4

However, this will not improve as 1Password, macOS, and Firefox continue to move forward together.


  • Having the same problem with Firefox here. Still works okay in Safari.

    Tried all the remedies listed above but still no joy. 1Password updater tool reports I'm up to date.

    MacOS: 10.9.5
    1Password: 4.4.3
    Firefox: 54.0.1
    Safari 9.1.3

  • rudyrudy

    Team Member
    edited August 2017


    Unfortunately you're not going to be able to use the current Firefox extension anymore. You're going to have to install something 4.6.8 or older from

    The Firefox extension 4.6.9 and newer requires Native Messaging support in 1Password in order to function. 1Password 4 doesn't have this support. 1Password 6.8 is the first version to support Native Messaging. You won't be able to run that version on 10.9.5 as 1Password 6 as a minimum supported OS version of 10.10.


  • jqfischerjqfischer
    edited August 2017

    Hi sjk,

    same problem here:

    MacOSX: 10.9.5.
    Firefox: v55
    1Password: v4.4.3.
    1Password extension: v4.6.9.

    Same effect when starting Firefox: button is active for a short moment and then gets inactive. After that no response.

    1P works on Chrome but would love to hang on to FF & 1P combi.

    Thanks for your support!

    This comment was originally posted in: 1Password button in Firefox greyed out not working

  • sjksjk oversoul

    Team Member
    edited August 2017

    Hi @jqfischer,

    Hope you don't mind, I've moved your comment into this other discussion since you mentioned running 1Password 4.4.3. See Rudy's explanation of why the current 1Password extension will no longer work with 1Password 4 and the option to use an older version of the extension. There's also another discussion with comments about the 1Password 4 / Firefox combination.

    I hope that's helpful even if not the solution you were hoping for.

    ref: /QVA-97273-948

  • Rudy-

    Thanks. That fixed it. I had to use v4.6.7 before the etention came back to life. I'm stuck at 10.9.5 on the Mac due to software incompatibilities with Apple's new OS.

    Thanks again!

  • Hi sjk,

    thanks for your comment. I downgraded to extension version 4.6.8. in Firefox and disabled updates for it. 1password is back and working. Now wait and see how long it resists Firefox's update compulsion.


  • sjksjk oversoul

    Team Member

    You're welcome, @rborst, on Rudy's behalf. Thanks for letting us know you had to revert to version 4.6.7 of the extension to get it working with Firefox on your Mac.

    I'm stuck at older versions of OS X and iOS on my older Macs/devices. Still finding uses for them, while realizing their days until retirement are deceasing.

  • sjksjk oversoul

    Team Member

    You're welcome, @jqfischer. Interesting that version 4.6.8 of the extension did the trick for you, while rborst went back to 4.6.7.

    Now wait and see how long it resists Firefox's update compulsion.

    You could disable Check for Updates for extensions:

    Of course that'll disable automatic checking/updating for all of them.

  • I only disabled updates for 1Password not extensions in general for the moment. Hope that's enough ....

  • brentybrenty

    Team Member

    Definitely worth a try, but it isn't going to get easier. Firefox is dropping support for the old extension APIs completely later this year. You've got some time, but lagging behind on Firefox, macOS, and/or 1Password updates isn't only a bigger and bigger security risk as time goes on, things are just going to break eventually so it's a good idea to start looking at ways to move forward before that day comes. :(

  • sjksjk oversoul

    Team Member

    I only disabled updates for 1Password not extensions in general for the moment.

    Thanks for reminding me you can individually disable extension updates in Firefox; Safari's my primary browser. :)

    Of course what brenty mentioned is a factor.

  • Hi, I use 1Password 4.4.3 with Firefox 48.0.2 (last verion possible on my MBP with OSX 10.8.5). The 1Password Firefox extension made an autoupdate to 4.6.9 and now I see the 1Password icon in Firefox but can't open it (no reaction with a doubleklick). Is there a possiblitity to download an older version of the FF extension ?


    1Password Version: 4.4.3
    Extension Version: 4.6.9
    OS Version: OSX 10.8.5
    Sync Type: Not Provided
    Referrer: forum-search:1Password 4.4.3. with firefox 48.0.2

  • sjksjk oversoul

    Team Member

    Hi @B4Fan,

    I've moved your post into this related discussion of using 1Password 4 with Firefox, hope that's okay. See the previous comments about it and let us know if you have further questions. Cheers! :smile:

  • Thanks to Rudy. This link to older versions fixes the problem for now. But of course Brenty is right with his points !!!

  • sjksjk oversoul

    Team Member
    edited August 2017

    Glad that the info from Rudy and Brenty was helpful for you, @B4Fan. :+1:

  • I use Firefox 48.02 and Mac OSX 10.8.5. Since three days I have the same Problem - the Add-on ist istalled and visible, but 1Password 4.4.3 is not starting. As stand allone version it works fine.

  • rudyrudy

    Team Member
    edited August 2017


    The current Firefox extension is not compatible with 1Password 4. You will need to install something older than 4.6.9 from

    The alternative option would be to update your Mac to macOS 10.10 or newer and run 1Password 6.8 or newer.


  • I'm stuck on OSX 10.9.x, so 1Password 4.4.3 is the highest version I can upgrade to. It looks like the browser extension updated automatically on 8/8, and I'm having this same issue where the icon is greyed out and I can't click on it. I'm guessing I have to downgrade the extension version to get this working? Any instructions for that?

  • sjksjk oversoul

    Team Member
    edited August 2017

    Hi @stefanbergh, and welcome to the forum!

    I've moved your post over to this other discussion, hope you don't mind, where the first post will help answer your questions. :)

    Let us know if there's anything else we can help you with. Cheers!

  • Same issue. 1Password Add-On button no longer works on Firefox. Problem began this past week (August 7, 2017). Firefox 48.0.2 on a Macbook Pro (2014) running System 10.8.5. Both Firefox & Apple Updates indicate that I'm up to date (as far as running with Mountain Lion). It looks to me like 1Password had an automatic update this past week and now my version no longer works.

    I am not inclined to "upgrade" my computer to Sierra b/c past experience has taught me that such upgrades simply foul up the works of a perfectly working computer (and various software packages) and I don't need any extra bells and whistles or a change in the look.

    Please advise if I am correct regarding Agilebits pushing through an 1Password upgrade that doesn't work with my configuration (and I can't be alone), whether a fix is in the works, or how I can revert to a previous version that does work.


  • Hi Rudy,

    Thank you for your provided resolution. Fixed my issue.
    Truly appreciate it.

  • rudyrudy

    Team Member
    edited August 2017


    See this reply

    1Password 4 is long retired at this point and will not be receiving any further updates.


  • Hello Rudy -- Thank you very much! That fixed the problem.

  • rickfillionrickfillion Junior Member

    Team Member

    That's great to hear.


  • Same problem here. Extension is there when I go to Customize and stays solid until I exit, then is greyed out.

  • Well that explains it. I am on the Maverick OS and 1PW 4 - I have an old and somewhat temperamental iMac and have had difficulty with OS updates in the past so don't want to test my luck again. Guess I'm SOL as far as the browser extension is concerned until I upgrade to a new machine.

  • matthew_agmatthew_ag 1Password Alumni

    Hey @PR1,

    Thanks for taking the time to write in and sorry about the Firefox extension no longer working. You're correct that Firefox will no longer work with the older version of 1Password for Mac version 4. You can read more about this in my colleague's 1Password Announcement.

    As he mentions there, the recommendation for 1Password for Mac version 4 users who wish to continue to use the saving and filling features of 1Password is to switch from Firefox to the Safari browser. Unfortunately it's either that, copy and paste or as you said purchasing a newer Mac. Sorry about the lack of options. :(

    Sorry about the dropping of support, hopefully Safari will be a sufficient workaround for now. Do let me know if you've any questions.

    Best regards,

  • ... so pls what is the solution now?? it starts with OSX and ends for Windows. Have same problem on Firefox ESR 52.3.0 (64-Bit) on OSX 10.9.5 Thank you

  • Hi @RoadRunner1963,

    It can vary depending on the situation. In your case, OS X 10.9 tells me you are running 1Password 4 for Mac and the 1Password Firefox Extension will no longer be able to connect to this old version. To ensure continued support for future versions of Firefox (57 later this year) we've migrated out extension to the WebExtensions model which necessitated switching to a native message connection between the extension and 1Password. Only the more recent versions of 1Password support this, on the Mac it is 1Password 6.8.

    If you are unable to update past OS X 10.9 for any reason then the only real option left is Safari. Both Firefox and very soon Chrome will be native messaging only and 1Password 4 for Mac will not be able to connect to them. I apologise I don't have better news but this is the current state of extension support for 1Password 4 for Mac.

  • hello littlebobbytables
    I apreciate your efforts and your explanations! I just wonder because untill yesterday it worked. I go right to the assumption that my IOS 10.12.6 with Firefox ESR 52.3.0 (64-Bit) and 1PW 6 which is installed on my other computer will proper work?
    All the best

This discussion has been closed.