1pw 6.8 only shows splash screen

1pw 6.8 only shows splash screen when launched from the Home Screen on my iPhone SE with iOS Public Beta 4 released yesterday (which is Dev Beta 5, 11.0 (15A5341f)) - also happened with Beta 3.

Is this bug reproducible?

This does often but not always happen when trying to open the app from the home screen.

Which devices did this bug appear on and is it reproducible on any devices and/or computers?

iPhone SE (Model from Settings - General - Info: MLXP2DN/A)

A quick summary of the bug:

Just tap on the app icon, the splash screen appears and the blue ring in the middle constantly changes from pale to bright to pale blue (so I assume it's waiting for something). The upper info bar (carrierer, wlan, time etc.) is gone. But that's it. See attached screenshot.

 Detailed, step-by-step list on how to reproduce it:

Nothing else to say.

Note that I'm not signed in into 1pw.com because I have no account, I'm using a local vault only, to be synched via wlan.
Repro no matter if WLAN and/or mobile connectivity are turned on or off.

Versions of 1Password you're using on the devices and computers involved
6.8.
No computer involved at the moment the bug occurs (normally, I synch via WLAN with 4.6.2.625 on a Windows 10 PC (latest Insider build)


1Password Version: 6.8
Extension Version: -
OS Version: iOS Public Beta 4 (dev Beta 5)
Sync Type: WLAN

Comments

  • The splash screen:

  • iOS just crashed (screen black, circle, login shown, no reboot) and 1pw opened fine and I was able to synch with the PC. I killed the app, opened it again, no problem. Not sure what triggers the problem.

  • hi @snien,

    In my humble opinion this is nasty iOS bug that been introduced with iOS 11 beta 5, and other Apps have the same issue. We will just have to wait for beta 6.

  • rudyrudy

    AgileBits Team Member

    @HRD,

    Indeed.

    Rudy

  • Hi @rudy,

    On an initial look my view is this nasty bug is resolved with iOS beta 6.

    Thoughts?

Sign In or Register to comment.