Extension not working in Firefox

With 6.8 installed, on current Firefox ESR (52.3.0) with plug in updated. OS: Mac El Capitan

1 pass extension moved itself to the other end of the toolbar and then stopped working / greyed out. After restarting Firefox, it works for a short period of time and then no response again eventually.

Have tried reinstalling the plug in twice.


1Password Version: 6.8
Extension Version: 4.6.9
OS Version: El Capitan
Sync Type: Dropbox

Comments

  • edited August 2017

    Same problem with 6.8 installed, on current Firefox ESR (52.3.0) with plug in updated. OS: Mac El Capitan

    1 pass extension moved itself to the other end of the toolbar and then stopped working / greyed out. After restarting Firefox, it works for a short period of time and then no response again.

  • BTTT --- reply from support?

  • LWksLWks Junior Member

    Same problem here. Running 1PW 6.6.4, under OS 10.11.6 -- after updating Firefox to 55.0.2, the 1PW icon in menu bar became greyed out. Removed the add-on, reinstalled it, still greyed out. Quit Firefox, reinstalled the older version of Firefox, reinstalled add-on, and STILL greyed out - even on previous Firefox version.

  • LWksLWks Junior Member

    Update from here...
    Had been running 1PW 6.6.4 when I encountered this problem with the Firefox update

    I was able to solve this problem when I:

    • deleted the Firefox add-on
    • updated 1PW to 6.8
    • reinstalled Firefox add-on

    So far, it's stayed solid for over 12 hours and, best I can tell, doesn't seem likely to revert to being greyed out.

    See this other post regarding this topic on AgileBits:

    https://discussions.agilebits.com/discussion/81020/extension-not-working-in-firefox#latest

  • matthew_agmatthew_ag 1Password Alumni

    Hi @yetanotheraccount,

    Thanks for writing in and sorry about the lack of response so far. The versions of everything you have should mean that 1Password will work with Firefox. With the latest versions of the Firefox extension and the 1Password app, 1Password has moved to use an entirely new method of communication known as Native Messaging. It's likely that there is something wrong with the Native Messaging configuration that is causing this.

    The next step is to examine a Diagnostics Report for this issue. To create a diagnostics report from your Mac:

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    • A link to this thread: https://discussions.agilebits.com/discussion/81166/extension-not-working-in-firefox
    • Your forum username: yetanotheraccount

    That way we can "connect the dots" when we see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so we can track down the diagnostics and ensure that this issue is dealt with quickly. :)

    Once we see the diagnostics we'll be able to better assist you. Thanks very much!

    Best regards,
    Matthew

  • matthew_agmatthew_ag 1Password Alumni

    Hey @LWks,

    Thanks for writing in and for letting us know how you solve this issue. Hopefully it'll be of help to others who read this Forum.

    Best regards,
    Matthew

  • The extension stopped working again. I submitted a report. Email auto responder did not include a support ID number.

  • LWksLWks Junior Member

    Hello all,

    In case it's of any use, I thought I'd report that the changes I listed above really do seem to have done the trick for me - I've had no problems, whatsoever, with the 1PW extension (greying out or acting oddly in any way, in Firefox) since making those changes 4 days ago.

    And, except for the sync type, I seem to be functioning under the same configuration [on the Mac] as yetanotheraccount.

    1PW version 6.8 (680015)
    Extension version 4.6.9
    Under El Capital 10.11.6

    The only difference is that I just realized that I'm running Firefox 55.0.2.

    Maybe see if updating to that version of Firefox solves it.

    Hope this helps.

    • L -
  • matthew_agmatthew_ag 1Password Alumni

    Hey @yetanotheraccount,

    Thanks for sending in the report, we got the ticket. Your support reference is RJT-82187-655. We'll get back to you shortly :chuffed:

    Best regards,
    Matthew

    ref: RJT-82187-655

  • matthew_agmatthew_ag 1Password Alumni

    Hey @LWks,

    Thanks again for writing in to help. With the new 1Password for Firefox extension (version 4.6.9), all Mac users will need to be using version 6.8 of 1Password for Mac as a minimum. Hopefully we can get yetanotheraccount's 1Password back up and running. I'll mention what the issue was here once we figure it out :chuffed:

    Best regards,
    Matthew

  • Any news on my trouble ticket?

  • matthew_agmatthew_ag 1Password Alumni

    Hey @yetanotheraccount,

    Sorry about the delay, I have replied to you with an update on our progress. Thanks for you patience.

    Best regards,
    Matthew

  • I installed the latest update, but the plug in still stops working with Firefox. I'm having to restart my browser multiple times a day to get 1password to work. It's really aggravating. Been waiting quite a while for this to be fixed.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @yetanotheraccount Have you updated to 1Password 6.8.1? There are some important fixes there related to these connection issues.

  • edited September 2017

    I installed the latest update, but the plug in still stops working with Firefox.

  • brentybrenty

    Team Member

    @yetanotheraccount: If the connection is lost, 1Password will attempt to connect again after 30 seconds (to avoid spamming). If you're still unable to use the Firefox extension after waiting briefly, please send us a fresh diagnostics report immediately the next time it happens so we can try to see what's causing this on your machine. Just put [#RJT-82187-655] in the subject line so we can connect it to our conversation with you.

  • When it stops working, it stops working until I restart Firefox. Waiting 30 seconds or more has no effect. I was led to believe in email related to the diagnostic report I sent previously that the issue I reported was still being worked on. Replies to this thread are leading me to believe that your team considers my previous report addressed. Nobody has told me to send another diagnostic report until now. I've just been having to restart repeatedly, assuming a fix was forthcoming.

  • It just stopped working again after less than an hour since Firefox restart. I sent a report.

  • brentybrenty

    Team Member
    edited September 2017

    @yetanotheraccount: Thank you! I'm sorry you're still having trouble, but we'll see what clues we can find there.

    As Matthew mentioned in his last email to you, we're investigating this. But we're not able to reproduce the problem ourselves, so we haven't found what might be causing this on your machine. Hopefully the most recent diagnostics will shed some light on things.

    ref: RJT-82187-655

  • Hey there. Firefox extension is greyed out for me as well. I did all the re-installing, updating and re-starting, as described in various posts.

    Firefox: 55.0.3 (32-Bit)
    Extension: 4.6.10.60
    1 Password: 4.6.2.626
    Win 10 Home N: 1703 / 15063.540

    Any idea on how to proceed? This outage is rather annyoing, unfortunately. :(

  • Greetings @Schneenagels,

    Can you please try the following for us.

    1. In 1Password 4 for Windows check to see if the menu option "Help > Advanced > Use Native Messaging protocol" is enabled. If it isn't please select it.
    2. Restart your PC.
    3. Launch 1Password and unlock.
    4. Open Firefox and attempt to use the 1Password Browser Extension.

    If the extension is still not working then I've found this next set of steps has helped a number of people.

    1. Launch 1Password and enter the menu "File > Reopen 1Password Vault". Note the location of your vault.
    2. Use the control panel and uninstall 1Password 4 for Windows.
    3. Restart your PC.
    4. Download and install a fresh copy of 1Password 4 for Windows.
    5. If you aren't automatically asked to select your vault and are instead prompted with three options select "I have used 1Password before".
    6. Point 1Password to the location of your vault as noted in step 6.
    7. Open Firefox and attempt to use the 1Password Browser Extension.

    If it still isn't working please let us know. We'll probably need to request a diagnostic report but let's see if either set of those steps makes any difference first.

  • I have followed all of the trouble shooting instructions I have gotten via email, yet the plug in keeps greying out and stops working. I just sent another report. [#RJT-82187-655].

  • I've just answered your email @yetanotheraccount. As we're discussing this via email I recommend we keep the conversation there given the need for diagnostic reports to try and understand what is happening.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file