I have to click multiple times on items in Firefox extension

2

Comments

  • MikeTMikeT Agile Samurai

    Team Member
    edited November 2017

    Hi @txtsteve,

    I forgot, it may require restarting 1Password Helper and your browser, they don't switch until a new authorization session starts.

    First, close your browser and then open 1Password, go to the Help Menu > Restart 1Password Helper. You should see an authorization prompt show up when you open your browser.

  • Sorry, I didn't restart my browser after I made the change so I'm guessing the setting change didn't take affect.

    That being said, once I restarted my browser with the "Use Web Socket" option selected, clicking on the 1Password icon in my browser didn't work at all. It wouldn't even pull up the drop-down list.

  • MikeTMikeT Agile Samurai

    Team Member
    edited November 2017

    Hi @txsteve,

    I apologize. Today is not my day. Websockets is only available in 1Password extension for Chrome. If you're using Firefox, there is no WebSocket support it can fall back.

    For now, you can download 1Password 4.6.625 instead, so it should be okay with Native Messaging support in Firefox with that specific older build.

    Once we figure out the problem with Native Messaging issue in 4.6.626, we will follow up here.

  • @MikeT Thanks so much... so far I haven't had a problem with any website I've tried to log in with since installing 4.6.625.

    Many thanks,
    Steve

  • MikeTMikeT Agile Samurai

    Team Member

    That's great, thanks for letting me know.

  • edited November 2017

    I also tried this - but when I switched to "Use WebSocket", the 1Password icon in FireFox turned light gray and stopped working at all. :(


    Sorry, didn't notice there is another page of comments here.
    Will also try 4.6.625.

  • GregGreg

    Team Member

    Hi @siteimpulse,

    Sorry for the troubles! Have you tried to install 1Password 4.6.625 instead of 4.6.626 and use Native Messaging? Does the issue remain with the previous version?

    Thanks! :+1:

  • WOW!
    Just logged in to 10+ websites in a row and it worked like a charm every time!
    I's so much better now.
    Thank you!

  • GregGreg

    Team Member

    @siteimpulse: Thank you for keeping us posted! As Mike noted above, we still need to figure out what went wrong with Native Messaging in 4.6.626. We will follow-up here, once we do.

    Thanks again!

  • For some time it was great, but now the problem is back.
    At least with the new Firefox.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @siteimpulse,

    And you're still using 1Password 4.6.625 right, it wasn't updated by accident or anything like that?

    We're not aware of any changes in Firefox 57 that changes how 1Password work, the extension was already WebExtension for a few months.

  • @MikeT Tt seems I'm using 4.6.2.626. I guess I didn't notice the update.
    I'm sorry will downgrade again now.

  • MikeTMikeT Agile Samurai

    Team Member

    No need to apologize, we may need to look into pulling the 626 update off our server.

  • edited November 2017

    I thought I should join the conversation at this stage. Using Firefox Quantum 57.0 64bit, 1Password 4.6.2.626 (unfortunately) and firefox plugin 4.6.12.90. Same problem is happening to me and for quaite along time so it is not tied down to Firefox version or 1Password Version. I suspect it started after I downloaded the latest version of the plugin which is listed above. I still have the older one 4.5.1 and will try to install that one to see if it solves the problem. It is so frustrating to see Firefx users have to suffer from this. Not everyone is OK with surrendering their whole lives to Google or Microsoft. I hope this gets fixed soon.

    Note: Tried to send in the diagnostic data with Send to Agile Bits option. Got a warning saying default mail client could not be found. Asked me to make outlook the default mail application. It is indeed the default application in windows 10 settings. But it is not sending anything. This also needs to be adressed in my opinion. I've got a zip file but don't know where to send it to.

    Thanks.

  • edited November 2017

    And yet another surprise. I uninstalled the plugin to install the older one. I get a prompt "This add-on is not compatible with Firefox 57 and cannot be installed" I tried to revert back to the newer one. And guess what? Same warning message for the newer one too. I'm completely "add-on"less now. :(

    Edit: The above situation is valid for adding add-on from a downloaded version of the 1Password plug-in. (***.xpi file). Installing directly from Agilebits website worked for the same newer version although it claimed not compatible by Firefox during manual install.

    Anyway it works perfectly now. Fingers crossed)

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @alien2000a,

    Thanks for writing in.

    I suspect it started after I downloaded the latest version of the plugin which is listed above.

    Please make sure 1Password 4 is configured to use Native Messaging as it is required for the latest 1Password extension for Firefox. To do this, open the main 1Password 4 program and go to the Help Menu > Advanced > Use Native Messaging Protocol. Normally, this is supposed to be turned on by default as we started defaulting to this a few months ago but some users didn't get that turned on.

    After that, go to the Help Menu > Restart 1Password Helper and then restart Firefox, see if it works.

    If it still doesn't, please generate a fresh report via the Help Menu > Diagnostics Report > Export to File and email it to us at [email protected].

    is so frustrating to see Firefx users have to suffer from this.

    We had 1Password extension ready for the major changes in Firefox Quantum two-three months ago and majority have updated to Firefox without any issues with 1Password. There are some minor edge cases such as the ones in this thread we're investigating but it is not a widespread problem. I know it doesn't help to know that but we are working as fast as we can to address the known issues.

    Asked me to make outlook the default mail application. It is indeed the default application in windows 10 settings. But it is not sending anything. This also needs to be adressed in my opinion.

    Unfortunately, this is not an issue with 1Password, it's with Windows not processing the default call properly. Due to some users being affected by this with no workaround, we have removed this option from 1Password 6 and future versions of 1Password, so that you'd have to manually email us the file.

  • Final verdict. after a restart everything went back to square 1. I need to click at least two times for the passwords to be filled in by the browser add-on :(

  • brentybrenty

    Team Member

    @alien2000a: By "back to square 1" do you mean you're still running version 4.6.2.626? Have you tried 4.6.2.625 as Mike suggested above? That's the known fix for the multiple attempts issue which is the topic of this discussion. If you're having a different issue, please let us know the specifics.

  • I have to confirm. :(

    Still using 4.6.2.625 - and the problem started to occur again...

  • bundtkatebundtkate

    Team Member

    @siteimpulse: When you downgraded from 626, did you reboot before installing 625? If you're still having issues with 625, that would be the first that I've heard of it, so my best (somewhat educated) guess is that perhaps some 626 registry changes didn't get properly cleared when you made the switch and I know 1Password 4 isn't as in-your-face as it perhaps should be about telling you to reboot to complete the uninstall. I'll admit, I'm likely the one here that's least up-to-speed on this particular issue, so if I'm completely off-base here, I'll poke someone with their finger more on the pulse to see if they have other ideas. :+1:

  • Hi @bundtkate.

    Should I now spend time on properly re-installing this version or rather be a bit more patient and wait for the new version that fixes the problem once and for all?
    Is it coming anytime soon?

  • bundtkatebundtkate

    Team Member

    @siteimpulse: Given our past experiences I would go ahead and spend time properly reinstalling and being sure to reboot between uninstalling 626 and reinstalling 625. 625 has been the permanent solution for everyone we've worked with thus far. Given troubles reproducing the issue ourselves in addition to MikeT's comments above, I suspect the more immediate fix will be pulling 626 rather than pushing an update. So far as I'm aware, we've still be unable to reproduce this problem ourselves and are still working to identify the exact cause meaning an update isn't likely to be in the immediate future.

  • Just FYI I am having the same problem with 626.

  • brentybrenty

    Team Member

    @tomlut: I'm not sure I understand. Did you mean 625?

  • tomluttomlut
    edited March 2018

    I am using version 4.6.2.626 of the main application and version 4.7.0.90 of the Firefox pug-in with version 59.0.2 (64-bit) of Firefox on Windows 10 (1709) and more often than not have to select logins multiple times from the Firefox 1Password plug-in menu before the details are populated onto the web page.

    I only mentioned it because of bundtkate's comment that you were having trouble reproducing it.

  • brentybrenty

    Team Member

    @tomlut: Thanks for clarifying. But have you tried 625? It's helped others who've experienced issues with 626 and Firefox. Also, using the Ctrl \ keyboard shortcut can help. :)

  • The only solution that finaly resolvs the issue for me was changing from Native Messaging Protocol to WebSockets again in 1Password settings.

  • GregGreg

    Team Member

    Hi @xadox,

    That is quite strange. Are you using 1Password 4.6.2.626 with the latest version of Firefox? Please let me know.

    Additionally, please note that we are working on the new app for Windows, 1Password 7 (already available in beta) that will replace 1Password 4 when it is released. Feel free to raise any questions, if you have them, in the meantime. Thank you! :+1:

    Cheers,
    Greg

This discussion has been closed.