"Add opera extension" page doesn't download extension.

My opera extension stopped working so I went to the mini app at the top of my screen. I clicked on "Add opera extension" and then clicked on the green Install button. Nothing downloaded. I tried the manual link and that didn't download anything either. Not sure what to try at this point. Any help would be really appreciated. I also don't know how to find the 1password extension version for Opera. :-/ sorry.

1Password Version: 6.8.2
Extension Version: Not Provided
OS Version: 10.10.5
Sync Type: Dropbox
Referrer: forum-search:opera


  • Hello @futurenaut,

    You can view installed extensions in Opera via Opera's menu option View > Show Extensions. When I install the extension I get a small popup just below the address bar. Opera won't automatically install our extension and you have to go enable it in their Extensions page. You may find this is all that is needed. If it isn't and you're still having problems please let us know.

  • I am having the same issue. Clicking the green install bar doesn't do anything, neither does clicking the download link. Showing the extensions sidebar doesn't help.

    URL: https://agilebits.com/onepassword/extensions

  • Greetings @ClearScreen,

    Is there any chance you're mixing up the extensions sidebar with the extensions page? I only ask because in the View menu of Opera there is not just View > Show Extensions which will open the extensions page but there is also View > Show Extensions Bar, the purpose of which isn't entirely clear to me but I can confirm is of little help when attempting to install an extension. It could be you meant the extensions page but given the particular phrase used I hope you understand why I check rather than make an assumption.

    Can I also confirm what you mean by the green install bar doesn't do anything. Is it that clicking it yields absolutely zero response from the browser, almost like it hasn't registered the click at all or is it redirecting you to the page https://agilebits.com/onepassword/extensions/opera?beta=false but the extension doesn't appear to be installed which is equivalent to the green install bar not doing anything? The devil is in the details as they say so it's best we understand as accurately as possible what has (or hasn't happened) in order to narrow down the possible causes.

  • Same problem here - clicking the green icon does NOT install anything. When I downloaded the BETA version of the extension, Opera (in my case 49.0) pops up a menu above the browser window saying "EXTENTION INSTALLATION FAILED - ATTEMPTED TO DOWNGRADE EXTENSION".

  • brentybrenty

    Team Member
    edited December 2017

    @PrincipeAzzurro: Which version of the extension do you have installed currently?

  • Same problem here. Not possible to download the extension. Using Opera: 52.0.2871.64...
    Am I not supposed to be able to use Opera?

  • brentybrenty

    Team Member
    edited April 2018

    @uffez: I am also using Opera version 52.0.2871.64, and seems t be working here. Try installing it again:


    1. Click "Install 1Password for Opera"
    2. Click "Go to Extensions"
    3. Click "Install"
    4. Click "Yes, Install"

    if you're still having trouble, can you tell me where exactly you're running into trouble with that? Do you perhaps have "security" software, settings, or other extensions/software that are interfering?

  • Well, it fails from he beginning as I am not able to download the extension. Download never starts at all. Works in other browsers: Safari, Chrome...

  • brentybrenty

    Team Member

    @uffez: Thanks for clarifying. I'm glad to hear that Chrome and Firefox are working for you normally at least. But there isn't going to be anything we can do about that I'm afraid. The best I can suggest is to check your settings in Opera and other software to see if you can figure out what is preventing you from even connecting to download the extension. That isn't normal. We see issues like that in most browsers from time to time when people are using "security" software that's trying to be a person-in-the-middle even with their secure connections. Our server will refuse connections if it isn't end-to-end encrypted, so that would prevent you from being able to download from us, or use 1Password.com at all in most cases. Let me know what you find.

  • Works now, Was some strange setting in extensions in Opera.


  • brentybrenty

    Team Member

    @uffez: Great! Can you tell me which setting? It may help others as well. :)

  • Well, when I eventually checked in the extensions settings - it was deactivated... My bad, but I hadn´t noted this before. Maybe deactivated when upgrading.

  • Greetings @uffez,

    At least we've discovered the cause, even if we may never learn how it came to be disabled.

  • I am experiencing this same problem. Perhaps of note, the 1password Opera extensions was previously installed but was both disabled then removed. I have turned off all the security that I can think of and the download page remains unresponsive. The automatic download does not occur and the manual download is unresponsive.

  • OS: High Sierra: 10.13.6
    Browser: Opera Version: 53.0.2907.68
    1password: 7.0.4

  • brentybrenty

    Team Member

    @daanes: Did you try re-enabling it? Any idea what removed it, or did you do that yourself? This is strange.

  • Hi @daanes,

    I've tested a copy with a copy of Opera and both the automated and manual installation worked so it looks like something is somewhat wonky with your copy of Opera. Can you try the following please.

    1. Ensure there is no copy of the extension showing in the extensions page (menu option View > Show Extensions).
    2. Restart Opera.
    3. Attempt to install the extension one more time from Browsers - 1Password.

    Sometimes the restart in the middle turns out to be important in eliminating some weird state its gotten into. Hopefully that's enough for the extension to install. If it partially works in that there seems to be an entry visible but the extension is working check to see what the icon for the extension looks like. If it's the generic puzzle icon Opera didn't install properly and I find you have to delete and try again. Typically it seems to work on the second attempt if it fails on the first.

  • Hi Brenty,
    I did not see your post earlier. I can't re-enable it because it no longer appears in the Opera extensions list and I have tried every view from All to Disabled to Enabled. I removed it a few weeks ago because the extension did not seem to be working properly so I figured I'd uninstall and then re-install. Perhaps I have done something to mess it up but I have no idea wat that have been.

  • brentybrenty

    Team Member

    @daanes: I don't think it's you're fault that you're having trouble with this, but it is a bit baffling since, like lil bobby mentioned, we're able to install it here, and others seem to be able to as well. I'd encourage you to try the following so see if this gets opera sorted:

    1. Drag opera to the Trash
    2. Restart your Mac
    3. Install a fresh copy of Opera: https://www.opera.com
    4. Install the 1Password extension: https://1password.com/browsers/

    If that doesn't work, it may be something with Opera's support files, and nuking them may be necessary. However, do you perhaps have "security" software which might be interfering with the connection when you try to download it? Let me know.

  • Am running BitDefender AV software but nothing else beyond native Mac security. I'll try your suggestions after morning coffee, a need more urgent than software!

  • It worked! Thanks so much for your help.

  • brentybrenty

    Team Member

    Excellent! Thanks for letting me know that was it! I'm glad to hear that all is well. It sounds like you should be all set, but don't hesitate to reach out if we can be of further assistance. We're always here to help! :)

  • michaelgarinmichaelgarin Junior Member

    I am experiencing the same problem. With the release of the newest Opera version, I decided to make it my default browser (a big decision), but if I can't get the 1Password application to work (the icon is on my tool bar) but the application won't function. I receive a message on the Opera Addon page saying:
    1Password extension (desktop app required) can:
    Access your data on all websites
    Communicate with cooperating native applications

    Every other application that I had integrated into my Opera browser from Safari works just fine. I hope this will be true for 1Password soon as well.

  • Hello @michaelgarin,

    So the 1Password extension shows as being installed in Opera and you can see the button in the Opera toolbar, is that correct? Can I ask what version of 1Password you are running please.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file