Cannot enable "Sync with iCloud" - possibly because 1P expects your store Apple ID to be the same as

When I try to enable "Sync with iCloud" in 1Password on my iPhone 6s (iOS 11.0.1) it says "iCloud Drive Not Available - It looks like you have not signed into iCloud or enabled iCloud Drive....etc". My iCloud Drive is enabled and working happily for everything else - only 1Password is complaining. I already have a bunch of 1P entries on my iPhone because it was previously synced from my PC via WLAN - but I'm getting rid of that PC. So now I want to use iCloud sync between my Apple devices - starting with the 1P content on my phone - which I could do if 1P would allow me to enable iCloud syncing. Note that I'm NOT talking about actual syncing - I'm simply trying to enable it! I use a different Apple ID for the App Store than I use for my iCloud account. My IOS version of 1P is the pro version - so it might be tied to my App Store Apple ID. Now when I try to enable iCloud syncing, 1P might be looking at my iCloud Apple ID instead - thereby getting confused because there are 2 Apple IDs involved. Also, choosing the "Reset all iCloud" data option does not help. What else could keep you from enabling iCloud Sync?


1Password Version: 6.9
Extension Version: Not Provided
OS Version: MacOS 10.13
Sync Type: iCloud
Referrer: forum-search:iCloud drive not signed in

Comments

  • BenBen AWS Team

    Team Member

    Hi @mrgjlgx

    My understanding is that with iOS 11 (or, anything 10.3 or later) it is no longer possible to use a different Apple ID for iCloud than the one you use for purchases:

    When you use iOS 10.3 or later, you sign in to iCloud, the iTunes & App Store, iMessage, FaceTime, and your other Apple services in one place.

    Sign in with your Apple ID - Apple Support

    Perhaps I’ve misunderstood? If I have, and Apple does actually allow you to still use separate Apple IDs then I’d recommend running through this guide:

    If you're having trouble syncing with iCloud

    Please note, as mentioned in the guide:

    We’re unable to troubleshoot issues with iCloud beyond the scope of this article. If you’ve tried everything in the article and are still unable to sync, switch to a more reliable sync method.

    I hope that helps!

    Ben

  • It took awhile, but I figured it out. You need to initiate the whole process from a Mac (you can't initiate iCloud syncing via content that's already present on an iPhone - which was there because I had previously done a WLAN sync from my old PC). Instead of starting off with iOS, install standalone 1Password on your Mac first (High Sierra in my case), enable sync via iCloud on the Mac, sign in to the iCloud browser prompt that 1P brings up - using your PRIMARY Apple ID (not the iTunes ID, if different). Then sync with iCloud on an iPhone or iPad running iOS 11. That was all I needed to know! Now it works just fine. This might be useful your FAQ page for others who have 2 Apple IDs. FYI: And yes, you can certainly still use 2 Apple IDs just fine! Until Apple provides a migration path, they will probably support it. (If Apple ever disallows that, not only would a lot of people lose their purchases, but everyone using iCloud Family Sharing would lose all of their Apple Music libraries - since I'm the organizer - according to their support page.). And FYI: I did realize you don't support iCloud syncing beyond that article - I was simply trying to figure out how to enable the feature - so please, help others by putting what I figured out on your "iCloud troubleshooting page". Thanks!

  • BenBen AWS Team

    Team Member

    Thank you for the update, and for the feedback! I’ll talk to our documentation team and see what we can come up with. :)

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file