1password extension for safari is not working

I installed the 1password application in my Mac OS High Sierra (brand new Mac) and when I install the extension and click the button on safari it gives a message that it cannot connect to 1password app.

I tried the troubleshooting guidelines (uninstall - reinstall - reboot) but nothing seems to fix this.

BTW installations on other devices worked fine.

Any help is appreciated

George


1Password Version: 6.8.3
Extension Version: 4.6.11
OS Version: 10.13
Sync Type: Not Provided

Comments

  • brentybrenty

    Team Member

    @gxilouris: It sounds like you may have multiple copes of 1Password, so that macOS is launching the wrong one, and 1Password cannot connect to the browser. If you do a Spotlight search, what do you find?

  • I only have one instance! However I think it was an issue with the fingerprint unlock.
    So apparently the association with the application was ending before the screen for iTouch validation was up. Thus I was never asked for my fingerprint. For some strange reason it fixed it self (really I did nothing after sending you the message) and I got the popup just in time to verify using itouch. Everything fixed now !

    Thanks for your message BTW.

    George

  • LarsLars Junior Member

    Team Member

    @gxilouris - on behalf of Brenty, you're quite welcome! Glad to hear everything's working smoothly now, but let us know if you need anything else. Cheers! :)

  • I actually have a similar issue. Same versions, a single copy of 1password. The extension tries to contact 1password mini to no avail. 1password mini does not recognized the extension is installed. It started to suddenly misbehave since the update.

  • LarsLars Junior Member

    Team Member

    Hi @xguerin - sorry to hear you're having difficulties. Can you tell us a little more? What version of macOS are you running, what version of 1Password for Mac and the extension, and what browser/version are you experiencing this with? Before we go down the rabbit hole, I'd like you to remove the extension, restart your Mac, then re-install the extension -- let us know and provide the additional information if it continues not to work. Thanks!

  • Here are the version I am using:

    OS: High Sierra
    1password: 6.8.3 from the AppStore
    Safari extension: 4.6.11
    Safari: 11.0

    I already went through all the sanitary operations you mentioned: removing the extension, restarting the Mac, reinstalling the extension. Unfortunately, the problem persists:

  • LarsLars Junior Member

    Team Member

    @xguerin - thanks for the update, and sorry to hear the problem still persists. To get a better idea of what you might be experiencing, I'd like to ask you to create a diagnostics report from your Mac:

    https://support.1password.com/diagnostics/?mac

    Please add the following code (including the square brackets) to the Subject line of your diagnostics email before sending it:

    [#BNE-88259-578]

    This will link your diagnostics to our current discussion. We'll take a look and let you know what we find out.

    For anyone else reading, please note: this ID is for @xguerin only. If you’re experiencing the same issue and need help, please ask us for your own ID.

  • Since most recent 1Password update and MacOS to High Sierra, I"m with same problem: Safari button for 1Password inop. Only way I can make work is go to Preferences and disable and re-enable 1Password extension. Using all same versions as described by xguerin. I know most recent update mentioned improvements in various browsers but Safari for Mac not showing improvement.

  • LarsLars Junior Member

    Team Member

    Welcome to the forum, @cvaux! I'm sorry to hear you're having trouble with 1Password's extension in Safari right now. That's not normal behavior, and there are a few possibilities for why it might be occurring. Do you have any proxies or similar installed (like Privoxy or the like)? These can interfere with 1Password's ability to communicate with the browser.

  • Made no changes that I'm aware of. I found that disabling and re-enabling the extension worked after clicking the heck out of it and a very very delayed response to open. Other interesting factor seems related to the timing that holds the extension open for a number of minutes before it locks. After the lock, it's back to disable-enable method. The uppermost menu bar with 1Password opens always immediately.

  • LarsLars Junior Member

    Team Member

    @cvaux - have you tried deleting the 1Password extension, restarting your Mac, then re-installing it from either Apple's gallery or from us directly? If not, give that a try. Let us know what you discover!

  • I tried your most recent advice although I did deinstall and reinstall the entire extension before I contacted support. My guess is the restart of Mac did the trick. I did then get a "can't connect to 1password mini" error message. followed instructions on agile bits site for troubleshooting and working as expected so far. Will see what happens with timeout issues.

  • LarsLars Junior Member

    Team Member

    @cvaux -- yep, wondered if that might be helpful. Glad to hear it, along with troubleshooting the connecting to Mini issue, seems to have gotten you back on the right track. Let us know if you need further assistance, and have a great rest of your week!

  • Issue has returned. When I first use iMac in the morning (do not power off at night), the same behavior occurs: icon in menu bar for Safari can be clicked without effect. I go into preferences, click off 1Password extension and immediately click on. Menu icon then works perfectly. I think it has to do with timing. ?iMac going "to sleep", ?power saver

  • LarsLars Junior Member

    Team Member

    @cvaux - going to sleep shouldn't affect anything. But if you're running antivirus/proxy/VPN software overnight that DOES interfere with local connections, that might be the culprit, since toggling off and back on fixes the issue. Do you run anything like that as an overnight task?

  • I do have McAfee anti virus running. Only 'overnight' task I can see is an automatic update that runs once or twice a day. The included firewall and live virus checking are constantly on too. On starting to use Safari this morning, same aggravating behavior with 1password: on/off toggle of extension in preference gets it going but rather clunky fix. I'll check McAfee site for any complaints of 1Password interaction.

  • LarsLars Junior Member

    Team Member

    At this point, @cvaux, in order to get a closer look at what might be going on with your setup, I'd like to ask you to create a diagnostics report from your Mac:

    https://support.1password.com/diagnostics/?mac

    Please add the following code (including the square brackets) to the Subject line of your diagnostics email before sending it:

    [#DRH-52242-322]

    This will link your diagnostics to our current discussion. We'll take a look and let you know what we find out.

    For anyone else reading, please note: this ID is for @cvaux only. If you’re experiencing the same issue and need help, please ask us for your own ID.

  • LarsLars Junior Member

    Team Member

    @cvaux -- thanks; I've replied to you over there -- let's keep the conversation going privately, now that it includes personal information from your Mac. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file