1Password 6 doesn't start. [resolved through email]

schafexschafex
edited November 2017 in Mac

Hello,

Every Time i open 1Password 6, it directly crashes. I tried to reinstall 1Password 6, but it fails to start the apllication at the end.
So I installed the version from Mac App Store, which works, but my license is not working with this version.

I'm running the latest version of Mac OS High Sierra 10.13.

Do you have some thoughts in this?


1Password Version: 6.8.3
Extension Version: 4.6.12.90
OS Version: OS X 10.13
Sync Type: Dropbox

Comments

  • Hey @schafex

    I'm sorry 1Password is crashing on your end. Simple question, but have you tried restarting your Mac and installing the the direct download version of 1Password again?
    What else have you done to try resolving this?

  • LarsLars Junior Member

    Team Member
    edited October 2017

    @schafex -- sorry to hear you're having trouble just now! I'm with @Thelauffer -- you should definitely restart your Mac, if you haven't in a while.

    If a simple restart doesn't fix your issue, then we're going to have to dig a little deeper. Unfortunately, the Mac App Store version of 1Password will not work unless you pay to unlock it, because it's sold via Apple, and they have no way to know you purchased 1Password for Mac from us already. So I'd recommend deleting the Mac App Store version by clicking on Launchpad in your Mac's Dock (the rocket ship icon), then locating 1Password in the list of apps, and deleting it by click-and-holding until it "wiggles," then delete by clicking the black X in a circle at the top-left of the icon.

    Once that's done, exit Launchpad and drag the 1Password 6 app from your Applications folder to your Mac's trash. Don't use any app cleaners or uninstallers to do this, as these programs can remove more data than we want them to. Just drag the 1Password app to the Trash, then restart your Mac. After your Mac restarts, visit our downloads page and grab a fresh copy of 1Password for Mac and use the package installer to install a new copy. Test it out and let us know how it works.

  • Hi @Thelauffer and @Lars

    Thank you for your quick responses.

    Yes, i uninstalled both versions of 1Password , restarted my macbook and tried to install 1Password with the direct download version. It seems that the installation is working, but if i try to open 1Password it crashes.

    I just spotted that i have the same problem with another application called "CleanMyMac 3". It also crashes directly after i launch it. All other applications work.
    So i guess, this issue is caused by my personal macbook setup. Unfortunately i can not find information in the web how to solve this.

    Let me know, if you know more about this issue.

  • Although this can be a little intrusive, you may want to try reinstalling macOS on your MacBook. I wouldn't suggest an erase and install, but just a reinstall as it can help with the crash since this is happening to more than one app. Apple has a good article on this:

    https://support.apple.com/en-us/HT204904

  • LarsLars Junior Member

    Team Member

    @schafex - Ahh, CleanMyMac. That's almost certainly the cause of the problems (though as soon as I say that, of course I'll turn out to be wrong). This would be one of those "app cleaners or uninstallers" I mentioned in my previous reply.

    Let me be clear: such programs are not bad in and of themselves; they can be wonderful for getting rid of all traces of an app that you truly no longer want to use (as well as other chores), but when it comes to deletion and re-installation (if something's become corrupted), that's where things can get a little dicey. If the settings aren't just right, you'll remove critical data from your Mac that 1Password needs -- or you'll remove only part of it, so that 1Password thinks it's been installed before (because it sees certain files it recognizes) but then others it would need aren't there, because they were selectively removed by the app cleaner, and...well, you get the picture.

    Long story short, we won't know anything unless we can take a closer look at what's actually going on with your specific setup. I'd like to ask you to create a diagnostics report from your Mac:

    https://support.1password.com/diagnostics/?mac

    Please add the following code (including the square brackets) to the Subject line of your diagnostics email before sending it:

    [#UDV-41797-729]

    This will link your diagnostics to our current discussion. We'll take a look and let you know what we find out.

    For anyone else reading, please note: this ID is for @schafex only. If you’re experiencing the same issue and need help, please ask us for your own ID.

    ref: UDV-41797-729

  • @Lars @Thelauffer

    Thanks for your support.

    If nothing else works, i try reinstallation of mac os.

    I just sent the diagnostic report via email.

    I see your point, although i haven't used CleanMyMac 3 to uninstall or delete 1Password or data from 1Password.

    This is the message i get, when i try to open 1Password:


    Translation: The program "1Password 6.app" can not be opened.

  • bundtkatebundtkate

    Team Member
    edited October 2017

    Thanks for the dignostics, @schafex! I see we've received them, so we'll take a look and get back with you ASAP. :chuffed:

    ref: HTC-75755-114

  • bme2014bme2014
    edited November 2017

    I am having the same issue. 1Password was crashing on launch with EXC_CRASH (Code Signature Invalid). I have restarted my computer multiple times. I then remove 1Password from my computer and tried to run the installer from 1password.com/downloads and the installer crashes with the same message.

    ref: VUL-42889-194

This discussion has been closed.