Can't paste in password to open Knox

Hello!
I used to be able to copy my Knox vault's password from 1Password, then paste it into the password field to access [vaultname].sparsebundle.

Y'know, this little window.

Now, when I copy the password from 1P and attempt to paste into the password-entry field, I just get macOS's error sound.

I encountered this problem once before (in 2016?) and found a solution on the 1P help fora. Now I'm coming up blank. Error sound.

What do I need to do to be able to paste in my Knox vault password?

Thanks in advance for your help.
-Mike

Maybe this background will help:
I store the vault and 1Password.agilekeychain in Dropbox.
I'm migrating to a newer Macbook Pro.
1P works successfully on the new machine.
I downloaded and installed a fresh version of Knox 2.3.2
I think I've got a full copy of the vault on my machine (not just represented in the Dropbox folder).


1Password Version: 6.8.3
Extension Version: 4.6.12.90
OS Version: 10.12.6
Sync Type: Dropbox

Comments

  • brentybrenty

    Team Member

    @mikeinPDX: Hmm. I can't paste into macOS password fields like that here, and I don't remember every being able to (copy is always disabled there too). This StackExchange discussion ca. 2013 seems to bear that out. You can always save the password in the Keychain after entering it, but I'm not aware of any way to paste there directly, whether you're using Knox or mounting an encrypted Time Machine drive.

  • I use an app called Force Paste when I need to paste into dialogs that disable pasting.

  • Andrew_AGAndrew_AG

    Team Member

    Looking at the screenshot you sent, that's not Knox but rather macOS trying to open the .sparsebundle you're trying to unlock, and I don't believe it's ever been possible to paste a password that way. We can't troubleshoot pasting into .sparsebundles, so you'll need to contact Apple support for any assistance with that, but since that's not Knox you could just open the vault with Knox instead of using maOS to do so, since you can paste into Knox. Just right-click (or Control-click) the sparsebundle in the Finder and select "Open With > Knox" and you should be able to paste in the password.

  • Face palm!

    @Andrew_AG nailed it. macOS was trying to open the sparsebundle with DiskImageMounter. I set macOS to open sparsebundles with Knox and was able to paste in the vault's password from 1P. Phew! Access to valuable files restored.

    Thank you all for your rapid replies!

  • Andrew_AGAndrew_AG

    Team Member

    You're very welcome, @mikeinPDX. I'm glad to hear that did the trick. :)

  • brentybrenty

    Team Member

    Sorry for not being clearing in my original response. Glad that helped! :chuffed:

    P.S: Thanks for that link, @pervel! That's really interesting. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file