Extension not filling fields after pressing Enter

I am experiencing an issue where the extension doesn't always fill in the username and password fields. Overall the app is working as expected... If I press ctrl+(period) I get the extension menu that pops up and finds the correct website that I am currently at, then I should be able to press Enter and the username and password fields will be filled.

However, with some websites that have a pop-up box for the username and password, the fields aren't being filled correctly. This issue has been pretty intermittent for me and I can't always get it to replicate. So far I've had the issue on Hellofresh.com and chase.com. I'll update if I find more conclusive examples. Thanks


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • beyerbeyer

    Team Member

    Hey @ForbQuiet,

    To me, the most probable reason for this would be an issue connecting to the 1Password.com servers. If your item can't be downloaded, then you would result in the symptoms you described. In the future, we plan to have a secure cache of your items to prevent issues like this. In the meantime, I'm pushing for us to have a better way let users know there's a network issue (which could be on our side or theirs).

    To back up this theory, the next time you try filling on one of these two sites and nothing happens, can you please try the following?

    1. Select Window (from the menu bar) > Extensions.
    2. Enable the Developer mode checkbox at the top.
    3. Click the background page link that is now visible under the 1Password extension.
    4. Click the Console tab in the new window that was opened.

    Assuming this is a website that usually works, you'd very likely see an error there. If it's a network issue, you'll see something like this:

    Failed to load resource: net::ERR_INTERNET_DISCONNECTED

    Error: Request timed out. This probably means that you’re not connected to the Internet or our servers are down.

    Please let me know if you see something different and thanks for your help!

    --
    Andrew Beyer (Ann Arbor, MI)
    Lifeline @ AgileBits

  • Hey, so I tried what you suggested but I believe it may be a problem with the specific web page because I can go over to their main sign in page and my login info will generate correctly and I can sign in in another browser tab. I'm getting this error only on specific pages, in this case, it is their help page that requests a login. Especially since the 1password app has to query the server before it can find any of my vault information. Also, the app will find my information but when I press Enter to fill...that's when nothing happens. Here is a screenshot to show what I'm seeing.

    Not sure if that link will work correctly...
    Another thing, the console does show an error message but I believe that was from a previous time, after each attempt to fill my information the console only shows "Start" and "End". Here is another screenshot

    You can see at the top the end of the No Internet Connection error, but I tried to fill it multiple times and thats where the multiple entries of Start and end come from towards the end of the console.

    Sorry if this is unclear at all...
    I believe the error has something to do with the app not finding the input fields on certain web pages or something because like I said it is only on some web pages, specifically ones that have a pop-up type login box. It's like the app can correctly find the webpage I'm at but can't find the fields on where to put the information.

    Anyway, relatively small issue because I haven't come across it a whole lot, but thought you guys should know. Great work though!! Loving the Chrome app :D

  • beyerbeyer

    Team Member

    Hey @ForbQuiet,

    Thanks for the screenshot. I was able to reproduce your filling issue, and it is likely caused by the login form you're attempting to fill coming from Zendesk (via an iframe) instead of HelloFresh. I've opened an issue on your behalf and we will dig into it.

    Thanks for taking the time to clearly show us what you're seeing. We will be updating our filling logic as frequently as possible, but please don't hesitate to let us know if you run into any other sites not filling properly.

    --
    Andrew Beyer (Ann Arbor, MI)
    Lifeline @ AgileBits

    ref: b5x-124

  • Ok great. Thanks. I know I saw it on another site I just can't remember what it was. If I run into it again I'll update.

  • beyerbeyer

    Team Member

    :) :+1:

    --
    Andrew Beyer (Ann Arbor, MI)
    Lifeline @ AgileBits

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file