0.9.9 released – our third (and last?) Release Candidate!

dtearedteare Agile Founder

Team Member

We were too excited this weekend to rest and instead added some nice enhancements for you to start the week with. This is our third and possibly last release candidate, so if you encounter any issues, please let us know!

This update is working its way through the Chrome Web Store update process now and should be available for everyone in about an hour from now. Here's the full changelog:

[NEW] Can now use ⌘\ to open 1Password, even in fields that are not decorated with an icon.
[IMPROVED] Now decorating newly added fields with the 1Password icon when needed.
[IMPROVED] Better Italian and Russian translations.
[IMPROVED] Many UX improvements to the Save Login window, including better keyboard support.
[IMPROVED] Saving a login on a site with iframes now does a better job of detecting the best username and password to save.
[FIXED] Can now show Save Login window on sites that use iframes.
[FIXED] The page is no longer scrollable while the Save Login dialog is open.

Please put this new version through its paces and let us know how it goes.

Thank you! <3

Comments

  • Many thanks for frequent updates. However, I'm still confused with auto-locking.

    We have "Lock 1Password after system is idle for XXX minutes" and regardless what I put in there the extension gets locked before time's up. It seems that the value is simply ignored. From the logs I see that actually the extension gets locked whenever my laptop gets locked. Is this the case?

  • sfringersfringer Junior Member

    Interesting @Dominik_Skorka , in my experience (granted on my Macbook where the extension got synced) the extension has not locked since I launched Chrome this morning (several hours now), despite having walked away from my system for more than the timeout set, though not having manually locked my Macbook.
    I haven't had a chance to test on my Chromebook yet.

  • beyerbeyer

    Team Member

    Hey @Dominik_Skorka,

    I sincerely apologize for the confusion! There are some issues with Chrome's idle API which we rely on to inform us when a user has gone inactive. We are also supposed to get a notification when a user locks their computer. However, after digging into Chrome's source code, it seems this notice was built around Linux screensavers being the primary "lock screen." After further testing, I've found varying results across multiple Window Managers which is not ideal (pun entirely intended). I'm in the process of writing up a comprehensive bug report for the Chromium team as well as a support article for our users. So far Mac and Windows appear to be working as we intended and will lock 1Password when the system is locked. On Linux, we lock after the auto-lock timeout if the idle API doesn't detect any user activity and if Chrome completely stops running (suspending your computer, quitting, kill, etc.). There is still one case that I've recently found where user input on the KDE (tested on Plasma 5) lock screen is getting registered as user activity in Chrome. Unfortunately, we can't poll the operating system ourselves as a browser extension.

    I'll have that support article very soon that describes our findings in more detail. In the meantime, please let us know your OS, Window Manager (if Linux), and Chrome version if you believe 1Password is remaining unlocked after being away past your configured auto-lock time. I have enabled a verbose logging method which can be used by anyone who thinks 1Password isn't locking as expected.

    --
    Andrew Beyer (Ann Arbor, MI)
    Lifeline @ AgileBits

  • beyerbeyer

    Team Member

    There is still one case that I've recently found where user input on the KDE (tested on Plasma 5) lock screen is getting registered as user activity in Chrome.

    Quick update on this, we've come up with a compromise where we monitor the actual activity of Google Chrome, while letting Chrome monitor the activity of your machine. We will be releasing our first docs very soon which will cover this slight caveat, but the bottom line is if you stop using Chrome for longer than 30 minutes 1Password will auto-lock. As long as you don't go 30 minutes without opening, closing, or navigating on any tab we will respect your auto-lock settings based on the activity information Chrome provides to us. My hope is we can either improve this in a later release or Chrome will catch up with the times and provide us better data.

    --
    Andrew Beyer (Ann Arbor, MI)
    Lifeline @ AgileBits

  • caseycropcaseycrop
    edited November 2017

    I still have the problem that the extension periodically goes white and becomes unusable. This happens often and restarting the browser doesn't resolve it. To be honest I haven't been participating so much in the beta because the addon is unusable most of the time. I kept waiting for this bug to be fixed so I could use the addon and start participating. But now we're approaching 1.0 and I still can't use the addon, so I guess I better speak up.

    Here's a screenshot:

    Chrome, Fedora, Gnome 3

  • brentybrenty

    Team Member

    @caseycrop: Totally, thanks for letting us know! Can you tell me which version of Chrome you're running there? Have you tried using 1Password on a new profile without other extensions installed? That might help eliminate some external factors.

  • Sure @brenty, my Chrome version is 61.0.3163.100. I haven't tried the new profile, but I'll give that a go. Also this morning I uninstalled the extension and reinstalled it, and so far I haven't encountered the error again.. maybe it was some cached data causing an issue? We'll see over the course of the day if it pops up again.

  • @beyer thank you for in-depth explanation.

    This is my setup:

    • Chrome: 62.0.3202.94 (Official Build) (64-bit)
    • Ubuntu: 17.10, Gnome 3.26.1

    Looking forward your final expertise.

  • sfringersfringer Junior Member

    @beyer I was away from my Macbook Pro (Mid-2014 - 10.12.6 (16G1036)) for about one hour this morning, Chrome (62.0.3202.94 (Official Build) (64-bit)) was minimized to the Dock. The system was not locked. I'm pretty sure no activity should have been registered on the Mac. When I brought Chrome back up from the Dock, the 1Password extension was still unlocked; my expectation was that it should be locked. Is my expectation wrong, or is there something occurring in Chrome that registers as activity, and hence keeps the extension from locking?

  • dtearedteare Agile Founder

    Team Member

    @caseycrop: Whew! I'm glad to hear reinstalling the extension fixed the issue you were encountering. I suspect what was happening is early on in the beta we had a bug where multiple copies of the same account could be added and it would confuse 1Password. Reinstalling would have gotten you back to a good starting place.

    @Dominik_Skorka, @sfringer: Beyer was travelling late yesterday and will be offline for a while so I thought I'd jump in. There is an issue in Chrome on certain window managers (KDE is the one I know of OTTOMH) that tells 1Password that your machine is active when it really isn't. Thankfully Beyer gave me an awesome pull request to review yesterday that addresses this issue and it will be available in the final release. I'm sure Beyer will jump in here with more details once he gets settled after his travels.

    Thanks again for the issue reports, everyone!

  • sfringersfringer Junior Member

    @dteare thanks much for the quick follow-up, I appreciate the information.
    On a positive note on my Chromebook, and the reason I started using this extension, the lock behavior is working as expected.
    Thanks again!

  • dtearedteare Agile Founder

    Team Member
    edited November 2017

    That's great to hear! Thankfully that's been the experience for most of us as well. We were going crazy trying to pinpoint this edge case for a while as it worked for so many people on so many platforms, but thankfully Beyer figured it out it was related to specific window managers. I was happy he found that as I like having my sanity :)

  • @dteare Just an update that I haven't had the whitescreen issues since reinstalling. Thanks!

  • brentybrenty

    Team Member

    Really great to hear! Thanks for the update. :chuffed:

  • dtearedteare Agile Founder

    Team Member

    Beautiful! That's music to my ears. Thank you so much for singing that sweet sweet song to me, @caseycrop :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file