Clicking "Use Suggested Password" and "Save Password" don't do anything? [remove Screen Shader]

edited November 2017 in 1Password X

hi all!

I've been a keepassx user forever since I use linux, so I was excited to give 1password x a try once I heard about it. I'm trying it out on my Chromebook first.

However, I can't seem to get it to work. Password fields show the little 1pass icon as a popup, but clicking on the "Use Suggested Password" and "Save password" tooltips don't seem to have any effect, they just dismiss themselves.

Am I missing something?


1Password Version: Not Provided
Extension Version: 1.01
OS Version: ChromeOS 62.0.3202.82
Sync Type: Not Provided

Comments

  • I'm also experiencing this problem.
    X version: version 1.0.1
    Chrome version: Version 62.0.3202.94 (Official Build) (64-bit)
    other enabled extensions and version:
    AdBlock 3.20.0
    Chromebook Recovery Utility 3.1.7
    crouton integration 2.5.2
    Docs 0.10
    Google Docs Offline 1.4
    Super Neutron Drive 15.4.1
    Text 0.5.68
    TooManyTabs for Chrome 2.2

  • khadkhad Social Choreographer

    Team Member

    Hi @stillinbeta and @lukelane124,

    Thanks for trying 1Password X. Sorry you're having some trouble.

    • Is there a certain website where you are having trouble, or is it all websites? Just to get us on the same page (metaphorically and literally), can you try https://evernote.com/ ?

      Use Suggested Password is working as expected for me there, so it will be a good way to test.

      Also, while you can save a login before entering anything on the page, Save in 1Password works best if you enter your details before selecting it. Then everything you entered on the page will be saved. (If you make a mistake and the login is incorrect or incomplete, you can update it. Make your changes, then click the 1Password icon and choose Update Saved Login.)

    • Does the problem only exist on your Chromebook(s)? Are you able to test on a different computer?

  • The evernote website worked perfectly. I chose "use suggested" the password was filled and the account was added to the extension.
    I am running on osx 9.5 (Mavericks for backwards compatibility reason).

    I'm having trouble with amazon when updating an existing password (on amazon, not in vault already). I choose use selected in the upper "new password" field, it is populated but I don't get a notification that the login has been saved.

  • khadkhad Social Choreographer

    Team Member

    Excellent! Thanks for letting me know things are at least working correctly on one site. Let's see if we can figure out what's happening on Amazon for you.

    I just tested and it appears to be working as expected. This is what I'm seeing. Does it make a difference if you disable all your other extensions temporarily and then reload the page?

  • @khad I just checked evernote, trying to sign up on the mane page. The same thing happens, clicking just dismisses the popup.

    In comparison to your gif, hovering over the items in the dropdown list doesn't highlight them, they stay the same colour.

  • @khad ahhh, I just figured it out! I have a chrome extension called Screen Shader that makes my screen not quite so bright during the day (a la Flux). Turning that off fixes all my issues with 1 Password X!

    Chalk this one up to User Error :)

  • beyerbeyer

    Team Member

    @stillinbeta: Oh that's very interesting! Out of curiosity, I'm going to check out that extension to see what might've caused that.

    If we can be of further assistance, please let us know. We are always here to help!

    --
    Andrew Beyer (Ann Arbor, MI)
    Lifeline @ AgileBits

  • khadkhad Social Choreographer

    Team Member

    Aha! That's really good to know. I'm glad the solution was so simple. I'll leave it to beyer to see if there is anything we can improve to not get clobbered by Screen Shader (or other similar extensions).

  • Hi, very funny but I had exactly the same issue. It seems 1Password X can't be used in conjunction with Screen Shader!

  • beyerbeyer

    Team Member

    @ishann: Thanks for letting us know you ran into the same issue. We are in the process of adding a nifty notification to warn users of any potential extension conflicts as we come across them. I've never used Screen Shader, but after testing it, I experienced weird window repositioning which I suspect is the root cause of this issue.

    Sorry for the incompatibility!

    --
    Andrew Beyer (Ann Arbor, MI)
    Lifeline @ AgileBits

    ref: b5x-164

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file