Remember Secret Key after Chrome restarts

Hi, I am having the problem that the secret key is not being remembered when the browser closes. Every time I restart Chrome, I have to re-enter my username, secret key and master password. Then I get another email saying that there is a new 1Password sign-in. If I go to "My Profile" my computer is registered as an authorized device multiple times.

Is this expected behaviour? It only occurs on my Ubuntu machine---when I use 1Password X on MacOS, it seems to remember the secret key.

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided


  • MitchMitch

    Team Member

    Hi @mikid0,

    Is it possible you have Chrome set up to clear local storage when you quit? Please go to: chrome://settings/content/cookies and double check that the setting "Keep local data only until you quit your browser" is turned off.

    Let me know if the setting checks out but you still run into this issue when you restart Chrome. :)

  • Hi Mitch, thanks for the reply. That setting is definitely turned off---the cookie settings that I have are:

    Allow sites to save and read cookie data (recommended) - ON
    Keep local data only until you quit your browser - OFF
    Block third-party cookies - ON

  • MitchMitch

    Team Member

    Got it, thanks for looking into that.

    Let's take 1Password X out of the equation for a bit. Try signing in directly from > Sign In, then quit Chrome and repeat. Are you still asked for all your info?

  • Hi Mitch, apologies for the delay in replying.

    I tried your instructions, and yes I still need to re-enter my secret key (and username/password!) when logging into

  • bundtkatebundtkate

    Team Member

    @mikid0: Mitch is out for a well-deserved weekend and will likely be more useful than I at the end of the day, but just as one thing to check while he's away -- do you have any tools on this computer that might be clearing your browser cache? You Secret Key is cached by your browser, which is what allows future sign-ins to be simplified (you only need your Master Password), but I can imagine some security software or even software intended to speed up performance might automatically clear that cache for you preventing this from working properly.

  • edited December 2017

    Hi, all. I had this same problem and think I have found the cause. I run a privacy app called Cookie on my Mac. Cookie was deleting a Local Storage database called leveldb in Chrome each time I quit that browser. I made leveldb a Favorite in Cookie so it no longer gets deleted. My problem seems to be solved.

    No idea if @mikid0 uses something that deletes Local Storage in Chrome. But, I would look around to see if anything is deleting leveldb and see if you can prevent that from happening.

    Good luck!

  • Hi, all. Thanks for the replies.

    I am not aware of any apps/tools that are clearing the browse cache. I rebooted this morning, and the "" cookie is dated 29 November. I can't see "leveldb" as a local storage database (thanks for the suggestion @marclafountain!), which may mean it was never there, or has been deleted---I will have to keep checking.

    Just for the avoidance of doubt, I had to enter my secret key again this morning.

  • brentybrenty

    Team Member

    @marclafountain: Thanks for sharing! Indeed, 1Password X (and use the browser's local storage for this, so anything that is clearing that will "reset" things and you'll have to sign in from scratch.

    @mikid0: Just to clarify, we're not using cookies for login state, as those are stored in plaintext on the machine and would be really insecure. So clearing only the cookies should not have an impact on this, only local storage. You can find it here though:

    ~/Library/Application Support/Google/Chrome/Default/Local Storage/

  • dtearedteare Agile Founder

    Team Member

    Thanks for the update, @mikid0.

    You mentioned in your original post that things were working as expected on macOS. That's great news and means that you won't want to use that folder path Brenty posted above as that's specifically for Mac. To be honest, I'm not sure where things are stored on Ubuntu but by the looks of things in your previous post, you already found the Chrome settings folder so you should be able to find the local storage folder without too much trouble :)

    I'm not sure of the cause but my first suspicion is there's an app somewhere that's cleaning things up for you when Chrome closes. I know you mentioned you're not aware of having any apps installed that do that, but so many apps do these types of things nowadays it's easy to have one without knowing.

    My second suspicion is perhaps Chrome is unable to write out your local storage settings for some reason. Perhaps verify the file permissions and also try creating a new Chrome Profile and see if that changes anything.

    Please let us know how it turns out. You have our curiosity piqued! :)

  • brentybrenty

    Team Member

    @mikid0: I apologize for getting things turned around earlier. Since you're having this issue in Chrome on Ubuntu (oops), you should be able to find Chrome's local storage in this location:

    ~/.config/google-chrome/Default/Local Storage

    Or, for Chromium,

    ~/.config/chromium/Default/Local Storage

    You could open Terminal and cd ~/.config/google-chrome/Default/Local\ Storage to monitor things there for changes...but I wonder if nothing is getting saved there at all.

    Again, sorry about the mixup.

  • @dteare and @brenty: thanks for the response, and no problem about the mixup.

    I had been monitoring ~/.config/google-chrome/Default/Local\ Storage for the last couple of days. The only content is the leveldb folder, which seems to be where the 1Password X content is stored.

    When I exit and restart chrome, the following message would appear in leveldb/LOG:

    [email protected]:~/.config/google-chrome/Default/Local Storage/leveldb$ cat LOG
    2017/12/08-09:29:39.368 12309 Reusing MANIFEST leveldb/MANIFEST-000001
    2017/12/08-09:29:39.375 12309 Recovering log #4
    2017/12/08-09:29:39.385 12309 Reusing old log leveldb/000004.log 
    2017/12/08-09:29:39.390 12309 Delete type=0 #3
    2017/12/08-09:29:50.885 12309 Level-0 table #8: started
    2017/12/08-09:29:50.927 12309 Level-0 table #8: 154344 bytes OK
    2017/12/08-09:29:50.935 12309 MANIFEST write: IO error: leveldb/MANIFEST-000001: FILE_ERROR_FAILED

    The permissions on leveldb were rw for my userid only. I added g+rw the permissions on leveldb and leveldb/MANIFEST-000001, and I think this resolves the issue.

    When I restart the leveldb/LOG now contains:

    2017/12/08-09:47:35.131 14440 Reusing MANIFEST leveldb/MANIFEST-000001
    2017/12/08-09:47:35.138 14440 Recovering log #7
    2017/12/08-09:47:35.146 14440 Reusing old log leveldb/000007.log 

    I need to test over a reboot (which I can't do right now, unfortunately), but it seems to be a permissions issue. I will let you know the outcome.

  • dtearedteare Agile Founder

    Team Member

    Awesome! Looks like you've solved the mystery :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file