1Password for iOS filling

2»

Comments

  • AMCarter3AMCarter3 Junior Member
    edited December 2017

    As I continue to test and explore ways to get 1P login's working more consistently on my iPhone and iPad, I noticed something really odd about syncing across my 3 devices in my 1P account. All 3 devices (iPhone, iPad & laptop) appear to be connected to the same 1P vault. But, they are clearly not sync'ing perfectly with each other now. So, I created 3 test login's - one each on my phone, iPad and computer and watched. Here's what I see...

    1. Computer -- The test login created on my laptop sync'd TO my phone and iPad instantly. No issue here.
    2. iPhone -- The test login created on my phone sync'd TO my iPad instantly, but NOT to my computer... not after about 20 mins.
    3. iPad -- The test login created on my iPad sync'd TO my iPhone instantly, but NOT to my computer... still not after about 20 mins.
    4. Even though I created a new "test" login on my iPhone and on my iPad, the total number of login's listed in my login category list on my iPhone and iPad did NOT change... it stayed at 770.
    5. However, the total login's on my computer increased to 771 reflecting the one new "test" login I created.

    BUT WAIT... it all changed after about 30 mins.... Now, here's what I see:

    1. Computer -- The only test login showing on my laptop is the one created on the laptop. The test login's created on my phone and on my iPad have never shown up on my laptop. The total login count is 771.
    2. iPhone -- All 3 "test" login's show on my phone and the total count is 774.
    3. iPad -- The only test login showing now on my iPad is the one created on my laptop. The other 2 test login's disappeared. The total count is 771.

    Very weird behavior. Maybe this is associated with the inconsistent my login issues on Amazon, Chase, etc. on my iPhone and iPad (but not on my computer). What do you suggest I do to get all 3 devices sync'ing correctly with each other?

  • BenBen AWS Team

    Team Member

    @AMCarter3

    Are you using a 1Password.com account, or a 3rd party sync service?

    Ben

  • AMCarter3AMCarter3 Junior Member
    edited December 2017

    1Password.com account.

    I rebooted all 3 devices last night and this morning all 3 devices appear to sync OK, I created 2 more Test logins - one on my iPad and one on my iPhone. They both sync'd instantly with each other AND they both showed up on 1P on my laptop. That's good progress.

    However, the total login count still varies... 1P on my iPhone and iPad started up this morning with 770 logins and still shows 770 logins, despite the fact that I just added 2 more test logins. 1P on my computer shows 772 - reflecting the 2 new test logins I just added. Something is still not "right".

  • BenBen AWS Team

    Team Member

    Thanks. And for the iOS devices... you’re aware that the extension does not do any syncing? Only the main app syncs... So if you add a new login through the extension it will not appear on your other devices until you launch the main 1Password app. Could you please confirm you were launching the main app for each test?

    Ben

  • AMCarter3AMCarter3 Junior Member

    I'm not entirely sure what you mean by "Extension". I added the test logins by opening the 1P app on my phone, iPad and laptop and clicking on the "+" sign in the menubar.

  • BenBen AWS Team

    Team Member

    Thanks, @AMCarter3. That answers my question. Could you please try testing this for me?

    From each device create a new item using the same procedure you have been. Once you have created the item sign in to your 1Password.com account through the web interface ( https://signin.1password.com/ ). Check to see if the item you created appears there.

    Please report which devices have added items but have not had their items show up on the website.

    Thanks.

    Ben

  • AMCarter3AMCarter3 Junior Member
    edited December 2017

    Ben, I did that... created a new TEST login on all 3 devices. All 3 showed up instantly on all devices AND on my web interface account. However, the login count is still inconsistent -- it still shows 770 on iPad and iPhone... and 775 on my laptop (reflecting the 3 logins I just added.

    Is there some way to show the item count for all categories on the web interface? All I see is the grand total for all items.

  • Before you can send a diagnostics report, you’ll need to set up an email account on your iOS device.

    I also find this a bit confusing; it suggests I need to do something now / in the future (instead of already having done something in the past), because of the ’ll.

    What about this?

    Sending a diagnostics report is only possible if you have configured an email account in the Settings (App) of iOS.

    Additional sentence with link to KB article might be:

    (Learn how to do this)

    Optional third sentence:

    We do not support third party mail clients available in the App Store.

  • BenBen AWS Team

    Team Member
    edited December 2017

    Thanks, @XIII. :)

    Ben

    ref: akb-1213

  • brentybrenty

    Team Member

    Ben, I did that... created a new TEST login on all 3 devices. All 3 showed up instantly on all devices AND on my web interface account. However, the login count is still inconsistent -- it still shows 770 on iPad and iPhone... and 775 on my laptop (reflecting the 3 logins I just added.

    @AMCarter3: Just to clarify, are you missing items on one or more devices, or is it just the count that's throwing you off?

    Is there some way to show the item count for all categories on the web interface? All I see is the grand total for all items.

    Yep! If you have All Vaults selected in the 1Password.com web interface the item count for "All Items" will reflect the total of all of the vaults in your account:

    Just keep in mind that if you have any other vaults in the app on one of your devices, or have hidden one or more vaults there, what you see there will be different from the website. Let me know what you find!

  • AMCarter3AMCarter3 Junior Member
    edited December 2017

    Brenty,

    I asked "is there some way to show the item count for all categories on the web interface? All I see is the grand total for all items." I have 2 vaults -- 1) personal (I don't use it) and 2) shared (my wife and I use it). they appear on all 3 devices and online. When I show all vaults online, I don't see the count for each category... I only see the total item count. So, I have no real way of telling if some login is missing from one of my devices. But, I did learn that my phone and iPad were set to "save" new items to my personal vault; not our shared vault.

    Unless there is some preference setting that I cannot find for my online vault, I recommend that this be corrected so the category count can be seen online so it can be compared to the category count on devices.

    Right now, 24 hours later, the total item count and the total login count online match on all 3 devices. All "Test" login's show in all 3 devices in the same vault.

    I just added two more rounds of Test logins on each device and online. They all matched up across all 3 devices and online almost instantly, but not quite online. All 3 devices are set to show all vaults. Yet, my phone and ipad show 1076 total items and 775 logins... and my laptop shows 1082 total items and 781 logins. Note the 6 digit discrepancy matches the 6 Test logins I created.

    CORRECTION... after a delay of about 15-20 mins, all item numbers match up.

    Any speculation as to why it took more than 1 hour for the item counts to completely match up last night and about 20 mins tonight? My internet connection is not the a problem.

  • brentybrenty

    Team Member

    Brenty, I asked "is there some way to show the item count for all categories on the web interface? All I see is the grand total for all items."

    @AMCarter3: Totally. "All Items" includes items of all types, so "all categories" is implicit in that: the items from any category are included in that count. Sorry for the confusion.

    I have 2 vaults -- 1) personal (I don't use it) and 2) shared (my wife and I use it). they appear on all 3 devices and online. When I show all vaults online, I don't see the count for each category... I only see the total item count. So, I have no real way of telling if some login is missing from one of my devices.

    Ah, maybe I misunderstood then. The 1Password.com web interface does not have counts for individual categories, if that's what you meant. But again all of those will be included in All Items. Since you said you'd created items that weren't syncing to other devices, I'm just trying to establish that some items are actually not present on some of your devices, or in 1Password.com. Certainly if there's a bug with the count we want to address that, but rather than fixating on numbers my primary concern is that you're not missing data, if that makes sense.

    But, I did learn that my phone and iPad were set to "save" new items to my personal vault; not our shared vault.

    Depending on your settings, that might be it right there. It isn't possible to hide vaults from All Vaults in the web interface, so double check that on your devices (Settings > Vaults > All Vaults, or Preferences > All Vaults). For example, if you had the Personal vault hidden because you don't want to use it, but you had 1Password setup to save new items there, that could explain why you had trouble finding things before.

    Unless there is some preference setting that I cannot find for my online vault, I recommend that this be corrected so the category count can be seen online so it can be compared to the category count on devices.
    In addition, right now, 24 hours later, the total item count and the total login count online match on all 3 devices. All "Test" login's show in all 3 devices in the same vault. I even did two more rounds of creating Test logins on each device and online. They all matched up across all devices and online almost instantly tonight.

    Great! I think only you would be in a position to say for sure, but it sounds like the Personal vault may have contributed.

    Any speculation as to why it took more than 2 hours for the login counts to match up last night? My internet connection was not having a problem. Or, maybe the discrepancy was related to where the new logins were being saved on my phone and iPad? That confuses me... while the new logins were being saved to my personal vault, they showed in our shared vault.

    Unless there's evidence to the contrary, usually the simplest explanation is the most likely. It's certainly possible that your device(s) had trouble connecting to send or receive changes from 1Password.com. This most frequently happens due to a problem establishing a secure connection. 1Password.com will reject it otherwise. But it really sounds like you were just saving new items somewhere you didn't expect, so it would be understandable if you weren't looking in the right place as a result. Let me know what you find!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file