1Password X not setting Secure input

When I use 1Password X, it doesn't seem to enable secure input when I type my master password. As a result, TextExpander is now suggesting my master password for abbreviation. Is this by design? Can I change this?


1Password Version: X 1.2.0
Extension Version: X 1.2.0
OS Version: OSX10.13.1
Sync Type: Account

Comments

  • brentybrenty

    Team Member

    @Verbal_Kint: Heya, Kai...I mean Verbal! :crazy:

    Glad you reached out! Unfortunately this is handled by Chrome, as 1Password X is not a native app that can interact with macOS directly. As far as I can tell, Chrome isn't using Secure Input at all. I swear it used to, but I'm not seeing that in any password field. It seems to be just programmatically disabling copying. Secure Input isn't something we can enable in the extension directly, but we'll see if there's something else we can do to help.

    You can, however, set exclusions in TextExpander itself:

    I hope this helps. Be sure to let me know if you have any other questions! :)

  • Thanks for the workaround @brenty. And the laugh.

  • beyerbeyer

    Team Member
    edited December 2017

    That @brenty is one funny fellow! I'm delighted to hear he could help you out.

    I use TextExpander as well but disabled suggesting snippets altogether a long time ago. I found myself in way too many situations where it would monitor text I wasn't comfortable with, like entering my Master Password within a virtual machine. Luckily 1Password was quick to suggest some replacement passwords for me. :tongue:

    Have a great week and let us know if you have any additional questions! :)

    --
    Andrew Beyer (Ann Arbor, MI)
    Lifeline @ AgileBits

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file