Change the order of vaults - get me ⌘2 back!

I just added another vault and unlike the 4 previous vaults I added, this one added itself in the #2 position, disrupting my keyboard shortcut muscle memory. I know many others have asked for this feature, so please add my +1 to the chorus!


1Password Version: 6.8.4
Extension Version: Not Provided
OS Version: macOS 10.13.1
Sync Type: Dropbox
Referrer: forum-search:Ordering vaults

Comments

  • brentybrenty

    Team Member

    @JasonGarber: Thanks for letting us know you'd like to be able to reorder vaults manually. I can't promise anything, but it's something we'd like in the future as well. Cheers! :)

  • sjksjk oversoul

    Team Member

    Hi @JasonGarber,

    It is possible to (re)assign shortcuts used for switching vaults in 1Password for Mac by changing them in System Preferences. Here's an example of swapping the vault switching order of ⌘2 and ⌘3 shortcuts, set to standalone Demo and test vaults (respectively) by default.

    Setting ⌘2 to the test vault:

    After setting ⌘2 and ⌘3 for the main app and mini:

    Clicking All Vaults in the main app shows the shortcuts have been swapped:

    Also under the Switch to Vault menu:

    And in 1Password mini (after it's restarted):

    This does work, while admittedly not the easiest or most elegant method. And when you have multiple vaults with the same name (e.g. Personal and/or Private while signed in with multiple accounts, a shortcut assigned to one of them only applies to the first vault or can even be overridden by a default, like after setting ⌘1 to Personal it still switches to Primary in this example:



    Maybe that can help get ⌘2 to switch to the same vault it did before you added the new one. :)

  • edited December 2017

    Thanks, @brenty.
    @sjk: Awesome workaround! Thanks! That'll work great for the problem I presented. Then I went and signed up for a 1Password.com account to try out X, but now it's below a team I don't control, so the ⌘1 problem you mentioned applies. Thanks for giving me a workaround and anticipating my next problem!!

  • brentybrenty

    Team Member

    Glad that workaround helped a bit in the mean time, but we'll keep working to make it easier to deal with a plethora of vaults. Thank you for your feedback on this!

  • +1 require this feature

  • brentybrenty

    Team Member

    Thanks for letting us know you'd like us to add such a feature. :)

  • +1 for reordering vaults

  • BenBen AWS Team

    Team Member

    @spiffytiffy

    Thanks for the feedback. :) Did you see sjk’s suggestion above? https://discussions.agilebits.com/discussion/comment/404343/#Comment_404343
    That may help.

    Thanks!

    Ben

  • @Ben Yes, I’m more concerned about the visual organization when I look at my list of vaults. Thanks!

  • BenBen AWS Team

    Team Member

    Gotcha. Thanks!

    Ben

  • I just ran into this same issue. In 1Password 6 my vaults were in one order, and after upgrading to 1Password 7 they are in a different order! Very frustrating. I guess I will have to try the workaround.

  • BenBen AWS Team

    Team Member

    @craigc123

    Hopefully that works for you. :) Please let us know how it turns out.

    Ben

  • craigc123craigc123
    edited February 11

    So I have set up the shortcuts, but for whatever reason, in 1Password 7 they only work from the menu bar mini 1Password version. When I open 1Password 7 it shows the new shortcuts in the menu but then as soon as I press them they disappear from the menu items, and nothing happens (the vaults do not switch).

    From the menu bar version it switches without any problems.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file