Stop 1Password Android accessibility filling

ashleykashleyk
edited December 2017 in Android Beta

1Password has recently taken to forcing a pop up screen when adding details to various apps and system features that is not at all helpful. In one case my bank's phone app wants to fill in information, which is not even available within 1Password, so I find myself swatting away the pop up screen, but it gets worse.

I've just been trying to set up the Hey Google feature on my phone and up pops 1Password again. At a certain point Google wants my phone's pin code to continue, but I can't add it, because the 1Password pop up has appeared in that place and it won't go away, so access to the phone is now entirely blocked with the pin code entry covered by 1Password's pop up... I guess I'll have to wait for the battery to die before I can use my phone.


1Password Version: 6.7
Extension Version: Not Provided
OS Version: Android 6.0.1
Sync Type: Dropbox

Comments

  • mverdemverde

    Team Member

    Hey @ashleyk,

    The "Autofill with 1Password" pop-up that you are seeing is a result of the new 1Password accessibility service which was introduced in our latest update. If you would prefer not to have the pop-up at all, you can disable it by turning off the accessibility service by going to 1Password > Settings > Filling > Accessibility.

    That being said, I'd love to try to understand the problem that you're encountering so that we can continue to refine this feature. When I go through the steps to set up Hey Google on my device and choose Trusted Voice, I'm also see the "Autofill with 1Password" pop-up when I'm prompted to enter my device's passcode. In my case though, I can see the text field clearly. I'm able to type my passcode as I normally would and I can submit it by tapping the enter key on the keyboard. I can also back out of the passcode screen by tapping the back button.

    so access to the phone is now entirely blocked with the pin code entry covered by 1Password's pop up... I guess I'll have to wait for the battery to die before I can use my phone.

    I'm unable to reproduce a scenario where access to my phone is blocked. Could you help me understand how this is the case for you? Perhaps you could upload a screenshot demonstrating the issue?

  • In my case the pop up covered some of the numbers needed to input the pin code, while it also proved impossible to go back, because the 1Password popup remained active at the forefront and immovable, rendering the back button useless.

    This morning I had another case when I tried logging into a forum using the Yandex browser, where I actually had the login details saved already. Up popped 1Password and offered to fill in the details, so out of curiosity I thought I would try. It asked me to fill in my master password and then came up with a message about Yandex and asked to continue. I gave it the go ahead and nothing happened.

  • fatso83fatso83
    edited December 2017

    I also reported this (KYP-82842-829), but the problem with the solution from @mverde is that it also disables the autofill for the parts that used to work. Autofill works fine otherwise, it's this newly acquired feature of a non-dismissable overlay that causes problems.

    The fix would be to make it possible to remove it by clicking elsewhere on the screen or something like that. Right now it won't budge.

    Here's a video snippet of me using BankID - an sms based application used for 2FA in banks in Norway. The overlay covers the submit button so it's impossible to log in without disabling autofill.

  • That's basically the same problem, but in my case it's slightly different when adding the phone pin code, because the numbers appear as a semi transparent overlay that remains behind the 1Password popup, so certain numbers cannot be physically reached. The result is the same though and this feature needs some refinement. I'm using Android 6.0.1 on a smartphone that's a couple years old now.

  • brentybrenty

    Team Member

    In my case the pop up covered some of the numbers needed to input the pin code, while it also proved impossible to go back, because the 1Password popup remained active at the forefront and immovable, rendering the back button useless.

    @ashleyk: I'm sorry to hear that. Thanks for clarifying.

    I also reported this (KYP-82842-829), but the problem with the solution from @mverde is that it also disables the autofill for the parts that used to work. Autofill works fine otherwise, it's this newly acquired feature of a non-dismissable overlay that causes problems.

    @fatso83: Thanks for the feedback on the beta! That's why we're doing this. :)

    The fix would be to make it possible to remove it by clicking elsewhere on the screen or something like that. Right now it won't budge.

    It sounds like finding a way to make it possible to move or cancel the prompt would help We'll see what we can do! :)

    ref: KYP-82842-829

  • The overlay has been causing issues here as well, possibility to move / cancel the prompt would be best imo.

  • brentybrenty

    Team Member

    Thanks for the feedback! Hopefully we can find a way to make it seamless. :) :+1:

  • It's almost 2020 and this is still an issue. Turning off Accessibility doesn't fix this.

  • brentybrenty

    Team Member

    @1passguy: Can you clarify? With Accessibility filling disabled on the device, you will not see any problems with Accessibility filling, as it's not available at all.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file