Problem with 6.7 APK

Hi v6.7 is putting my phone into a boot loop. Can I get the 6.6.2 APK from an official source please? thanks, H


1Password Version: 6.7
Extension Version: Not Provided
OS Version: Android Cyanogen Mod
Sync Type: Not Provided

Comments

  • brentybrenty

    Team Member

    @mrhash: I'm not sure what you mean. 1Password for Android is not involved in the boot process. The only official source is the Google Play store. You can download it there:

    https://play.google.com/store/apps/details?id=com.agilebits.onepassword

    And if you don't have a Google Account which is not on the beta, you can opt-out so it will allow you to download the stable version instead (usually takes a bit to switch though):

    https://play.google.com/apps/testing/com.agilebits.onepassword

    Let us know what you find though.

  • Hi i don't know why but i've tried twice to install 1Password 6.7 from Google Play and each time my phone crashes on startup. I think it's not the beta, i've deleted the app from my phone and it's running fine. I'd like to install the previous version that was working (6.6.2 i guess). If not i can download it from a mirror but in that case an apk checksum would be appreciated so i can verify the download.

  • brentybrenty

    Team Member

    @mrhash: I apologize. You're right. I just wasn't getting 6.7 here earlier. I thought it was still in the process of propagating through Google's servers. Did you send a crash report?

  • I can't send a crash report because the phone reboots on startup. i have to go into the bootloader to remove the app manually.

  • brentybrenty

    Team Member

    @mrhash: Sorry, I mean for the OS, since that's what's crashing. You should still be able to pull it from the device. Android should be logging exceptions unless you've disabled that. There are also free apps that will allow you to view these right on the device.

  • Well i can do that and make a report, but in the meantime can i get a checksum for the 6.6.2 so i can verify an apk download? thanks

  • mverdemverde

    Team Member

    @mrhash We only support downloading and installing 1Password from Google Play. With that in mind, I advise against downloading 1Password from other sources. Beyond the obvious concerns with potential tampering, it also adds barriers to keeping 1Password up-to-date, which is an essential part of staying secure.

    We haven't received any other reports of an issue like this and I see from your original post that you're running Cyanogen Mod. Although we don't support rooted devices or custom ROMs, I would like to try to understand how 1Password might be related to the issue you're experiencing. Could you provide me with the following details?

    1. Which version and build number of Cyanogen Mod are you running on your device?
    2. What steps do you follow before encountering the crash that triggers your device to reboot?
    3. Are you enabling any 1Password services before encountering the crash (such as the keyboard or the accessibility service)?

    Any additional details that you can provide should help shed further light on possible causes for the reboot.

  • Hey @mverde thanks for following up on this. Here's the answers:

    1. 12.1-20151117 on a Samsung S4 mini
    2. I simply updated 1Password from the google play store and then the phone crashed and everytime the phone restarts it has to reoptimize all the apps (presumably dalvik cache is wiped or corrupted).
    3. No extra services changed or set. Just an upgrade, normal install, has been working on the last version or maybe the version before, can't remember exactly which version i was running before, the last update was probably a couple of months ago.

    So following the problem i wiped the 1password folders in /data/app and /data/data, and phone operated fine, then did a clean install from Play store and the same thing happened again. Hope that helps.

  • mverdemverde

    Team Member

    Hey @mrhash, a quick search has me wondering whether this is related to 1Password or if it's simply a coincidence. There is at least some anecdotal evidence on StackExchange that this can happen with CM 12.1:

    https://android.stackexchange.com/questions/134051/cm12-app-install-reboot-issue

    Are you able to pull the logs using adb and see if you encounter the same FileNotFoundException mentioned in the SE post above?

  • The logs here are the best i could extract:

    First attempt: 1password installs then repeated Trebuchet errors on screen. Starting the 1password app causes a reboot but ADB had disconnected at that point.

    Second attempt: 1password install and immediate reboot.

    https://gist.github.com/MrHash/f3b10ca55dc327d3a741381ea3172b47

  • I tried clearing the Trebuchet launcher cache and same problem.

  • mverdemverde

    Team Member

    Although I don't see any logs of FileNotFoundException, there are plenty of references to invalid or corrupted memory addresses. This doesn't look to me like something that is related to 1Password, but instead possibly related to the OS install itself. This is outside the scope of our customer support, but you may need to look at reformatting your data partition or re-flashing the device altogether.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file