Auto-Fill Does not work in Firefox 57.0.1

I have recently updated to Firefox 57.0.1 & have realized auto-fill does not work in certain website which used to work before the update. E.g. "" and also ""

1Password Version: 6.8.5
Extension Version:
OS Version: 10.13.2
Sync Type: icloud


  • brentybrenty

    Team Member
    edited December 2017

    @amitabhbaishya: I'm not sure I follow. What update are you referring to? I was able to save and fill logins at each site using 1Password, though I found that these pages worked more smoothly since they avoid the silly popups:

    Can you tell me more about the problem you're having? To be clear, 1Password does not "autofill"; it only fills when you tell it to, for example using the ⌘ \ keyboard shortcut. Does that not work for you? Let me know what you find!

  • yes you are right it does not fill when i choose the login

  • daltondalton

    Team Member

    Thanks for the confirmation, @amitabhbaishya! Were you able to try the two links that brenty shared with you? 1Password should have an easier time filling those login forms for you since there are no popups to mess with.

    Along with that, could you let us know how you're telling 1Password to fill your Logins? Are you using "open and fill" within 1Password for Mac, pressing the Command-\ shortcut to fill, or clicking on your Login in 1Password mini? Once we know more about how you're using 1Password, we'll be able to more easily try and reproduce any issues you may be having.

  • Hi Dalton, that's right. when I press Command + \ it does not fill for CIBC and Simplii Banking( the links I shared above).

    I have not tried the links that were shared by Brenty because it does not look to be as legitimate links to the banking site. Sorry but i cannot try it there. I will only try it on the two links i shared with you.

  • brentybrenty

    Team Member
    edited December 2017

    @amitabhbaishya: I'm not sure what you're talking about. These are the same site:


    Both are at, just different web pages on their server.



    Both of these are, just different web pages on their server.

    And if you follow your original link, in each case, if you don't fill in any username or password and try to login, you'll be taken to the URLs I gave you — which is how I found them in the first place, not having an actual account to test with.

    It's worth noting that a login saved for either site will not be offered for filling by 1Password if you're at a different site, to defend against phishing attacks. You're welcome to enter the URLs in by hand too. Better safe than sorry.

  • I agree with the problem... for years 1Password worked with autofill for username and password on site and now it does not. (Nothing gets filled in to either the username or password fields). I have to copy and paste to make it work... something has broken in 1Password or CIBC has changed the operation of their website that stops 1Password from working...

  • Hi @amitabhbaishya & @cmc,

    Let's address the sites one at a time and let's start with CIBC.

    I don't have an account with them but I can still test filling at a surface level. I visited and the page that loaded for me had a login form on the right hand side that requested a card number and password. The login form was instantly available without any user interaction with the page. I manually saved a Login item for this page using the steps outlined on our page "How to save a Login manually in your browser" ( ) and then proceeded to test. I tested filling the already loaded page with the keyboard shortcut ⌘\ and I tested open and fill and tested Vivaldi, Chrome and Firefox. In all six tests both the card number and password fields were filled by 1Password.

    On the surface it seems like 1Password is quite capable of working with this page. If there is an issue we will want to learn about it but we will need to be able to reproduce the issue to stand any chance at correcting it.

    To ensure there is no confusion and to give us the best chance at reproducing the issue can you:

    1. Confirm that 1Password is working normally on other sites. By this the best test is to visit the sign-in page for a site you have stored in 1Password, confirm no fields are already filled and that either the keyboard shortcut ⌘\ or clicking on the 1Password Browser Extension and selecting your matching Login item then correctly fills all the required fields.
    2. Save a new Login item using the steps detailed at "How to save a Login manually in your browser" ( ) and attempt to fill using this Login item on the CIBC site. This will help eliminate a number of possible variables and the idea is we should see similar behaviour if we're following the same steps.
    3. Let us know if the page you see differs at all from the page I'm seeing. To make this easier I'm including a screenshot below. The screenshot was taken after 1Password filled the page.

    All my testing was performed on a Mac running 1Password 6.8.6 and the current version of browsers are: Firefox 58 and Vivaldi 1.13.1008.44 (which seems to be based on Chrome 62) and Chrome 64.0.3282.119.

  • As requested, I tested the above and it is perhaps interesting that the "manually save login" does not work (for me) from the location. When I press the gear and select the "Save New Login" option, the 1Password screen disappears and nothing happens. If I try using the "manually save login" procedure from a different website (e.g., Vivint alarm system) the "Save New Login" works perfectly. I am running on a iMac with Firefox 58.0.

    If I first load the CIBC website from and then use 1Password, it does fill and execute correctly, even though the path is stored in the 1Password login configuration. (which as you know, 1Password doesn't change the screen from to since both are at

    But the original question still remains, why can't I execute my saved login configuration that takes me to ? (Since this has been working with 1Password for years....)

  • littlebobbytableslittlebobbytables

    Team Member
    edited January 2018

    Hi @cmc,

    Given I can save and fill from their homepage I'm puzzled. It might be worth us giving a diagnostic report from your Mac a scan to see if anything leaps out to us. If you're happy to do so this link will guide you through the steps and has sections for the various supported versions of 1Password.

    How to send a 1Password diagnostics report

    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is [email protected].

    Once you've sent the report you should received an automated response from us with a ticket ID. Can you post that here please to help us to keep an eye out for it. Given it works for me we should be able to get it working for you as well.

    ref: BEG-44841-182

  • Report sent to support+extension and regular support (wasn't sure which email address to use): #LPF-79166-928 and #BEG-44841-182

  • brentybrenty

    Team Member

    @cmc: Thanks! I see that we've received your messages, so we can continue the conversation there. We'll take a look at the diagnostics and get back to you shortly! :)

    ref: BEG-44841-182

This discussion has been closed.