1Password Extension flashes in Firefox Quantum

I updated Firefox Quantum to 57.0.1 (64-bit) and 1Password Firefox extension icon started to flash. And it doesn't work either. When I call 1Password mini it indicates "Add Firefox Extension..." as if there was no extension installed.
I have found a newer version from Firefox Quantum (57.0.2). After installation the same error occured.
Anyone else with the same problem?


1Password Version: 6.8.5
Extension Version: 4.6.12.90
OS Version: macOS Sierra 10.12.6
Sync Type: Not Provided

Comments

  • daltondalton

    Team Member

    @aroland: Since you're already using the latest version of 1Password for Mac and the 1Password extension, can you try restarting your Mac as a next step? If that doesn't do the trick, I'd like to ask you to create a diagnostics report from your Mac using the following instructions:

    How to send a 1Password diagnostics report

    You'll want to send that diagnostics report to [email protected].

    Once you've sent the report, you should receive an automated response from us with a ticket ID. Please post that number here so we can keep an eye out for it. Once we review the diagnostics report, we'll hopefully have a better idea of what may be going on. :)

  • Dear DaltonD,

    You have right. I restarted my Mac, and everything has improved. I should have begun with this process. Thanks!
    Merry Xmas!

  • daltondalton

    Team Member

    That's great to hear, @aroland! I'm glad restarting your Mac did the trick. Have a great day and don't hesitate to get in touch if you have any follow-up questions! :)

  • edited December 2017

    I am also seeing this behavior, though I haven't rebooted yet.


    macOS: 10.13.2
    Firefox: 59.0a1 (2017-12-23) (64-bit)
    1Password 6: Version 6.8.5 (685004), AgileBits Store
    Browser Extension: 4.6.12.90

    ref: YCZ-37862-349

  • Rebooting has not fixed it.

  • brentybrenty

    Team Member

    @theironborn: Are you seeing the same thing with the stable version of Firefox? I had some issues with beta myself, so it may be affecting the alpha as well.

  • edited December 2017

    I've seen no issues with stable. None in beta either (though I've used it far less) (58.0b12 (64-bit)).

    ref: YCZ-37862-349

  • edited December 2017

    And it seems Nightly 59.0a1 (2017-12-27) (64-bit) doesn't have the issue either. 59.0a1 (2017-12-23) definitely did though.

    ref: YCZ-37862-349

  • jxpx777jxpx777 Code Wrangler 1Password Alumni
    edited December 2017

    While we do listen to bug reports about 1Password not working with a given build of pre-release browsers, we only declare support for the stable releases of Safari, Chrome, Firefox, and Opera because it's not uncommon for prerelease builds to have bugs that break things for a few days.

    Specifically with regard to Firefox, they've been tinkering with some of their build process in ways that have caused some issues, e.g. Bug #1404956. This Nightly process, though, is exactly where these issues should be found and fixed. If you're using Nightly builds, it's a good idea to report bugs or unexpected behavior in Bugzilla. If you want more a stable release, then stick with channels closer to Stable. The continuum between stability and cutting edge features is a balance that you'll have to find for yourself.

    Cheers!

    --
    Jamie Phelps
    Code Wrangler @ AgileBits
    Fort Worth, Texas

    ref: YCZ-37862-349

  • What about Firefox Developer Edition? Today the 1pw add-on stopped working. It's flashing between grey and white and does nothing when I click on it.

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    @scwtech There's currently a bug with Firefox Developer Edition's bundle identifier. We've been discussing this here in the forums, and you can follow this Mozilla bug to see when it should be resolved.

    --
    Jamie Phelps
    Code Wrangler @ AgileBits
    Fort Worth, Texas

This discussion has been closed.