1Password crashes on saving 4 line license key

Hi there,

I just got my Alfred license key. As soon as I add the 4 line license key, 1Password crashes. When I restart 1Password and trying to unlock it, all my Passwords are gone and it crashes again and again. Looks like the 1Password vaults is corrupt.

So, I had to restore from backup. Is this a known issue? What can I do?

1Password Version: 6.8.5
Extension Version: 4.6.12
OS Version: OS X 10.12.6
Sync Type: none


  • brentybrenty

    Team Member

    @howdytom: Thanks for reaching out. I’m sorry for the trouble! I tried this here, and it doesn't seem to have anything to do with it being four lines:

    No problem with that, so the devil's probably in some details you haven't provided:

    1. What kind of vault are you saving to?
    2. What's the format of the license key?

    I'm wondering if there are special characters in it which are causing an issue for 1Password's standard text fields. Thanks in advance!

  • sorry for the delay. I have't received a email notifcation.

    What kind of vault are you saving to?

    I am saving to the default primary vault.

    What's the format of the license key?

    Frankly, I don't know what format Alfredapp uses for the license key. I guess base64 (ASCII) encoding. There are no special characters included. Just lower-upper-case letters, numbers and slashes.

  • I tried again to save the 4 lines license key. Before I’ve copied the key to a text-editor and than pasted it to 1Password. And guess what, it worked out! 1Password doesn’t crash. Maybe the Rich text format caused this issue. Really strange.

    Thanks for your assistance.

  • brentybrenty

    Team Member

    Aha, I think you may be right about the rich text. Thanks for checking, as it's something we can investigate. Glad to hear all is well for you now! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file