Firefox Quantum says 1password script is slowing Firefox down

I just started using Firefox Quantum (57.0.4). 1password is working normally, except that I got a message in the browser when having it try to put the credentials into a log in form, and it said, "A script in 1password is causing Firefox to slow down."

The site it did this on is http://www.sedo.com. It eventually inserted the credentials, but it took about 6-7 seconds to begin doing so. Funny thing is, when I was using Chrome until today, even there I was noticing that for Sedo.com it also took a very long time before the credentials were placed into the fields. So, it sounds like a 1password bug, not Firefox--it's only that Firefox issues a warning message to me.


1Password Version: 6.8.5
Extension Version: 4.6.12.90
OS Version: MacOS 10.13.2
Sync Type: Not Provided

Comments

  • brentybrenty

    Team Member

    @slobizman: Indeed, all code that's run has an impact on performance, and the 1Password browser extension must use Javascript to work with Firefox's APIs to save and fill in the browser. Though it's likely that if there was a bug in 1Password you'd be encountering the same issue across other sites as well, it's definitely worth investigating. At a glance, there seems to be a lot going on on that page, and they've got a number of their own scripts, some trying to load missing elements, which could certainly have an impact. I'll ask someone else to take a closer look here to see if there's anything we need to do to improve 1Password, but initially it seems like the site itself is just over-engineered. Thanks for bringing this to our attention! And, frankly, Firefox for bringing it your yours. ;)

  • Hello @slobizman,

    The homepage for sedo has 970 fields that 1Password has to consider when you ask 1Password to fill it. It's easy for us as humans to say those two fields when looking at a page but the extension has to consider all input fields to figure out which ones it should work with.

    Try the following URL, https://sedo.com/auth/login?locale=en_US. It's a dedicated login page and with a much more reasonable 5 input fields you should find everything runs smoothly.

    970 fields isn't the worst I've seen but I do question that a page really needs that many or that there can't be a better way of constructing the page.

  • slobizmanslobizman Junior Member

    970 fields? Wow! No wonder I often curse how slow that site is overall. I went to the dedicated login page, and sure enough that was very quick. Thanks to both of you for your assistance.

  • brentybrenty

    Team Member

    Likewise, thanks for bringing this up! lil bobby here also showed me a few tricks, so it was a good learning opportunity. Technically he exaggerated though. It was 969. :lol: :+1:

  • s_mcleods_mcleod
    edited June 11

    I get this all the time with 1Password 7.3 and Firefox.

    I think I've noticed it especially frequently on websites with lots of JavaScript - for example Twitter, once you've already logged in and you have to re-enter your password to change privacy settings etc... the 1Password extension lags up Firefox something crazy then you get the warning.

    This didn't ever occur with 1Password 7.1 and below (from memory), but it could obviously be recent changes in Firefox or even websites (twitter in this example).

  • brentybrenty

    Team Member

    @s_mcleod: Wow. I haven't seen anything like that in Firefox for a long time. Literally -- this thread is a year and a half old! If you'll provide the exact details, we can investigate:

    • OS version
    • 1Password version
    • browser version
    • extension version
    • URL
    • list of installed extensions

    Those last two are going to be likely most critical, as we typically saw issues like this in the past due to a lot of active scripts on the page and/or in other extensions.

  • s_mcleods_mcleod
    edited June 11

    Hi @brenty,

    Thanks for your reply, that's really interesting - it sounds like it could perhaps be my specific configuration (as you mention, browser version and extensions for example), if it helps - it occurs on both my 5K iMacs and on my 2018 Macbook Pro 15".

    • OS version: 10.14.5
    • 1Password version: 1Password 7 Version 7.3 (70300020) (1Password Store)
    • browser version: Firefox 68.0b8 (64-bit)
    • extension version: 4.7.4.90
    • URL: https://twitter.com/settings/safety (when making a change and prompted to fill password to save the form)
    • list of installed extensions:
      • 1Password extension
      • Don't track me Google
      • Decentraleyes
      • uBlock Origin
      • Tracking Token Stripper (Removes Google Analytics UTM)
      • Smart HTTPs
      • Evernote web clipper
      • Feedly subscribe button
      • Google container
      • Facebook container
      • Twitter container
      • Reddit container

    I will try with all extensions disabled and with another browser.

  • s_mcleods_mcleod
    edited June 11

    Just tested with all extensions disabled - the lag up and warning still occurs.

  • s_mcleods_mcleod
    edited June 11

    If I try with Safari (with no extensions other than the latest 1Password) - I get the same lag up and the pin wheel of death on the tab with the password form, the tab also starts using 100% CPU, very similar to Firefox.

  • ag_anaag_ana

    Team Member

    @s_mcleod:

    Just tested with all extensions disabled - the lag up and warning still occurs.

    Just out of curiosity, does the same thing happen immediately after a reboot of your computer?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file