Clicking on Icon in Form does Nothing

Hi! I'm new to 1password and am having a bit of an issue with the chrome extension.
I installed the 1password X version, was able to login and everything. So far so good.

The problem I'm having is when trying to actually fill-in some passwords in any forms.
Lets say I go to any website (amazon, this one, my bank, etc).
The 1pwd icon shows up in the username/password field as expected. The proper suggestion for a login is displayed, but when I click on it, nothing happens.
If I hit CTRL+Shift+X (Chrome@Windows user) for the toolbar to display the extension itself, and then click on the "FILL" button that shows up, everything fills-in as expected.

Same thing happens when trying to generate a password. The suggestion shows up when clicking on the icon, but when I select the generated password, the popup just closes but nothing is actually filled in.

Hope this makes enough sense. Let me know if there is any extra information I might be able to provide.

Thanks in advance.
Best,
Javier.


1Password Version: Not Provided
Extension Version: X v1.3.0
OS Version: Windows 7 and Windows 10
Sync Type: 1password cloud

Comments

  • I'm having the same issue with the icon, clicking a suggested login does nothing, but cmd+shift+x and fill works okay.

  • brentybrenty

    Team Member

    @jrapoport: Thanks for reaching out. I’m sorry for the trouble! Can you tell me which version of Chrome you're using? I'm not able to reproduce this here even on Amazon, so I wonder if there's something different with your setup. Can you give me the exact URL(s) where you're having trouble? Also, do you have other extensions which have full access to modify the webpage that may be interfering? Thanks in advance!

  • brentybrenty

    Team Member

    @beneverard: Thanks for getting in touch! Likewise, I'm sorry you're having this issue, but I'm not seeing it here. Please tell me the following:

    • 1Password X version
    • Chrome version
    • OS version
    • Other extensions which are able to modify the webpage
    • Website URLs where you're having trouble

    Glad to hear that the keyboard shortcut is working. Looking forward to hearing back from you!

  • @brenty Certainly here are the details.

    • 1Password X 1.30
    • Chrome Version 64.0.3282.85 (Official Build) beta (64-bit)
    • Mac Sierra 10.12.6
    • Yes a few, but even after disabling all but 1PX, still an error
    • Every site does this

    Interestingly I had to log into send this message, so I recorded a GIF so you can see what's happening --> https://cl.ly/2y2x3a1B1H3a

  • brentybrenty

    Team Member

    @beneverard: Ah! Thanks so much for the GIF! That's crystal clear. I see you're running the Chrome beta though. That's one things that's different from me. Do you have the same problem with the stable version of Chrome?

  • Same boat here, using Chrome Beta in Windows - Version 64.0.3282.71 (Official Build) beta (64-bit)
    Also happens on the Chromebook that's in the beta channel.

    Also using a handful of extensions that can modify things, but disabling them all changed nothing.

    I'll try to install non-beta and report back!

  • Interestingly, when I click on the item the box disappears, but the 1Password pop-up comes up and I use the keyboard it will fill in the password as normal... so it seems this is relating to the click event.

  • LarsLars Junior Member

    Team Member

    @beneverard - looks like you might be right, but it also appears that this is related to using the beta build of Chrome. Like brenty, I've been trying to get this to fail in the way you've demonstrated, and I just can't. I'm using 63.0.3239.132 (Official Build) (64-bit), and 1Password X is working exactly as advertised there.

  • LarsLars Junior Member

    Team Member

    @jrapoport - I'm very eager to hear the results of your experiment, since brenty's experience mirrors my own, but you're having the same issue as @beneverard, and you're both on the beta. Let us know!

  • @Lars I've just downloaded 63 (Stable) and tried and 1PX works fine, so I guess it's limited to beta then. Though, it did work on beta up until recently, though I can't recall exactly when.

    I guess the concern may be if there's something in beta which prevents this working that's about to be handed down to stable.

  • @brenty @Lars I was trying to install stable here at work but something's preventing me from installing the 1PX extension, not sure what's going on.
    I can try again when I'm home.

    As @benevard was saying, maybe this is worth investigating in case there's something in 64 that's breaking 1PX?
    Or maybe there's some flag or something in any beta release that's causing this issue?

    Let me know if there's anything else I might be able to do to help!

  • LarsLars Junior Member

    Team Member

    Thanks, both @beneverard and @jrapoport -- you guys are the best for being willing to help us troubleshoot. However, if you're willing, try installing the beta version of 1Password X. In our testing, it's solved there. Let us know what you discover! :)

  • @Lars INDEED!
    Just switched to beta 1.3.2 and clicking on the icon's popup fills in the form! Thanks for the suggestion!
    Moving to beta and never looking back then! :sunglasses:

  • LarsLars Junior Member

    Team Member

    @jrapoport Excellent! Glad to hear the fix is working in the beta, and let us know if that changes. Cheers!

  • brentybrenty

    Team Member

    I guess the concern may be if there's something in beta which prevents this working that's about to be handed down to stable.

    @beneverard: Totally. It's something we'll continue to monitor. Thanks for bringing this to our attention! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file