App 2-way verification

Hi guys,

I use WhatsApp on my phone and I have 2-way verification activated. So every couple of days WhatsApp ask me to enter the PIN.

Since the latest 1Password update your app recognizes the field and provide me to enter the PIN automatically. Great! So I unlock 1Password, but 1Password can't find my WhatsApp details.

I think the problem is, that I added this detail as a database entry and 1Password use the "Logins" category only. Right?

But for me this is not a normal login. A login is for a website where I have an url, a username and a password. At WhatsApp I have nothing about it. I have a PIN only.

Is there an option that 1Password searches in more categories? Is there any workaround you can give me? In general which category to you recommend for Apps or similar, when you have a PIN only?

Thanks and best regards, Philipp


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • Have you tried the password category @Philipp?

    It's really annoying that WhatsApp feel the need to prompt users every couple of days but their rationale for it is that it'll prevent a user forgetting their password.

  • Hi @darrenNZ

    Good idea with the password section. I added the PW there and I'm waiting for the next WhatsApp request now. :-)

  • brentybrenty

    AgileBits Team Member
    edited January 12

    @Philipp: I'd really recommend just using a Login item. It's okay if it doesn't have the whole username, password, etc. But Password items are saved as a failsafe when generating passwords, so that category can get a bit cluttered. And a Login makes it easy to specify the website — in the case https://www.whatsapp.com — so it can be matched to the app. I hope this helps. Be sure to let me know if you have any other questions! :)

  • Hi @brenty
    That's good point why I should use the Login item for that also.
    Thanks!

  • brentybrenty

    AgileBits Team Member

    You're totally welcome! Here if you have any other questions. :chuffed:

  • Hi @brenty
    In January I added WhatsApp for this 2-way verification to the login sector. Then the password request was working with the new popup field. I think this was version 6.7.1.Beta-1 or Beta-2.
    But with the last beta releases the popup is not working again. I have to switch to the keyboard again.
    I'm not sure if 1Password did a change or maybe there was a new version of WhatsApp. But maybe could you find a solution that the popup will work again?
    Thanks!

  • brentybrenty

    AgileBits Team Member

    @Philipp: I'm sorry to hear that! I hate to do this to you (only a little though, cause there's good stuff there), but we just published version 6.7.2 to Google Play. Can you update and tell me if you're seeing the same behaviour?

  • Hi @brenty I will try next time. Maybe I have to wait some days (weeks) before WhatsApp asks me again.

  • mverdemverde

    AgileBits Team Member

    @Philipp I'm trying to reproduce the issue that you're encountering on my end. I haven't used WhatsApp before, so you'll have to forgive me if I'm not familiar with the settings. I've enabled 2-step verification on my new account, but as far as I can tell, it will only ask me for my PIN code when I add my phone number to the app. Have you enabled a different setting in order to get it to ask you for your PIN every couple of days?

    When I reinstall the app and am prompted for my PIN code, I found that the 1Password Autofill service doesn't identify the PIN code field as fillable but the Accessibility service does. I'll have to look further into it to determine why that is, but it leaves me curious to see if you're experiencing this issue with Autofill or Accessibility yourself. Could you clarify which one you are using in this case?

  • @mverde Hi, thanks for trying it out. Yes, WhatsApps asks me for the PIN also. This is (I think so) the two step verification. With the keyboard it is working, but not with autofill service. But it was working in the past. I'm not sure if 1Password or WhatsApp did any change.

    I'm not sure what is the different between Autofill and Accessibility? I mean: When 1Password recognize a login field, then there is a popup and I can login to my account, click the entry and 1Password do the login for me. The same was working for this PIN code also.

  • mverdemverde

    AgileBits Team Member

    @Philipp if you unlock 1Password and navigate to Settings > Filling, you'll see rows displayed for Autofill, Accessibility, and Keyboard. Could you tell me which of those are enabled?

  • @mverde Ah, I see! All of them are activated. Cheers

  • brentybrenty

    AgileBits Team Member

    @Philipp: Thanks for confirming! If you disable all of them and then try each one at a time, are you seeing any different results?

  • Hi @brenty I will try it next time WhatsApp ask me for the PIN again. But maybe I have to wait a little bit. I have no idea how to force WhatsApp to ask me earlier. I don't like to uninstall and reinstall the app. Hope that's ok.

  • Hi @brenty - You had the right idea. When the option Autofill is deactivated, then it is working. Important is, that Accessibility is activated. The keyboard could be activated or deactivated. Both its ok. But when I activate Autofill again, then it is not working again for WhatsApp.
    Cheers!

  • brentybrenty

    AgileBits Team Member
    edited March 3

    Hi @brenty I will try it next time WhatsApp ask me for the PIN again. But maybe I have to wait a little bit. I have no idea how to force WhatsApp to ask me earlier. I don't like to uninstall and reinstall the app. Hope that's ok.

    @Philipp: Oh, totally! I wouldn't want to do that either. It just sounded like this was happening to you more often than it has to myself and Verde:

    as far as I can tell, it will only ask me for my PIN code when I add my phone number to the app

    As he mentioned. :)

    Hi @brenty - You had the right idea. When the option Autofill is deactivated, then it is working. Important is, that Accessibility is activated. The keyboard could be activated or deactivated. Both its ok. But when I activate Autofill again, then it is not working again for WhatsApp. Cheers!

    That's really helpful! I'll let Verde know your findings. That may help him crack it. Thank you! :)

  • mverdemverde

    AgileBits Team Member

    @Philipp thanks for confirming that you're seeing the same behaviour that I am on my end. I'll keep looking into why Autofill isn't seeing the PIN field as fillable whereas Accessibility is.

  • Hello,
    I got your update 7.0 BETA-2 from today.
    But also with the new update I have the same problem. I also disabled and enabled both options (autofill & accessibility). But it is the same like last beta.
    Best regards, Philipp

  • brentybrenty

    AgileBits Team Member

    Thanks for letting us know. We'll keep at it!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file