Yet another multiple fields autofill issue

Hello all,

I can't get 1password to fill out username, passcode and password on this site:
wgdc.exconnect.hsbc.co.uk

When autofilling, it puts what I typed under “password” in the “passcode” field instead and leaves the “password” field empty. Checking the the “web form details”, I can see that all three values are correctly stores in the 1password entry, it just does not autofill properly somehow.

Can someone else test this and let me know if I'm the only one with an issue?

I use Chrome for Mac 63.0.3239.132.

Cheers


1Password Version: 6.8.6
Extension Version: 4.6.12.90
OS Version: macOS 10.13.2
Sync Type: dropbox

Comments

  • brentybrenty

    Team Member

    @kaz219: Are you sure that's the correct URL? I can't get that website to even load, so I'm afraid I may not be of much help at this point.

    However, in many cases manually saving a new login for the site will allow 1Password to save additional information from the form to fill better. Just try these steps to save the login manually:

    1. Navigate to the website
    2. Enter your login credentials
    3. Click the 'keyhole' icon to bring up the extension
    4. Click the 'gear' icon for Settings
    5. Click Save New Login
    6. Give it a name and Save
    7. Close the webpage and select your new login from the extension to have 1Password Go & Fill
    8. Submit the form manually if you have autosubmit disabled

    Let me know if that helps!

  • @brenty : many thanks, I forgot to put https in front of it. I did save a completely new login, but it didn't help...
    https://wgdc.exconnect.hsbc.co.uk/

  • brentybrenty

    Team Member

    @kaz219: Huh. I guess I am just so used to sites redirecting to HTTPS if they don't support HTTP. Pretty silly of my to not think of that. Thank you! :lol:

    I see what you mean. They appear to be using different randomized names (like "a4167011310403736") for the fields each time the page is loaded...and a hidden password field (with the ID "dummy_pass2" — not joking) beneath the actual password field, presumably to interfere with filling. This is a really odd one, but we'll see if there's a way to work around this. Thanks for bringing it to our attention!

    ref: opxi-79

  • Hello @kaz219,

    Due to the multiple fields needing filled and the randomised field names we will need to add an exception to 1Password to cope with it. The randomised field names throw off a particular filling strategy, one of only two that can cope with the more esoteric forms (the norm being username and password).

    There is another filling strategy that we can use here and my testing indicates this should work. Below you're going to see a chunk of text. Copy this into the macOS clipboard and switch to 1Password. You will find there is a new menu option as long as you aren't in the All Vaults view so ensure you have a specific vault selected. The menu option is File > New Item from Clipboard. It appears because the clipboard fits a certain form. You'll want to edit the new Login item and click the show web form details. In there you will need to replace the three placeholder values with your real ones and it has already been set up to tick the checkbox. The one thing it doesn't do is set the region so if that is needed let us know.

    Hopefully you find this works for you :smile:

    {
      "URLs": [
        {
          "overview": {
            "label": "", 
            "url": "https://wgdc.exconnect.hsbc.co.uk/vpn/index.html"
          }
        }
      ], 
      "categoryUUID": "001", 
      "details": {
        "fields": [
          {
            "designation": "username", "name": "Enter user name", "type": "T", "value": "username"}, 
          {"name": "passwd", "type": "P", "value": "passcode"}, 
          {"designation": "password", "name": "passwd1", "type": "P", "value": "this is the word peekaboo"}, 
          {"name": "eula_check", "type": "C", "value": "\u2713"}
        ]
      }, 
      "overview": {
        "ainfo": "username", 
        "ps": 88, 
        "title": "HSBC", 
        "url": "https://wgdc.exconnect.hsbc.co.uk/vpn/index.html"
      }, 
      "sectionName": "H", 
    }
    
  • Amazing, that works! Region is always automatically correctly set for me somehow, so I don't need it for now.

    I suspected a randomisation of the field name, because looking at the fields name under “show web form details”, there was random things, changing every time I would same the login again.

    THANKS!!

  • brentybrenty

    Team Member

    Thanks for the update! Glad lil bobby 's suggestion helped. :chuffed:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file