1Password 7 for Windows Alpha 1 is here!

135

Comments

  • The latest update and/or allowing 1Password to modify startup entries seems to solve my HitmanPro.Alert problem :)

  • MikeTMikeT Agile Samurai

    Team Member
    edited February 2018

    Hi @XIII,

    Awesome, thanks for letting us know. One update at a time to making 1Password better. :smile:

  • Seems like I cheered to early; when I close 1Password it tries to restart itself and HMP.A will block it...

    Also the Windows (10) Start Menu seems broken since I updated; the search field no longer appears when I start typing.

  • Moritz_Moritz_
    edited February 2018

    @XIII I think I've figured it out. Are you using Sophos Central or straight up HitmanPro.Alert?
    I manage my Endpoint using Sophos Central and have Intercept X on it.
    I have added "'CallerCheck' exploit prevented in 1Password for Windows desktop"
    to Endpoint Threat Protection Policy as a "Scanning Exclusion" + I have added "1Password for Windows desktop" to the "Exploit Mitigation Exclusions" list. This is still causing logs to be created by the Sopos Endpoint client in terms of filling the logs every couple minutes with "Nothing found to clean up: '1Password for Windows desktop' at ..." and it did indeed let 1Password start itself after rebooting.
    I can't speak for either 1Password nor Sophos Labs so I can't point my finger at any of them with certainty. (False Positive on Sophos Labs' end or 1Password using a "weird" API/function to do things)

    Hope this will help anybody having this issue.

    See screenshots:


    /e
    Since I have written that post, I don't see any new logs à la "Nothing found to clean up: '1Password for Windows desktop' at" in my Event Log so..

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    A quick search on the internet shows that CallerCheck is a fairly aggressive check, a lot of apps got falsely flagged with this including Excel.

    I'm not quite sure what the CallerCheck exploit is but it is expected that a new version of 1Password would intitially get false positives, we would go through this every few releases. We now get false positives with BitDefender on 1Password 7 as well. Once we report the false positives, they'll improve.

    Please do report it as such, they'll review it to make sure it is false: https://community.sophos.com/kb/en-us/125439

    @XIII,

    Also the Windows (10) Start Menu seems broken since I updated; the search field no longer appears when I start typing.

    I'm not sure how that is related to 1Password? We have no interaction with start menu, it would mean hijacking explorer.exe or Windows itself to break it, which would've definitely flagged us as malware.

    Just to be clear, we didn't change anything in the last update related to Hitman or its check. What we did was update our updater to remove the previous 1Password 6 files, I suspect that may have reduced Hitman from flagging 1Password if both 1Password 6 and 7 were accidentally running at the same time.

  • I use HitmanPro.Alert; not Sophos Central. Still need to investigate how to exclude 1Password (if possible).

    I also use Emsisoft AntiMalware which uses the BitDefender engine as it’s second engine, but did not experience any problems with that program.

    The Windows 10 Start Menu works again after a reboot.

  • Alex0205Alex0205
    edited February 2018

    I like the "Type in window" feature in theory, but it has created a usability problem. When I right click an entry in the Mini viewer and hover over the password field, I used to just have to move my mouse a bit to the left to select the "Copy" option. But now because of the "type in window" options, I have to move my mouse way up to get to Copy, because I'm on a workstation and typically have >20 application windows open. It has really messed up my muscle memory

    Redacted screenshot

    I don't mind the feature itself, but could you adjust this menu so that "Copy" stays right next to "password" and I can get to it with a small movement?

  • Thanks @Alex0205 , it's indeed jumping up and down, depending on where your mouse was to open 1Password mini and how much space is left between menu and edge of screen and so on... good news - next update will make Copy scenario easier.

  • SpaldoSpaldo
    edited February 2018

    I am confused about the hockey thing. When you try to download from this website it points you. Anyway, that aside.

    I am running 510. When you to to release notes:

    https://app-updates.agilebits.com/product_history/OPW6#beta

    It says there is 514. When you press download, it goes to 510.

    The program also uninstalled itself... >_<

  • I specifically chose 1PW4 (over Dashlane) and the agilekeychain format (despite the metadata issue) because I make heavy use of the ability to add attachments to individual logins and individual secure notes. Please reassure me that I won't be forced to adopt OPVault unless and until it can offer the same functionality!!

  • SergeyTheAgileSergeyTheAgile

    Team Member
    edited February 2018

    @Spaldo yes, you are right, it's a bit confusing at the moment. 1Password 6 uses HockeyApp and if you are on a beta channel it will serve you one of 1Password 7 alpha builds. From that moment on new update mechanics take over and it will update itself to whatever last is available on 1Password 7. Simplest way for now is to use 1Password > Check for updates menu inside the app. As part of update sequence 1Password 7 will ensure 1Password 6 is removed (there are file names and count changes between them, it would be really complicated to try and run both version 6 and version 7).

  • pbryanwpbryanw Junior Member
    edited February 2018

    @SergeyTheAgile - Thanks for making Check for updates accessible from the menu in 1Password 7 :chuffed:

    I also like the neat touches that have been included, like being able see the download status of the current update, and the last update date & time in the menu :+1:

    Edit: Hi, I've noticed two issues when uploading custom icons - when you choose an icon in edit mode, the icon only shows when you click save, instead of after the file picker has been closed.

    Also, selecting clear icon from the icon menu in edit mode, doesn't appear to work for me. I'm using 1Password 7.0.514 on Windows 10.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    @pbryanw,

    Thanks for reporting these issues.

    Edit: Hi, I've noticed two issues when uploading custom icons - when you choose an icon in edit mode, the icon only shows when you click save, instead of after the file picker has been closed.

    We've fixed this already internally, you'll like what we've done. It'll be in the next update.

    Also, selecting clear icon from the icon menu in edit mode, doesn't appear to work for me

    Try closing the window and reopening, the icon will be cleared off. 1Password is not refreshing it properly, we're working on it.

    @petalhanger

    I specifically chose 1PW4 (over Dashlane) and the agilekeychain format (despite the metadata issue) because I make heavy use of the ability to add attachments to individual logins and individual secure notes.

    I'm not sure I understand, can you clarify what the issue is with OPVault and attachments you saw?

    OPVault does not get rid of your ability to add attachments to any items, there is no difference in how you do this between AgileKeychain and OPVault in 1Password. There may be some limitations in certain versions of 1Password but 1Password 7 for Windows will let you add any attachments to any items you want.

    While you can still import/convert AgileKeychain with 1Password 7 to OPVault, but from there on, only OPVault format will be supported for syncing.

  • SpaldoSpaldo
    edited February 2018


    @SergeyTheAgile thanks for the info. I thought it was updating itself but for some reason its stuck on 510. The check for updates button doesn't come up, there is only "your app is up to date". However, I never pressed the button. The update channel doesn't have any drop down either?

    It seems to be stuck on 510 and no 514?

  • astralastral
    edited February 2018

    Hi, was so psyched to see the e-mail that standalone vaults were here that I just bought the Pro features on iOS to celebrate. Really happy about the coming-soon ability to be able to use standalone vaults without having to have a 1password membership! Thank you guys so much for working in this direction. Looking forward to testing the desktop app out when that feature lands.

    Until then, I can report one bug that I can reproduce reliably: After viewing the Troubleshooting submenu once and moving the mouse away so it disappears (or selecting a menu option so it closes), the submenu gets cropped until I relaunch the application:

  • @Spaldo normally it should have "stable"/"beta" options in dropdown, for some reason it seems to be not selected. Please select "beta" and it should be ok, and if not - we are here to fix that ;)

    App does quick check for updates status when you open 1Password menu or when you open Settings > Update, don't worry, it doesn't consume much of traffic and it does that only once an hour or on your direct request.

  • @astral I'm glad that it is going to fit your needs. 1Password membership is good in many ways, but we do recognize that people have reasons for local vaults.

    You are right, menu resizing is not doing well. We'll fix that, thanks for letting us know!

  • SpaldoSpaldo
    edited February 2018

    @SergeyTheAgile unfortunately for some reason the drop down is totally empty now?

    I've uninstalled & reinstalled 510 (can't find 514 link) and it made no difference...

  • @astral that one says it installs, but, never does? The link it puts in the start menu is somewhere hidden in appdata but does not let you run it

  • SergeyTheAgileSergeyTheAgile

    Team Member
    edited February 2018

    @Spaldo the link to build 514 should have updated your app, but if you are still seeing that %localappdata%\1Password\app\7\1Password.exe does not have 7.0.514 in it's file properties then something went wrong with the update. Please send Diagnostics Report and mention this thread or my name, we will figure out what's going wrong. Most likely either AV was interfering or 1Password files were locked/used by browser.

    @astral that issue with menu clipping is resolved and should be available with next update, thanks!

  • @SergeyTheAgile I can't generate the diagnostics report because it won't install. I will try to delete the directory and re-install

  • @Spaldo Diagnostics Report mostly consist of files from %localappdata%\1Password\logs, there are logs for setup process that can show what's wrong.

  • Very strange. It looks like Bitdefender was doing something funny. It has never stopped the program before, so I am not sure what it was doing!

    Once I removed the files from quarantine, uninstalled, rebooted & reinstalled then it started working

  • Glad it works again, 1Password 7 has a number of changes in the way we package it compared to 1Password 6 - it's now much less files and same 1Password.exe can be used in multiple roles (native messaging host or app). That could have confuse AV.

  • Is there any extension for Edge?

  • Yep, it's in Windows Store, here is the link https://www.microsoft.com/store/productId/9WZDNCRDR64J

  • @wkleem so far 1Password 7 requires same .NET Framework 4.6.1. There is a temptation to bump requirement to .NET 4.7.1 but there is nothing we absolutely need there. With that being said, I'd recommend to update to the latest, even if API does not change it gets internal bug fixes, for example i has fixes for crashes related to pen/touch support (even if you don't have/use them, it could crash app when you just move your mouse).

This discussion has been closed.