Firefox 58 and Reading manifest: Error processing key: An unexpected property was found in the WebEx

With last version of Firefox 58 your Addon does not work anymore. I got this error: "Reading manifest: Error processing key: An unexpected property was found in the WebExtension manifest.". I use the 1Password 4.x for Windows (Windows 10 64 bit). I tried to reset Firefox, reinstall the Addon and 1stPassword is updated. How to resolve it?


1Password Version: 4.6.x
Extension Version: Not Provided
OS Version: Windows 10 64 bit
Sync Type: Dropbox

Comments

  • GregGreg

    Team Member

    Hi @temp3000,

    Thank you for reporting this!

    I checked how 1Password behaves in Firefox on my side and it seems to be working correctly there. Could you please tell us the exact versions of 1Password 4, 1Password extension, and Firefox that you're using? Here is how you can find them out:

    Find the version numbers of 1Password and the extension

    Thank you!

    Cheers,
    Greg

  • 1Password version: 4.6.2.626
    Firefox version: 58.0.1
    Firefox add-on versione: 4.6.12.90

  • GregGreg

    Team Member

    @temp3000: That is indeed quite strange, since you are using the latest version of everything.

    Could you please create a Diagnostics Report from your PC, where you have this issue, so we could take a closer look? Here is how:

    Sending Diagnostics Reports

    Attach the Diagnostics Report to an email message addressed to [email protected].

    Please do not post your Diagnostic Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your report in our inbox. You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report and ensure that this issue is dealt with quickly. Thanks!

    Cheers,
    Greg

  • Ok my support ID is [#PIY-65351-444]

  • bundtkatebundtkate

    Team Member

    @temp3000: I found your e-mail, but since I think this will be a quick one, I figured I'd reply here to make things easier. You don't have native messaging enabled in 1Password 4, which is needed for 1Password to work with Firefox. Go ahead and open 1Password 4, then choose Help > Advanced and check Use Native Messaging Protocol. Restart Firefox and you should be all set, but let us know if you're still having trouble. :chuffed:

    ref: PIY-65351-444

  • yes! Problem solved. Thanks a lot :)

  • GregGreg

    Team Member

    @temp3000: On behalf of Kate you are very welcome! :) Please feel free to contact us anytime, we are always happy to help you with 1Password.

    Cheers,
    Greg

This discussion has been closed.