Adding a Username to an Entry without a Username leads to an error "No Change"

Hi guys,

I just stumbled upon the following. I had an entry in my vault that only has a password and an URL. As there should be a username too, I tried to edit the entry in the Android Beta App and add a username. When tapping "save" the error message "No Change" pops up and the entry ends up without a username as before. I could repeat this behavior on another entry.

Then I added the username on my Mac in the Chrome Browser extension of 1Password which worked as designed. Then I deleted the username in this entry again (in the Chrome Browser Extension). Went back to the app and added the username there again, which then worked fine.

The "No Change" error message only seems to pop up when you try to change older entries in the vault.

Not sure if you are already aware of this.

Cheers,

Lydia


1Password Version: 6.7.2.BETA-1
Extension Version: 4.6.12.90
OS Version: Android 8.1.0
Sync Type: Dropbox

Comments

  • periperi

    Team Member

    Hi @LydS. Thanks for reporting this. Do you see the option to send an error report when you see the 'No Change' error? Also, does the notification give any other information? Or does it just read 'No Change'?

  • It only reads "No Change" and has a filled red circle on the left with a white x in it, just like there is no change, despite the fact that there is (the added username). It shows the message for a short second or less and then leaves the edit mode without saving anything. So it doesn't count it as a severe error (just a user error) and therefore there is no way to report anything at this point in the app.

  • LydSLydS
    edited February 2018

    Sorry, wanted to upload them in the correct order, but it didn't work out as well as I had planned. ;) But you can order them yourself by looking at the device time.
    Hope this helps.

  • periperi

    Team Member
    edited February 2018

    Thanks, @LydS! By chance was this created as a Password item from 1Password on Mac and then converted using the 'Convert to login' button in that version?

  • I've experienced a similar issue, but without the "No change" message.
    Here's how to reproduce it:

    • Using Chrome 64 and 1Password X 1.4.0 go to https://github.com/
    • In the home page there is a registration form
    • Leave username and email fields empty
    • In the password field, use the one 1Password X suggests
    • When prompted, save the new login item
    • Now open 1Password on Android and edit this new item
    • Enter a username and save
    • The username is NOT saved
  • periperi

    Team Member

    Thanks for these steps, @lammoth. With these steps I'm able to reproduce this and the 'No Change' issue reported above. I'll pass this on to my team to look into. ref: OPA-1415

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file