Accessibility keeps turning off / Autofill feature doesn't work

Hello

I have a Huawei mate 10 pro with the latest firmware installed. I really like the accessibility feature but it keeps turning off randomly and I have to reactivate it in the settings. The autofill feature doesn't work at all. When try to turn it on it just goes back to the previous menu.

Any help is appreciated

Comments

  • brentybrenty

    Team Member

    @OolongT: Thanks for reaching out. I'm sorry to hear that. Have you tried restarting the device?

    When try to turn it on it just goes back to the previous menu.

    Also, can you elaborate on this? Are you saying that you're unable to enable the accessibility option in Android Settings? If so, that would explain why it isn't working for you.

  • briwilbriwil
    edited July 2018

    I'm on a Huawei P20 Pro and experiencing the exact same thing. When I go to Settings/Filling within the app and try to toggle "Autofill" the app blanks, makes me reauthenticate my fingerprint, and goes back to the app's settings page.
    Separately, clicking "Accessibility" within 1Password's settings page takes me to the phone's Accessibility section within the phone's Settings app, so all is good- but if I go back an hour later to 1Password's filling section within it's settings, it's unchecked again.
    This sucks, I never experienced either of these things on my Note 8.

  • I'm on a Huawei P20 Pro and experiencing the exact same thing. When I go to Settings/Filling within the app and try to toggle "Autofill" the app blanks, makes me reauthenticate my fingerprint, and goes back to the app's settings page.
    Separately, clicking "Accessibility" within the app's setting page takes me to the phone Accessibility section within the phone's settings app, but if I go back an hour later to 1Password's filling section within it's settings, it's unchecked again.
    This sucks, I never experience either of these things on my Note 8.

  • Yeah, welcome to Huawei hell, I'm having the exact same problem (I have a P20, wife has a P10 lite). To be clear, this has nothing to do with 1Password, EMUI is pure garbage, plain and simple.

  • periperi

    Team Member

    Hey @smnstrk and @briwil. Sorry to hear that! One thing to look for is any optimization software. Do your Huawei devices have anything like that installed? If so, that's likely disabling the accessibility service.

  • None that I'm aware of; what's an example, though, of this kind of software?

  • jimgerjimger
    edited July 2018

    @smnstrk Xiaomi does the same [removed by 1Password] in MIUI. Although in MIUI you can exclude apps from battery saving features. It would make perfect sense if EMUI has that kind of options too...

  • smnstrksmnstrk
    edited July 2018

    @jimger You can do that in EMUI too. The problem is, sometimes it works for a day or two, sometimes it doesn't (most of the time). This crap is the same reason I can't use the XDA Navigation Gestures normally, it keeps resetting, sometimes even every few minutes. Believe me, I've tried every possible solution out there and wasted way too many hours on this already, I'm done. I'm just waiting for a bigger iPhone X (whatever they're gonna call it) and then I'll finally be able to say goodbye to Android.

  • @smnstrk I suppose it has some other ways to disable too. Well u can always go to more stock android devices like pixel and android one devices (and oneplus). If you are covered by the features and price of iphone, who am I to disagree :P

  • @jimger thanks, but no thanks. I hate Google, I'm currently using an Android phone only because Microsoft killed Windows Mobile.

  • periperi

    Team Member

    Hey everyone! I just want to remind you all of the forum rules. Please refrain from using profanities here. We want this forum to be accessible and friendly to everyone.

    That said, are you still having problems after excluding 1Password from the battery saving features?

  • Hello everyone! I have Huawei P20 and have too all time turned off accessibility and good news I have solution!
    So to set an app to keep running in background on Huawei do this:
    1. Open the Phone Manager app.
    2. Tap the Battery icon > Launch
    3. Tap the reading app you’re using, set to Manage manually with the Run in background option selected.
    4. Then, go to the device’s Settings > Apps & notifications > Apps > Settings > Special access > Ignore battery optimisation, tap the reading app you’re using and select Allow.

    Good luck everyone and keep up good work 1P team like always!

  • brentybrenty

    Team Member

    Oh wow. Thank you for the kind words, and for sharing that! It can help others who run into a similar issue. :chuffed:

  • Thanks Janis! Solved the problem. Was driving me crazy before. 😊

  • periperi

    Team Member

    Hi @SimonJames2020. I'm so glad Janis was able to help you out!

  • This doesn’t work for me on oppo A73. 1password accessibility still turns itself off after 1 fill.

  • periperi

    Team Member

    I've replied to your comment in our other thread. Let's keep the conversation going there.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file