Auto fill and submit not working in Firefox 58.0.2

When I double click a login item whilst in the Mac app (version 6.8.6) it used to open the url in the browser, fill in in the login and password and submit. Now it just opens the url and I have to click the browser extension button and click the selected site for it to fill and submit. This happens on my Microsoft Surface Pro as well.


1Password Version: 6.8.6
Extension Version: 4.6.12.90
OS Version: OSX 10.12.6
Sync Type: 1Password subscription

Comments

  • littlebobbytableslittlebobbytables

    AgileBits Team Member

    Hello @paulfrost,

    It seems there have been some changes in Firefox that have impacted open and fill and even filling on particular sites. One is already reported and the other one will be to soon. That doesn't help 1Password users right now though so I'm wondering if you would be willing to test the beta version of our extension where we've hopefully added workarounds for both. You can easily switch between the beta and stable version of the extension without worrying about the 1Password application so if you're happy to try here are the recommended steps.

    1. Visit the Firefox Extensions page which is at about:addons and ensure Extensions is the selected tab in the list on the lefthand side.
    2. Remove the 1Password extension and restart Firefox. Through a lot of testing I find this ensures avoiding any weird caching issues.
    3. Install our beta extension which can be located at 1Password Browser Extensions.

    I believe the changes we've made should return full functionality to Firefox so it would be great to learn if this is indeed the case.

  • That's working OK for me now. I've tried several different sites and it worked every time.

  • brentybrenty

    AgileBits Team Member

    Glad to hear it! We're here if you need anything else. :)

  • Firefox is still having problems (even with installing the latest beta addon) with sites that aren't a problem in other browsers. How should I report those (I assume it is related to this)?

  • brentybrenty

    AgileBits Team Member

    @bm5k: Can you be more specific? I don't know which "problems" you're referring to, or the versions and URLs involved. It's hard to say one way or the other under the circumstances.

  • 2017 MacBook Pro; macOS 10.13.3; Firefox 58.0.2 + 1Password beta addon 4.7.0.4; Safari 11.0.3 (13604.5.6) + 1Password beta extension 4.7.0b2.

    Firefox won’t “open and fill” passwords on some sites (every site I tried, actually); I double checked those same sites in Safari and had no issues.

    Following the above instructions (https://discussions.agilebits.com/discussion/comment/414094/#Comment_414094) didn’t fix the issue.

  • brentybrenty

    AgileBits Team Member

    @bm5k: Thanks for clarifying! Just to make sure we're on the same page here, is this what you're doing?

    1. Open Firefox
    2. Click the 1Password extension button
    3. Find the login you want to fill (one for a different website than the one you already are on)
    4. Click it to have 1Password open and fill

    I'm not seeing any issue with this in Firefox here, so I want to make sure you're not having trouble doing something different. As lil bobby mentioned, there are some known issues with Firefox that can impact this for some users. We've added some workarounds, but ultimately the extension runs entirely within the browser, so if the browser is not behaving correctly we're limited in what we can do on our end. Let me know what you find.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file