Device not compatible error on Samsung Galaxy S7

saadsaad

Team Member
edited February 2018 in Android

This post is for Samsung Galaxy S7 users that are experiencing an incompatible device error when installing 1Password from the Play Store app. If you see a message like the one below, keep on reading!

1Password is designed to work on devices with a minimum screen resolution. While the Samsung Galaxy S7 is nowhere near this limit, it does provide the ability to change the apparent resolution of the display in Settings. From what we've been able to determine, lowering the resolution this way can result in Google Play showing 1Password as incompatible with your device. You can work around this issue by following these steps:

  1. Open the Settings app on your Samsung Galaxy S7
  2. Go into Display and change the resolution to WQHD
  3. Navigate back to Apps > Google Play Store > Storage
  4. Tap Clear Data
  5. Restart your Samsung Galaxy S7

You should now be able to install 1Password from Google Play again!

This discussion has been closed.