Browser connection refused

Hey there peeps,

I'm always getting the message that 1Password refuses the connection between my Chrome browser (Version 64.0.3282.186 ) and the 1Password App. I have no idea how to fix this. My PC is running the newest Windows 10. I also uninstalled Chrome and the extension and re installed everything. Nothing worked. Still getting this error message:

"Browser connection refused - 1Password refused connection from untrusted source, check logs for details."

However, if I click on the message the 1Password app opens but is frozen. No clue how I can fix that it works on chrome. Please help me:)


1Password Version: 7.0.506
Extension Version: 4.7.0.90
OS Version: Windows 10
Sync Type: Not Provided

Comments

  • GregGreg

    Team Member

    Hi there @Flogisch,

    Thanks for writing in! That is quite strange.

    Could you please provide more information about your PC? Is it your work computer? Are you running any kind of AV/anti-malware software there? It may take a little troubleshooting to get this straightened out, so I hope for your understanding.

    Additionally, I'd like to ask you to create a Diagnostics Report from your PC, where you have this issue:

    Sending Diagnostics Reports

    Attach the Diagnostics Report to an email message addressed to [email protected].

    Please do not post your Diagnostic Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your report in our inbox. You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report and ensure that this issue is dealt with quickly. :)

    Thank you! :+1: I will be looking forward to your reply and email.

    Cheers,
    Greg

  • Thanks for your comment!
    I finally fixed the issue. I uninstalled the 1Password App from my PC and installed it again (2times or so). Fixed the issue somehow.

  • bundtkatebundtkate

    Team Member

    @Flogisch: Looking at your initial report here, you were on an older alpha build of the main app, so I suspect you snagged an update along the way. The version you were on is a bit confusing as it's something of an "in between" version where you needed to update again immediately after installing it. If you didn't grab that second update, you may have run into some trouble. Sorry about that, but glad you were able to get thing sorted. :chuffed:

  • Interestingly, I'm having the exact same issue. It was working yesterday, and is not today. Not sure what component(s) might have updated since yesterday. I'll email my info...

  • sjmagysjmagy Junior Member

    Encountering the exact same issue. Worked fine yesterday, but not today. Chrome, Windows, and 1Password (both desktop app and extension) are all up to date and running latest. Wondering if a security certificate expired and that's what's causing the connection to be refused?

  • brentybrenty

    Team Member

    Indeed. Sorry for the trouble, folks. Google's signing keys for their certificate for Chrome have been expired, and 1Password 4 does not have the new ones. I'd suggest using Firefox, or upgrading to 1Password 7, as that has support for the latest signatures.

  • I'm running 1Password 7 and Chrome and suddenly got this today.
    I remember having this issue before and the problem that time was that there was a Chrome update pending so I did that but it didn't help.

    1Password 7.3.612 and Chrome 71.0.3578.98
    It also happened with whatever exact version of Chrome 70 that I was running just a few minutes ago.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @okand,

    We've released 1Password 7.3.619 Beta 3 update just now to support Chrome 71 and newer.

  • syntax53syntax53
    edited January 3

    I think you need to put this update out ASAP. I just had to switch my app to beta channel in order to work with Chrome again. I just introduced someone to 1password (on a trial) and having to jump through this hoop is not a good first impression. Whether or not this is Chrome's fault-- to the end user, Chrome works and this doesn't.

  • MikeTMikeT Agile Samurai

    Team Member
    edited January 3

    Hi @syntax53,

    Thanks for writing in.

    We've shipped 7.2.617 with the fix on the same day (Dec 16) before we shipped the beta update to support Chrome 71 and newer on the next day. There has not been any issues with Chrome since then.

    You don't need the beta build to support Chrome.

    If you're having an issue with the stable version, it is something else or you didn't have the 7.2.617 update.

  • My browser said "connection refused" for the 1password extension. I searched on the internet for that and landed here. I went into my 1password app and did a check for updates and it said I had the latest version. I switched to the beta channel and it downloaded an update and then it started working.

  • FYI-- I found this in the logs

    <tr class=e><td>E</td><td title='2019-01-03 12:58:06'>3119814ms</td><td title=''>ThreadId(19)</td><td>1Password::api:1690            │  3119814ms │ Refusing helper connection from &quot;C:\Program Files (x86)\Google\Chrome\Application\chrome.exe&quot;, because of untrusted certificate.</td></tr>
    <tr class=w><td>W</td><td title='2019-01-03 12:58:25'>3139266ms</td><td title=''>ThreadId(4)</td><td>1Password::api:1684            │  3139267ms │ suggesting beta update from 7.3.612 to 7.3.648</td></tr>
    <tr class=e><td>E</td><td title='2019-01-03 12:58:26'>3140037ms</td><td title=''>ThreadId(20)</td><td>1Password::api:1690            │  3140038ms │ Refusing helper connection from &quot;C:\Program Files (x86)\Google\Chrome\Application\chrome.exe&quot;, because of untrusted certificate.</td></tr>
    <tr class=w><td>W</td><td title='2019-01-03 12:58:27'>3140792ms</td><td title=''>ThreadId(4)</td><td>1Password::api:1684            │  3140792ms │ suggesting beta update from 7.3.612 to 7.3.648</td></tr>
    

    Potentially I was on a BETA update and switched to stable and since the stable update you are referring to was still less than the beta build I was running, then it wasn't updating.

    p.s. that "suggesting beta update from 7.3.612 to 7.3.648" message would have been helpful to display on the screen somewhere to the end user. Not hidden inside a log.

  • bundtkatebundtkate

    Team Member

    That message displays in a banner at the bottom of your app @syntax53. It sounds like you had an older beta build, but had the stable channel selected in your update settings. If that's the case, then you won't see any update prompts until either you switch back to beta or there is a new stable update available with a build number higher (for lack of a better term) than your current beta. Normally, this means you'll get the next stable update that's available as it will share a build number with the beta that got promoted to stable, but this case was a bit different. Since these were emergency releases that weren't expected, they didn't follow the normal build number progression since the stable build was a 7.2 build and all betas have been 7.3 recently. In this case, I'd hazard those logs were likely generated when you changed to beta and checked for updates.

  • brentybrenty

    Team Member

    @Stanzilla: 1Password for Windows version 4 was discontinued in 2017. We don't have plans to update it further. Our focus is on the current version.

  • BenBen AWS Team

    Team Member

    I'd suggest reaching out to our sales team at [email protected] for further. :+1:

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file