Opera 53 Error [fixed in v6.8.9]

markbyrnmarkbyrn
edited May 18 in 1Password 6 Beta

Updated from Opera Dev Beta 52 to 53.0.2893.0 and 1Password is now disabled due to: “For your protection, 1Password will only fill information in browsers that have been signed by identified developers. For your protection, 1Password will only fill information in browsers that have been signed by identified developers.” 1Password worked fine in Opera Dev beta up until this version.


1Password Version: 6.8.7
Extension Version: 4.7.1.1
OS Version: OS X 10.13.4
Sync Type: Not Provided

«1

Comments

  • ditto

  • ag_kevinag_kevin Junior Member

    Team Member

    Hi @markbyrn ,

    This means the signature has changed for Opera Development. Before 1Password can support this, we will be investigating to make sure the change signature was intended by Opera. We will then make the necessary update to support the change. In the meantime, you will need to use one of the other editions of Opera.

    Cheers,
    Kevin

  • Hi @ag_kevin - did you confirm that the signature has changed for Opera Development and that you'll be rolling a new version of plugin? Or was this an error in Opera Development release?

  • ag_kevinag_kevin Junior Member

    Team Member
    edited March 22

    Hi sydlow,

    I'm sorry, there is no news yet. We have not yet been able to confirm the certificate change. We'll let you know when we have more information.

    Regards,
    Kevin

    ref: OPM-5951

  • This is still a problem. Opera developers claim they have attempted to contact 1password but no resolution yet. This is quite annoying to users.

  • LarsLars Junior Member

    Team Member
    edited April 2

    @vpavlovic - I can't speak for all our devs, but it certainly doesn't appear as if they've contacted us via email. If you're in contact with them, have them write directly to [email protected] and we'll verify these changes with them. Until that time, please use a non-dev build of Opera if you wish to continue using 1Password within Opera.

    ref: apple-12

  • Hi Agilebits - is there any fix on the horizon for this? There's been a couple of Opera version updates now

  • LarsLars Junior Member

    Team Member

    @sydlow - This issue should be resolved in 1Password 7 for Mac beta -- have you checked that?

  • @lars I haven't - as I generally don't run beta software. Will it be incorporated into v6?

  • LarsLars Junior Member

    Team Member

    @sydlow - at this point, I doubt it. It won't be too much longer until 1Password 7 for Mac is out of beta, and although that could change, typically adjustments of this type go into the new version, not older ones.

  • brentybrenty

    Team Member
    edited April 6

    @lars I haven't - as I generally don't run beta software. Will it be incorporated into v6?

    @sydlow: Correct me if I'm wrong, but isn't the problem you're having with a prerelease version of Opera? The stable version is working just fine for me here with 1Password 6. That could tide you over until you're ready to move to 1Password 7. We're unlikely to make any further changes to version 6 unless there's a critical security issue that needs to be addressed.

  • @Lars Yes, you're correct. But the Opera Dev app is self contained and I can isolate. If I run 1PW 7 beta it affects all instances of it.
    I'll live with the problem.

  • LarsLars Junior Member

    Team Member

    @sydlow - sounds good. :)

  • Hi all, any update on this. Today I've updated Opera to the 53.0 build and 1password extension stopped working. I've tried to move to the 1 password beta version 6.8.8 and extension beta version 4.7.1.90 but without positive effect. Any advice? Thanks

  • LarsLars Junior Member

    Team Member

    Welcome to the forum, @petrmahdal! 1Password 6 for Mac will not be updated with the new code signature for Opera. Because this happened while 1Password 7 for Mac was already in beta, we will make (in fact: already have) made the necessary changes to 1Password 7 for Mac to allow the 1Password extension to work once again within Opera, but that functionality won't be back-ported to version 6 or lower. If you'd like to join us in the beta of 1Password 7 for Mac, just turn on "include beta builds" in Preferences > Updates and check for a new update. Or you can download the 1Password 7 for Mac beta directly from this link if you prefer. Thanks! :)

  • Great, thank you for such a quick reply Lars, much appreciated.

  • I just upgraded to Opera 53 stable and now I'm toast due to this issue. When I try to download v7, I'm offered only 6.8.8... even when I "enable betas" on the downloads page. So v7 is apparently only available via the link posted above. It would have saved me considerable time if the page about the identity error were updated accordingly. Thanks! https://support.1password.com/code-signature/

  • brentybrenty

    Team Member

    @sscbarb: Thanks for getting in touch. I'm sorry for the inconvenience. We're not going to put beta stuff in the documentation, but we'll absolutely be updating it once 1Password 7 is officially released. Thank you for your feedback on this.

  • brentybrenty

    Team Member

    @petrmahdal: Glad Lars was able to help. We're here if you need anything else. :)

  • I'm sorry but I find this unacceptable. In order to use the browser I prefer, you are saying I need to trust all my passwords to a BETA software (1P-7).

    And anyway, don't forget that later on I'll HAVE TO buy 1P-7 (which might be sold only as a subscription service) in order to continue to enjoy a service, 1Password, which was working just fine until yesterday.

    I don't think it's a huge effort to register the new Opera signature in an update to 1P-6. I've been using 1P since a very long time ago, PAID FOR IT and well, you know, would expect it to work.

    Thanks.

  • BenBen AWS Team

    Team Member

    Thanks for the feedback. :)

    Ben

  • sscbarbsscbarb
    edited May 11

    @brenty I understand that you don't want to reference beta product in release docs. If that's the position, then fix the problem in the release software as @igroles suggests. It's not ok to make paid customers wrestle for hours trying to get the product to function again when the problem is well-known and has a workaround. Either Opera is a supported browser or it isn't. I hope that Opera continues to be fully supported. Thank you.

  • BenBen AWS Team

    Team Member

    @sscbarb,

    I understand your position. This is a very recent development and we’re still putting together exactly how we’re going to approach the situation. Again, we do appreciate the feedback, and will post more as we have more we can share. :)

    Thanks.

    Ben

  • Like others here, I find it frustrating that I updated my Opera, only to find that now 1Password cannot be used with it. I don't know what amount of work is involved with doing the code signature, but it seems inconsiderate of paying customers to just say, "Yeah, we're not going to fix it...you have to wait until the new version is ready" or get a beta version.... 1Password 6 is the current version, not some older version. I am a subscription customer and I think it is reasonable for subscribing customers to expect that this is fixed, especially being that this thread indicates the issue began back in March.

  • brentybrenty

    Team Member

    @iMacIIuser: We didn't break anything. Opera changed the identity of their browser. And to be completely clear, using the 1Password 7 beta does not put your data at risk. 1Password stores the data separately from the app itself; you can simply revert to 1Password 6 if you decide you don't like it, and use one of the many other supported browsers. I am sorry that this is inconvenient, but the reality is that no matter what any particular version of an app will not be updated indefinitely. We need to focus on developing the next version or there won't be one — for you or anyone else. And, in fact, a 1Password.com member, you will get all of the changes we're making in version 7; that's included in your subscription, and it's publicly available now. I think it would be silly of us to not let you know about the available options:

    • Use 1Password 7
    • Use a supported browser (Opera 53 is not supported in 1Password 6, just as opera 52 is not supported in 1Password 5)

    We cannot, however, offer you options that do not exist. I'm sorry that's not the answer you want, but that's the reality. :blush:

  • How would you make it compatible if you wanted to? Is it like recompiling the plugin with a new id certificate?

  • brentybrenty

    Team Member

    @sydlow: We'd have to backport some changes from the newer version, and that can be messy — in addition to requiring someone being pulled off of something else. I'm not ruling it out completely, but given everything else we're working on I am not certain that's going to happen.

  • I might be totally wrong, but it seems the problem is just that Opera 53 has a different signature than Opera 52.

  • This is what Opera devs advised:
    https://forums.opera.com/post/142700

  • So, to sum it up: the current version of 1Password doesn't work with the current version of a popular browser and the answer I get from 1Password (of the two pieces of software, the one I paid for, mind you) is to use a beta or change browser.

    And for the future, well, 1Password says I'll have to pay again in order to regain a functionality I was enjoying until two days ago.

«1
This discussion has been closed.