1Password extension for Chrome is saying I need the desktop app, but I do? No longer working

It used to work on chromse, but that isn't. It would ask me if I wanted to keep a password, and launch the desk top, but it just stopped on chrome. It's telling a need a desktop version, which I/ve had, but it isn't working.
Also, the app on the phone doen'st fill in any pw's among those saved from the computer. Please adviusel.


1Password Version: 6.8.8
Extension Version: 4.7.0.90
OS Version: 10.13.3
Sync Type: Icloud
Referrer: forum-search:1 password extension for chrome is saying I need the desktop ap, but I do? No longer working

Comments

  • Hi @johnnyduda,

    The modification in the title is a red herring, everybody will see the same text and it's to try and help differentiate between this extension that does require the native application and the much younger 1Password X extension that can talk directly to the 1Password account server. We also saw a number of people that would download the extension without having the native application so we're hoping the title change helps a bit there too.

    Can you try a couple of quick things for me please.

    1. In 1Password select the menu option Help > Troubleshooting > Restart 1Password mini. You will need to unlock 1Password afterwards as 1Password mini is what retains the unlocked state for you. If you click on the 1Password Browser Extension button in the Chrome toolbar does the familiar 1Password mini menu appear? If it does I would hope filling and saving is restored.
    2. If that doesn't help check to see if there is a pending Chrome update. Google's support page, Update Google Chrome can help on how to check and update without loss of open tabs. Does the extension work after this?
    3. Try a restart of the Mac, launch and unlock 1Password and then open Chrome. Is there any improvement or is the extension still not working?

    If we reach this point and still no improvement I will probably want to review a diagnostic report but let's cross that bridge and how to create one if it's required.

  • Hi @littlebobbytables ,

    I am having the same issue on my Mac. I have been using 1password from my browser for almost an year and about 2 weeks ago, it started giving this trouble - on clicking the extension Icon, the browser bar just blinks and nothing happens.

    I tried all the things you mentioned and restarted everything - left 1password application running, locked and unlocked - and no change.

    Next step is to re-install Chrome. Hopefully, someone has other suggestions.

    Thanks,

  • Greetings @anuragjain,

    By any chance have you updated to 1Password 7 and by any chance do you have 1Password stored in the user Applications folder ~/Applications/ and not the system-wide one at /Applications/. If you do that will be the cause for you.

    1. Quit 1Password from the main window using the keyboard shortcut ⌃⌥⌘Q or hold down the alt key and click on the 1Password icon in the macOS menu bar; select the menu option Quit 1Password Completely.
    2. Move the 1Password application bundle from ~/Applications/ to /Applications/.
    3. Launch 1Password from its new location.
    4. Restart any open browsers.

    You should find the extension now works. If this doesn't fully resolve the issue please let me know.

  • I did try all that and it did not work. Then I found a post saying that I need a different extension called 1password X. I downloaded that and it worked fine.

  • Hello @anuragjain,

    That's not quite accurate. The 1Password X extension is a standalone extension designed to allow 1Password account users access to their account on platforms where we don't have native support e.g. ChromeOS and Linux. You can certainly use it on Mac but it isn't the extension designed to connect to the native 1Password client and so things like (auto)locking and 1Password mini are not the same.

    If you wish to get the 1Password extension designed for 1Password for Mac working let me know. If you prefer to stay with 1Password X no worries and if you have any issues with 1Password X you'll find that extension has its own dedicated section in the forums :smile:

  • Hi @littlebobbytables
    I would like to use the correct extension as I am missing its ability to fill and hit enter on login.
    If there are more tricks to be tried to mac version working, I can try them.

  • Greetings @anuragjain,

    Given we've eliminated the most likely scenarios here's what I would like you to do.

    Remove the 1Password X extension and install the normal one from Browsers - 1Password. Confirm the original issue is still present. Now create a diagnostic report and send it in to us. This link will guide you through the steps and has sections for the various supported versions of 1Password.

    How to send a 1Password diagnostics report

    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is [email protected].

    Once you've sent the report you should received an automated response from us with a ticket ID. If you can post that ID here it will help us locate the diagnostic report and we'll take a look.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file