No prompt in any browsers on my Galaxy S8 Oreo

Hi guys

I have a problem with 1password on my Galaxy S8 updated to Oreo. Until a few weeks ago it used to work pretty well prompting and autofilling logins in Samsung Internet (chrome based browser) .

Now I can visit any websites, some of which always used to work before, and the prompt doesn't appear. I've also tried to install Firefox but it's the same.

I tried restarting the phone. I tried to disable/re-enable Autofill and Accessibility settings in 1password. But it only wants to work in apps, not in browser.

Do you have any suggestions, please?

Comments

  • brentybrenty

    Team Member

    @andrea123z: Just to clarify, 1Password can only prompt when the apps themselves support this. Which browsers were you using? It may be that this isn't available in them yet.

  • @brenty thanks for replying
    I've been using Samsung Internet browser (chrome based) for months and 1password always worked.
    Samsung recently released a major upgrade for the Galaxy S8 to Android Oreo and that's when it stopped working for me.
    I tried to switch to Firefox for Android but same problem here, no prompt whatsoever from 1password.

    Is there a way for me to send you logs so you can investigate why this has stopped working? Is there any workaround?

  • brentybrenty

    Team Member

    @andrea123z: I'm nor familiar with Samsung's browser, but if they supported Google's autofill APIs (which 1Password is using) and hen broken that in an update that isn't something we can fix. Individual apps need to support that or 1Password (and other apps which register as autofill providers) cannot integrate with them. Hopefully they'll address that in an update. As far as I know Firefox has never supported this, but perhaps they will in the future. I believe that Chrome is supposed to be adding this in the near future though.

    In the mean time, as always, if you're unable to use autofill in an app, you should be able to use the 1Password Keyboard instead. I hope this helps. Be sure to let me know if you have any other questions! :)

  • Hi @brenty I made some more tests and 1password actually works in Firefox Focus on my phone. So this is not 1password problem but most likely a browser problem.
    It never worked in Firefox as you say, but I used it successfully with Samsung internet for months. Probably they've just broken the integration. Thanks for taking time to answer anyway.

  • brentybrenty

    Team Member

    Hi @brenty I made some more tests and 1password actually works in Firefox Focus on my phone. So this is not 1password problem but most likely a browser problem.

    @andrea123z: Ah, I'm sorry for not telling you that, but I didn't think the Firefox Focus thing was public yet. But you're right, it supports autofill with 1Password. I guess the cat's out of the bag there. ;)

    It never worked in Firefox as you say, but I used it successfully with Samsung internet for months. Probably they've just broken the integration. Thanks for taking time to answer anyway.

    You're welcome! I'm hopeful that, with Firefox Focus supporting it, Firefox (regular) will soon, and other browsers will follow. Thanks for mentioning it! :)

  • mverdemverde

    Team Member

    @andrea123z We're not entirely sure why Samsung Internet isn't working with accessibility at the moment. I've tested on older OS versions and the contents of the web page are available through the accessibility framework as expected. The contents are not available when repeating the same tests on Android Oreo though. Without those contents, the 1Password accessibility service is completely blind as to what is being displayed on the web page.

    Although Samsung Internet does not currently work with the 1Password accessibility service, you should be able to use Chrome, Firefox Focus, Opera, or Microsoft Edge successfully. I hope that one of those will suit your needs well.

  • This is the first I’m reading that 1Password auto-fill used to work with Samsung Internet. I thought it was not possible because of the way Samsung Internet was masquing the URL in a non standard way.

    Same thing for me. I’m on Oreo 8.0 on my Galaxy S7. 1Password auto-fill only works with Google Chrome. It doesn’t work with Samsung Internet or Firefox.

    Current version for latest stable Samsung Internet is 7.0.10.47

  • brentybrenty

    Team Member
    edited March 2018

    This is the first I’m reading that 1Password auto-fill used to work with Samsung Internet. I thought it was not possible because of the way Samsung Internet was masquing the URL in a non standard way.

    @johnny808: I know that's been an issue in the past too, so probably depends on the version.

    Same thing for me. I’m on Oreo 8.0 on my Galaxy S7. 1Password auto-fill only works with Google Chrome. It doesn’t work with Samsung Internet or Firefox.

    Check out Firefox Focus. ;)

    Current version for latest stable Samsung Internet is 7.0.10.47

    Thanks for letting us know! :)

  • I found a fix. Turns out 1Password does work in Samsung Internet.

    I use Transmission for Mac and have Remote login set up. The web interface, (when launched in the Samsung Internet app) will show the 1Password autofill pop-up. No idea why it works here and nowhere else but it got me playing with the settings and I found a fix to get it working on all sites.

    Open 1Password > Settings > Filling > Tap 'Autofill' > select 'Google' as the Autofill service which will turn off the Autofill toggle in 1Password.

    1Password will now pop-up for autofill when tapping on a username or password field in the Samsung Internet app. It will also still prompt 1Password autofill inside Android applications.

    Note: once 1Password autofill has prompted and been unlocked for a website login, you will have to manually type to search for the password you need. I assume 1Password cannot detect the website you’re on. It’s a minor annoyance but better than having no 1Password autofill at all. 1Password autofill for Android apps seems to be unaffected and still work as usual.

    My device is a Google Pixel 2 XL and the applications, (Android Pie, Samsung Internet, 1Password & Transmission) are up to date with the latest public releases (no betas) as of the date of this post.

  • brentybrenty

    Team Member

    Please don't post the same thing in multiple places. That just slows down response time for everyone and causes confusion, I'll close this so we'll continue the conversation in a single place: 1Password Accessibility with Samsung Internet not working on Android Oreo 8.0 :)

This discussion has been closed.